VectorLinux
October 23, 2014, 06:02:01 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Problems with agere SoftModem after driver installation Vector standar 5.9  (Read 2073 times)
MarcosAbel
Member
*
Posts: 6


« on: January 23, 2008, 01:26:53 pm »

Hello
I am a new vector linux users and i have problems whit one Agere SoftModem. My modem is a SV92 chipset based  modem and the driver seems to be this:
http://linmodems.technion.ac.il/packages/ltmodem/sv92/
after y download, compile and install this driver, I see one device called /dev/ttyAG3 that i suppose is my modem. Using the dialer that come with vector standar 5.9 (called nuts dialer or something like that) always says that "script failed" and the ppp utility necessary to run this dialer was not with the default installation. I installed from slackware 10.0 disc.
resuming, the kernel modules are successfully loaded (probed with lsmod| grep agr) but i can't connect any way.

Help me whit this one.

Regards.
 
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2288


« Reply #1 on: January 23, 2008, 03:54:28 pm »

Hi Marcos,

Try inserting the kernel module, then go to VasmCC, NETWORK, MODEM, AUTO. In my experience, some dialers could not access the device if a symlink to /dev/modem does not exist. Vasm will create it if it can detect your modem. If Vasm fails, try doing it manually, in a console as root issue ln -s /dev/ttyAG3
Then open Chestnut Dialer. Let start using Chestnut Dialer as root, because user doesn't have access to tty devices by default, we can work on this later. Go to Config, Default Account, and file all the necessary data. After that make a dial attempt.

Which program is missing? I have ppp installed by default. If you install Slack packages, try to find packages for the 12 version, which is the one VL is based on.

Buena suerte Wink
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
MarcosAbel
Member
*
Posts: 6


« Reply #2 on: January 25, 2008, 09:03:38 pm »

Bad news :-(
The modem utility in VasmCC don't detect the agere softmodem, in fact i get a information message that says that "A Agere/Lucent Modem is detected but can't be configured, please go to http://www.linmodem.org. Don't use this utility tho configure this kind of modems"  some like that.
I create a symbolic link to the /dev/ttyAGS3 device named /dev/modem and when y run chesnut dialer y get "scrip failed"
There is any solution to this issue?
regards.
Logged
JohnB316
Administrator
Vectorian
*****
Posts: 1346


Registered Linux User #386728


« Reply #3 on: January 27, 2008, 08:57:47 am »

You actually need to purchase the winmodem driver from linuxant.com and build it on your box. Since the Linuxant winmodem driver is proprietary, we can't distribute it, even if we wanted to. There may or may not be some old betas of the winmodem drivers floating around. A Google search will yield those. However, from what I understand about those drivers, modem speed may be restricted.

HTH,
John
Logged

VL 6.0 SOHO latest alpha on one box, VL 5.9 Lite on the other.
MarcosAbel
Member
*
Posts: 6


« Reply #4 on: January 28, 2008, 12:08:10 pm »

Hello:
After browse the linuxant.com site for a driver compatible with my agere softmodem i have seen that those drivers are for other kind of winmodems so i continue with the same problem.
Meabe is isn't helpful but the site where i download the driver that the site linmodem.org suggest is http://linmodems.technion.ac.il/packages/ltmodem/sv92/
I believe that vector is very nice and don't what to move out to another distro so I will continue waiting for answers in order to make this softmode to work.
Regards to all vectorians...
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #5 on: January 28, 2008, 12:21:13 pm »

MarcosAbel,
after you load the driver you compiled with "modprobe agrmodem" and "modprobe agrserial"
then open up chestnut dialer as root and click on the accountsconf button
then click on the new button
then click on the device tab
then click on the default button next to /dev/modem
then select /dev/ttyAG3 from the drop down list
then enter your username, password and phone number
and try to connect


HTH,
Uelsk8s
Logged
MarcosAbel
Member
*
Posts: 6


« Reply #6 on: January 28, 2008, 12:46:02 pm »

I have tried that before and always i get the "script failed" error.
regards..
Logged
MarcosAbel
Member
*
Posts: 6


« Reply #7 on: January 31, 2008, 11:28:29 am »

hello:
After seen the unofficially How to of the agere softmodem (senden to my by a linmodem discussion list user ) and try almost everything  I had decided  to make a fat32 partition for a win98 in order to use the modem with the commercial driver. I am not happy with this solution but what else I can do?.
Any way , here y post the how to for other partners that may need in the future.
Regards.

How To:
------------
This instruction set was provided by Hugo Canilli. He has thus had success with this AGRSM code requiring modem, under Linuxes: Ubuntu versions 6.10, 7.04, 7.10 and slackware 12.0. Marv Stodolsky lightly edited the text.

00) Be sure than kernel headers are installed. Under Ubuntu,
they are provided by a package pair with name format like
   linux-headers-2.6.22-14 linux-headers-2.6.22-14-generic
with 2.6.22-14-generic being the boot kernel version

0) Download the package agrsm-20070804.tar.gz to your Desktop.
Open a terminal.
Type the following:
   cd ~/Desktop
   tar xzvf agrsm-20070804.tar.gz
   cd agrsm
   make
   sudo make install
Note: the sudo is for usage in Ubuntu related Linux Distros/
For other Linuxes, first acquire Root/Adm powers with:
su - root
which will typically return a leading line with # ,
and Commands can be given without sudo:
   make install

This completes the driver installation.
The two above steps need only be repeated when a new kernel is installed,
which always requires matching drivers.

1) Next load the drivers
   sudo modprobe agrmodem
   sudo modprobe agrserial
which should announce creation of /dev/ttyAGS3

2) It is convient to create symbolic links, which dialer utilities will follow,
to the real port /dev/ttyAGS3 .
   sudo ln -s /dev/ttyAGS3 /dev/ttySAGR
   sudo ln -s /dev/ttyAGS3 /dev/modem
Check with:
   ls -l /dev/ttyAGS3 /dev/ttySAGR /dev/modem
whose output should include:
   /dev/modem   -->  /dev/ttyAGS3
   /dev/ttySAGR -->  /dev/ttyAGS3

3) The first critical functial test is:
   sudo wvdialconf /etc/wvdial.conf
which searches through potential ports for modem responses.
A success will end with a section like:
--------
ttySAGR<*1>: Modem Identifier: ATI -- Agere SoftModem Version 2.1.40
ttySAGR<*1>: Speed 4800: AT -- OK
ttySAGR<*1>: Speed 9600: AT -- OK
ttySAGR<*1>: Speed 19200: AT -- OK
ttySAGR<*1>: Speed 38400: AT -- OK
ttySAGR<*1>: Speed 57600: AT -- OK
ttySAGR<*1>: Speed 115200: AT -- OK
ttySAGR<*1>: Max speed is 115200; that should be safe.
ttySAGR<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found a modem on /dev/ttySAGR.
Modem configuration written to /etc/wvdial.conf.
ttySAGR<Info>: Speed 115200; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
--------
Then you can proceed to try a dialout (see below).

A failure will include lines like:
ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S1   S2   S3   
Sorry, no modem was detected!

In this case there are a few Remedies to try.
R1) edit your grub or lilo parameter to the kernel with the option "pci=noacpi"
For example in a Ubuntu system, gedit can be used to modify the file       /boot/grub/menu.lst
with command:
   sudo gedit /boot/grub/menu.lst

The middle of menu.lst includes sections correponding to each bootup choice like:

title      Ubuntu 7.10, kernel 2.6.22-14-generic
root      (hd0,0)
kernel      /boot/vmlinuz-2.6.22-14-generic ro quiet splash
initrd      /boot/initrd.img-2.6.22-14-generic
quiet

Make a copy of this section, and edit to:
title      Ubuntu 7.10, kernel 2.6.22-14-generic without acpi
root      (hd0,0)
kernel      /boot/vmlinuz-2.6.22-14-generic ro quiet splash pci=noacpi
initrd      /boot/initrd.img-2.6.22-14-generic
quiet

Save the edit
Restart the computer.
Among the bootup options, make the new choice:
     Ubuntu 7.10, kernel 2.6.22-14-generic without acpi
Test for modem detection, through steps  1,2 and 3
Go to the dialout test if successful.

R2) If not, try to disable the sound in the bootup BIOS.
R2a) Note a success can sometimes be achieved by moving the modem card to other PCI slot. But this option is not available on laptops.
See success report: http://linmodems.technion.ac.il/bigarch/archive-eighth/msg00304.html

Follow prior steps 1,2 and 3 for testing, retaining the bootup acpi=off parameter.

Dialout procedure
------------------
First edit in your dialout information with:
   sudo gedit /etc/wvdial.conf
In the sample below, the lines beginning with are informative, not essential.
The line order is not important.

[Dialer defaults]
# Lines begining with # are comments.
# wvdial will look for this file at  /etc/wvdial.conf
#  or  /home/LoginName/.wvdial.rc
Baud = 115200
Modem = /dev/ttySAGR3
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
#  Lack of dialtone acquisition can be due to low line voltage,
#    a common problem in Italy.
#  Try inserting a "dial without waiting": X3
#  Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0
#  In case of connection instabilities, specify a lower frequency:
#  Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=34

## Outside the USA, a country setting may be needed
# Init3 = AT+CGI=hexadecimal_country_code

ISDN = 0
Modem Type = Analog Modem
Phone =  Dialout_phone_number
# if going through a switch board, a perhaps necessary pause can produced with a comma:
# Phone = 1,Dialout_phone_number
Username = LoginName
# if Internet Provider is MSN.net, use under Linux:   MSN/LoginName
Password = YourPassWord

## If CONNECT is achieved but browsing fails, try activating the following line
# Auto DNS = yes
##    To make a logfile wvdial.out
# wvdial 2>&1 | tee wvdial.out
# #  For some Internet providers, the following line is necessary
# Stupid Mode = yes
##  for other wvdial  options, do "man wvdial" or see the documentation in
##    /usr/share/doc/wvdial/
## End wvdial.conf
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!