Please support VectorLinux!

Author Topic: Gnome-Settings-Daemon failing  (Read 2392 times)

dh2k

  • Member
  • *
  • Posts: 8
Gnome-Settings-Daemon failing
« on: February 02, 2008, 03:32:57 am »
Has anyone successfully installed freerock Gnome (www.GnomeSlackBuild.org) on VL5.9STD?

I can login to Gnome desktop but dialogue box popups advising:


There was an error starting the GNOME Settings Daemon
Some things, such as themes, sounds, or background settings may not work correctly.

The Settings Daemon restarted too many times
GNOME will still try to restart the Settings Daemon next time you log in."


Followed all advice mentioned at ubuntu forum (newuser, .gconf etc):
http://ubuntuforums.org/showthread.php?t=395456

but still not resolved this problem.

All Gnome apps work in XFCE and Gnome Destktops, but nothing is themed in Gnome hence is looks terrible..
« Last Edit: February 02, 2008, 06:53:09 am by dh2k »

JohnB316

  • Administrator
  • Vectorian
  • *****
  • Posts: 1346
  • Registered Linux User #386728
Re: Gnome-Settings-Daemon failing
« Reply #1 on: February 02, 2008, 07:03:32 pm »
You might want to go into #gsb on irc.freenode.net, which is the Freerock Gnome IRC support room, or post a message to their mailing list - the info is at http://gnomeslackbuild.org/lists/

The reason I suggest this approach is that not too many VL users use any sort of Gnome. Good luck in sorting this out.

Sorry I can't be more helpful.

John
VL 6.0 SOHO latest alpha on one box, VL 5.9 Lite on the other.

kazuya

  • Vectorite
  • ***
  • Posts: 104
Re: Gnome-Settings-Daemon failing
« Reply #2 on: February 21, 2008, 06:51:31 am »
I too am looking for gnome on this distro as well. I shall investigate and post result here. Which is more suitable to vectorlinux, dropline or freerock gnome?
Kde desktop interface is nice on VL as well.

I wonder if issues may be due to freerock gnome's requirements and dependencies conflicting somehow with gnome libs used in vl already upon installing..

kazuya

  • Vectorite
  • ***
  • Posts: 104
Re: Gnome-Settings-Daemon failing
« Reply #3 on: April 18, 2008, 07:29:53 am »
I know this is late, but i was actually able to use gnome via gsb. It installed flawlessly. Thanks for the recommendation.

Thor

  • Member
  • *
  • Posts: 6
Re: Gnome-Settings-Daemon failing
« Reply #4 on: June 04, 2008, 06:47:21 am »
Has anyone successfully installed freerock Gnome (www.GnomeSlackBuild.org) on VL5.9STD?

I can login to Gnome desktop but dialogue box popups advising:


There was an error starting the GNOME Settings Daemon
Some things, such as themes, sounds, or background settings may not work correctly.

The Settings Daemon restarted too many times
GNOME will still try to restart the Settings Daemon next time you log in."


Followed all advice mentioned at ubuntu forum (newuser, .gconf etc):
http://ubuntuforums.org/showthread.php?t=395456

but still not resolved this problem.

All Gnome apps work in XFCE and Gnome Destktops, but nothing is themed in Gnome hence is looks terrible..

The settings-daemon depends on GStreamer and GStreamer-Plugins-Base.

kc1di

  • Packager
  • Vectorian
  • ****
  • Posts: 1125
  • Morse Code Early digital mode. John 3:16
Re: Gnome-Settings-Daemon failing
« Reply #5 on: June 04, 2008, 08:07:51 am »
Has anyone successfully installed freerock Gnome (www.GnomeSlackBuild.org) on VL5.9STD?

I can login to Gnome desktop but dialogue box popups advising:


There was an error starting the GNOME Settings Daemon
Some things, such as themes, sounds, or background settings may not work correctly.

The Settings Daemon restarted too many times
GNOME will still try to restart the Settings Daemon next time you log in."


Followed all advice mentioned at ubuntu forum (newuser, .gconf etc):
http://ubuntuforums.org/showthread.php?t=395456

but still not resolved this problem.

All Gnome apps work in XFCE and Gnome Destktops, but nothing is themed in Gnome hence is looks terrible..

One of the problems you maybe running into is that VL 5.9 is based upon Slackware 12.0 and freerock Gnome is built to support only slackware 12.1.  you should be able to upgrade the dependecies you need but you will most likely have to get them from the slackware package sight. http://packages.slackware.it/
« Last Edit: June 04, 2008, 08:09:25 am by kc1di »
Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608

Thor

  • Member
  • *
  • Posts: 6
Re: Gnome-Settings-Daemon failing
« Reply #6 on: June 04, 2008, 01:07:19 pm »
My penny is on GSt lacking or compiled on another Gnome version. The slackware diff, is too small to probably have any effect.
But also make sure "liboil" is within. Preferable it should been compiled on same Gnome as the GSt or atleast the liboil should fit the running GSt.
I mention this, coz I did gnome on Slax and I separated GStreamer from the "gnome-desktop" package. Therefore I often forgot to put it back into also my own modules folder and I have ran into this issue countless times.