Author Topic: Installation error 'Cannot extract optional/X11.tlz'  (Read 4764 times)


  • Member
  • *
  • Posts: 2
Installation error 'Cannot extract optional/X11.tlz'
« on: February 04, 2008, 02:40:02 pm »

I'm trying to install VectorLinux and keep getting an error message...

Cannot extract optional/X11.tlz. Maybe the file is corrupt, or the partition is full. The current installation is in an unknown state We better abort and reinstall from the start

The PC is an old Dell Inspriron 3500 laptop with a 400MHz Celeron, 128Mb RAM  and a 6.4Gb drive.
I have tried various partitioning options, but keep getting the same error. This is the latest...

/dev/hd1                  swap  350Mb
/dev/hd2   bootable    linux  3000Mb
/dev/hd3                  linux   3000Mb (ish)

Any suggestions? I'm stuck!!



  • Vectorian
  • ****
  • Posts: 1132
Re: Installation error 'Cannot extract optional/X11.tlz'
« Reply #1 on: February 04, 2008, 03:55:00 pm »
There's certainly a possibility that your download of the ISO was corrupt, or at least, not completely correct.  Did you check the ISO against the md5sum?  Download managers have a higher potential of corrupting the download.  I would start by making sure you got a good download.

Next, it's _possible_ there is not enough room on / (root) for all of VL59.  My instinct says that there is, but I don't know the final installation size of a full VL59 installation which is why I mention the possibility.

I feel that the download may have been bad and I would start by verifying the md5sum.  You can also have the installer verify the cd contents during installatioin.


  • Member
  • *
  • Posts: 2
Re: Installation error 'Cannot extract optional/X11.tlz'
« Reply #2 on: February 05, 2008, 04:55:27 am »
I got the ISO from a DVD with Linux Format mag.
It's burnt on a rewritable CD.

I'll check that checksum!



  • Global Moderator
  • Vectorian
  • *****
  • Posts: 729
Re: Installation error 'Cannot extract optional/X11.tlz'
« Reply #3 on: February 22, 2008, 03:02:14 pm »
Often this is cause by corrupted download, bad build, or incompatible media to your drive.
Since you got this from a multi distro DVD we cannot verify the quality of it, and that makes it almost impossible to properly support it.
 I would recommend getting the ISO from the VectorLinux web site, and make a fresh burn. Take care in selecting media that is compatible with your drive.


  • Member
  • *
  • Posts: 3
Re: Installation error 'Cannot extract optional/X11.tlz'
« Reply #4 on: February 27, 2008, 08:46:58 am »
I had a similar issue on my install of VL 5.9Std Gold.
* Ubuntu installed no problem, same CD media brand.
* Redownloaded VL5.9 iso, checked md5
* Burned to new CD, checked burn when done.
* Hardware:  HP Pavillion a1000y, 512MB RAM, install to 6G part., 300MB swap
* Tried several times, selecting less options each time.
* My 1st guess is either the swap or the / partition is too small, but this is a dual boot with XP and others will very upset if I mess up XP so I'm not resizing.
* 2nd guess:  VL5.9 and CD/DVD drive hardware issue.
* VL 5.9 installed fine on my Dell GX150, 1GHz,  256MB RAM, / 7.5G  /home 9G, swap 2.5G