VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Setting locale?  (Read 2267 times)

Stokstaartje

  • Member
  • *
  • Posts: 36
Setting locale?
« on: February 06, 2008, 01:40:15 am »

First of all, I might be looking for the wrong solution...

When ripping cd's with K3b, sometimes the names of the artist/songs come out kind of garbled, e.g. Björk becomes Bjvrk. That in itself is not a big problem. But when trying to move/delete these files/directories the problems arise as these files are not found by the name shown on the screen.

rm -r Bjvrk
no such file or directory

I suspect that this all starts with not having the right locale, otherwise the right name would have shown? Correct or not?

And if correct, is it a simple matter of setting the correct locale?

And another if, if that is the case, how do I set the right locale?
Logged
----------------------------------
I hope I didn't brain my damage!

Stokstaartje

  • Member
  • *
  • Posts: 36
Re: Setting locale?
« Reply #1 on: February 06, 2008, 03:22:58 am »

Even more guessing:

Maybe it is not the locale, because I prefer having the english language as is. But maybe it is the character encoding: Do I need unicode support? utf-8? And how should I go about getting that installed?

Logged
----------------------------------
I hope I didn't brain my damage!

kukibl

  • Guest
Re: Setting locale?
« Reply #2 on: February 06, 2008, 04:37:01 am »

Well, if you want to keep US locale, but include utf-8 support do next:

-edit as root /etc/profile.d/lang.sh with your favourite editor

-comment this line with # sign

Code: [Select]
export LANG=en_US
-uncomment this line (a little below):

Code: [Select]
export LANG=en_US.UTF-8
That should solve problem for you. ;)

Else, you can set up locale for your language. Just type locale -a command, find line that suites your language and put it in edited file by replacing current setting. In example, for my language (Serbian) I would replace export LANG=en_US.UTF-8 with export LANG=sr_CS.utf8.
« Last Edit: February 06, 2008, 04:40:44 am by kukibl »
Logged

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: Setting locale?
« Reply #3 on: March 12, 2012, 12:31:53 am »

Thanks.  I was looking for how the locale could be changed.
Logged
I am using VL7.0 standard with XFCE