Please support VectorLinux!

Author Topic: 080131 xine-lib-1.1.10  (Read 1222 times)

exeterdad

  • Moderator
  • Vectorian
  • *****
  • Posts: 2046
080131 xine-lib-1.1.10
« on: January 31, 2008, 06:28:33 pm »
Dweeberkitty Has packaged xine-lib-1.1.10 for VL5.9

Sources:
http://vectorlinux.osuosl.org/veclinux-5.9/source/testing/libs/xine-lib/
Quote
xine-lib: xine-lib (xine multimedia playback engine libraries)
xine-lib:
xine-lib: xine-lib is a free (GPL licensed) high-performance multimedia
xine-lib: playback engine.  The xine shared libraries are used by xine-ui (and
xine-lib: other media players and multimedia applications) for smooth video
xine-lib: processing and playback of multimedia streams such as movies, radio
xine-lib: and TV network streams, DVDs, and VCDs.
xine-lib:
xine-lib: License: GPL
xine-lib: Authors: Many, see docs
xine-lib: Website: http://xinehq.de/
xine-lib:

Please leave feedback whether or not this package works for you in this thread.

Edited by JohnB316 only to fix the URL for the source tree.

Edited by exeterdad: Thanks John, I just discovered I placed everything in x-apps rather then libs.  All fixed and URL re-edited (is that a word?) to the correct location.
« Last Edit: February 01, 2008, 03:53:40 pm by exeterdad »

JohnB316

  • Administrator
  • Vectorian
  • *****
  • Posts: 1346
  • Registered Linux User #386728
Re: 080131 xine-lib-1.1.10
« Reply #1 on: January 31, 2008, 06:48:57 pm »
As I posted in the Packagers board, I became aware of an error in xine when Compiz was being used as the window manager under xfce4. Here is the error message I got with the xine-lib-1.1.8 in the VL 5.9 final:

Code: [Select]
john:$ This is xine (X11 gui) - a free video player v0.99.5.
(c) 2000-2007 The xine Team.
xiTK WARNING(_x_error_handler:258): X error received: 'BadWindow (invalid Window parameter)'
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  20 (X_GetProperty)
  Resource id in failed request:  0x1a00052
  Serial number of failed request:  43
  Current serial number in output stream:  43

A Google Linux search revealed that this is a known issue with xine running under compiz and xfce4. A patch was posted on the xine-cvs mailing list at http://sourceforge.net/mailarchive/message.php?msg_name=E1Iye9T-0007Dj-5I%40sc8-pr-cvs10.sourceforge.net

Dweeberkitty was kind enough to build the latest xine-lib, but the patch for compiz apparently didn't make it out of cvs, as I got the same error message with xine-lib-1.1.10 under compiz and xfce4.

HTH something,
John
VL 6.0 SOHO latest alpha on one box, VL 5.9 Lite on the other.

toothandnail

  • Moderator
  • Vectorian
  • *****
  • Posts: 2527
Re: 080131 xine-lib-1.1.10
« Reply #2 on: February 01, 2008, 07:25:44 pm »
Installed and works fine here (no compwiz-fusion...).

Sound quality is better than the older version.

paul.

JohnB316

  • Administrator
  • Vectorian
  • *****
  • Posts: 1346
  • Registered Linux User #386728
Re: 080131 xine-lib-1.1.10
« Reply #3 on: February 01, 2008, 07:46:10 pm »
Problem with using gslapt to get xine-lib: gslapt complained about the orbit issue. Has a fixed package of orbit been released? If so, EVERYTHING that has orbit as a dependency needs rebuilding if it's built against the incorrectly named package.

Thanks,
John
VL 6.0 SOHO latest alpha on one box, VL 5.9 Lite on the other.

florut

  • Member
  • *
  • Posts: 34
    • Personal Website
Re: 080131 xine-lib-1.1.10
« Reply #4 on: February 09, 2008, 03:59:37 pm »
Working fine here too. gslapt complained about the orbit issue too...
Proudly running VL 5.9 DLX GOLD 2.6.22.14 + KDE 3.8
...on my ASUS laptop with Pentium-M @1.8Ghz + ATI Mobility X700 + Intel Wireless 2200BG