VectorLinux
November 23, 2014, 10:15:38 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Where are LILO options?  (Read 8218 times)
Sivatheja
Vectorite
***
Posts: 156



WWW
« on: February 08, 2008, 08:51:10 pm »

Hi,

My machine is not dual boot and is VL only. Right now I'm getting LILO screen which has a 2 minute count down. I want to reduce this to 10 sec.
Preferably there should be no LILO in the start, and must directly boot to GUI Linux.

Any help?

Is there anything like windows where one can go to advanced boot options on 'F8' in Linux?

Thanks in advance,
Sivatheja.
« Last Edit: February 08, 2008, 08:53:18 pm by sivatheja » Logged

Full Linux Machine - Vector Linux 5.9 STD Gold, Intel - 1.79 GHz, 1Gb RAM, 60GB HDD
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #1 on: February 08, 2008, 10:18:07 pm »

You want to edit the file /etc/lilo.conf and change the line "timeout" to "timeout = 100" (that tenths of second making it 10 seconds). Then as root you need to run the command "lilo -v" to rewrite the map file.

To default to Linux, in the same file above, make sure the line "default = whatever the linux stanza below it is called".

Boot options can be passed to the kernel at boot by pressing the tab key once when you are in the lilo screen. But you need to know what options you want to pass. That info is found in "man lilo.conf" and the entire list is in /usr/src/`uname -r`/Documentation/kernel-parapmeters.txt. There are a whole mess of them.

Normally though, repair of a linux system, if that is what you are getting at, is usually accomplished by going into "linux-tui" from the lilo screen and working there, or by running a Live Linux CD and mounting the partitions you might need to work on from the Live CD.
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
Freston
Vectorite
***
Posts: 165


« Reply #2 on: February 09, 2008, 06:49:52 am »

Quote from: sivatheja
Preferably there should be no LILO in the start, and must directly boot to GUI Linux.
I wouldn't recommend that because there can always be a cause where you want to boot into a textual environment.

That said, if you use the method that lagagnon described to set lilo to 20 (= 2 seconds) you will greatly improve default boot time and yet have the possibility to boot into textual mode if there's a need for that. It's your call... but I feel this method gives the best from both worlds.
Logged
Sivatheja
Vectorite
***
Posts: 156



WWW
« Reply #3 on: February 09, 2008, 08:26:10 pm »

You want to edit the file /etc/lilo.conf and change the line "timeout" to "timeout = 100" (that tenths of second making it 10 seconds). Then as root you need to run the command "lilo -v" to rewrite the map file.

To default to Linux, in the same file above, make sure the line "default = whatever the linux stanza below it is called".

Boot options can be passed to the kernel at boot by pressing the tab key once when you are in the lilo screen. But you need to know what options you want to pass. That info is found in "man lilo.conf" and the entire list is in /usr/src/`uname -r`/Documentation/kernel-parapmeters.txt. There are a whole mess of them.

Normally though, repair of a linux system, if that is what you are getting at, is usually accomplished by going into "linux-tui" from the lilo screen and working there, or by running a Live Linux CD and mounting the partitions you might need to work on from the Live CD.

Thanks for the inputs! It worked Smiley
« Last Edit: February 09, 2008, 08:38:48 pm by sivatheja » Logged

Full Linux Machine - Vector Linux 5.9 STD Gold, Intel - 1.79 GHz, 1Gb RAM, 60GB HDD
funky_uncle
Member
*
Posts: 6


« Reply #4 on: May 03, 2009, 04:00:06 pm »

You want to edit the file /etc/lilo.conf and change the line "timeout" to "timeout = 100" (that tenths of second making it 10 seconds). Then as root you need to run the command "lilo -v" to rewrite the map file.
Here's a dumb question, but I didn't find the answer by searching the forums, so... how exactly does one edit lilo.conf? I can open it in medit, and make changes, but I'm denied permission to save it. Also, typing lilo in the terminal just gives me "command not found". I'm running VL 5.9 live (I've already installed it to disk, but I can't get past the grub ("error 15") so I'm trying to fix it from the live CD.
Logged
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #5 on: May 03, 2009, 04:19:34 pm »

You need to be root (system administrator) to edit Unix/Linux systems files. In a terminal type "su" then enter your root password. You can now edit /etc/lilo.conf. You must then run the command "lilo -v" (also as root) after editing the file, in order to write a new image.
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
funky_uncle
Member
*
Posts: 6


« Reply #6 on: May 03, 2009, 04:38:26 pm »

You need to be root (system administrator) to edit Unix/Linux systems files. In a terminal type "su" then enter your root password. You can now edit /etc/lilo.conf. You must then run the command "lilo -v" (also as root) after editing the file, in order to write a new image.
But going su in the terminal doesn't give me root privileges in the GUI, apparently. I'm trying to edit the file with medit. I see there's an editor in the terminal called nano, but it's not exactly intuitive... but I did manage to change the line that says boot=/dev/sda to boot=dev/sda1, because running the live CD, /dev/sda doesn't exist. The partitions start at /sda1. But I get the same problem, GRUB error 15.
*scratches head*
« Last Edit: May 03, 2009, 04:58:24 pm by funky_uncle » Logged
nightflier
Administrator
Vectorian
*****
Posts: 4029



« Reply #7 on: May 03, 2009, 05:53:46 pm »

Your "su" powers only live within the terminal where you enter your root password. The editor needs to be launched from within it. Launching a graphical editor may not work, that's why many of us prefer the text based versions. I like "mcedit", which I find a little more intuitive than nano.

LILO and GRUB are separate and different. If you installed the 5.9 Live version with GRUB, you need to edit the file "/boot/grub/menu.lst" to change the boot options.
Logged
funky_uncle
Member
*
Posts: 6


« Reply #8 on: May 04, 2009, 09:09:15 am »

Your "su" powers only live within the terminal where you enter your root password. The editor needs to be launched from within it. Launching a graphical editor may not work, that's why many of us prefer the text based versions. I like "mcedit", which I find a little more intuitive than nano.

LILO and GRUB are separate and different. If you installed the 5.9 Live version with GRUB, you need to edit the file "/boot/grub/menu.lst" to change the boot options.
Ah, I found the lilo.config file right away so I just assumed that I had lilo installed. I'll look for stuff about menu.lst instead then. Thanks for the info!
Logged
funky_uncle
Member
*
Posts: 6


« Reply #9 on: May 04, 2009, 03:05:17 pm »

Only I can't seem to find menu.lst, so I guess I don't have GRUB after all. Or do I? Confused, now.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4029



« Reply #10 on: May 04, 2009, 05:31:59 pm »

A couple of scenarios come to mind. Did you have another Linux distro with GRUB installed before? Some times LILO can't overwrite it. Another possibility is that GRUB did not install correctly from the live session.

My recommendation would be to try the traditional version instead of the live one.
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #11 on: May 04, 2009, 08:22:25 pm »

I'm running VL 5.9 live (I've already installed it to disk, but I can't get past the grub ("error 15") so I'm trying to fix it from the live CD.

Is there a reason you're running VL 5.9 Live (installed to disk)? Vector's Live versions aren't optimized for a permanent on-disk installation. VL 6 Standard has very significant improvements and newer versions of programs and you would do well to install it instead of 5.9 Live, barring some need we don't know about.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
funky_uncle
Member
*
Posts: 6


« Reply #12 on: May 05, 2009, 12:35:30 am »

I tried installing 6.0 but it didn't work for some reason. I'll try again, I have this Eee I'm experimenting on. There was nothing on the disk from before, I made three ext2 partitions (two for linux distros and one for files), plus some swap space. The installation process seemed to go without problems. I've been running the live edition from a pendrive (used UNetbooting to get it on the pendrive).
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!