VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Linksys wrt54g PCI wireless question  (Read 1593 times)

topgrey

  • Member
  • *
  • Posts: 11
Linksys wrt54g PCI wireless question
« on: February 03, 2008, 08:34:32 pm »

I hate to open a new topic on this but I've hit a wall........

Ok, I have settled on using ndiswrapper to manage the wireless driver for my card.  lspci -n returns:

00:09.0 0280:  1814:0301   for the card. (lspci returns 00:09.0)

ndiswrapper -l returns (i've deleted drivers i believe uneeded from this list to save time) :

rt61  :  driver installed
             device (1814:0301) present

cat etc/modprobe.conf returns:

alias wlan0 ndiswrapper
alias etho sis900

From what I understand VL is recognizing the driver (or ndiswrapper is, anyway) but it does not see the card at all.
I've followed multiple HOWTOs and got this far, thought I had it all wrapped up, and.....Nope....

At this point I can't figure out what part of the HOWTOs i've misunderstood.  Any other information I need to post just let me know.
All help would be greatly appreciated as currently I'm having to share my connection from my laptop in order to get my VL box online. 





Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Linksys wrt54g PCI wireless question
« Reply #1 on: February 03, 2008, 10:39:14 pm »

First what VL version are you using.

Did you modprobe ndiswrapper
to load the module.

You can check by using lsmod and looking for
ndiswrapper.

If it is there then the only thing left is to finish
the how-to.

HTH

Bigpaws
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Linksys wrt54g PCI wireless question
« Reply #2 on: February 04, 2008, 11:28:34 am »

Your topic references a router model, not a wireless card.  Perhaps you meant WPC54g?

Regardless, I use a linksys wrt54gs router and linksys wpc54gs (pcmcia) card (broadcom chipset); of course, the wireles card is the only thing that needs to be configured.  I've used it under vl58 and am currently using under vl59 with WPA security (had previously used WEP as well).  It works as expected without any problems to speak of.  I use the default bcm43xx driver, wpa_supplicant for security support, and wifi-radar for connecting.  If any of this sounds similar to your setup then perhaps I can help out.  Just need to know your version of VL, and which wireless card you're using (brand, model, revision/version number).

Cheers!
Logged

topgrey

  • Member
  • *
  • Posts: 11
Re: Linksys wrt54g PCI wireless question
« Reply #3 on: February 04, 2008, 06:08:57 pm »

My apologies, I guess VL version would help!!!  Yes, it is a Linksys 54g PCI card (without speedboost).  It's version 4.1 which uses the Ralink RT61/2561 etc. chipset.  I'm running VL 5.8 SOHO.  I'll give the suggestions a try although I'm pretty sure I did modprobe ndiswrapper.  I did not use lsmod to check for it as I did not know to.  That's why I love the forums.  The whole purpose for this was so I could start learning to use and love linux and it's been fun so far.  I'll give the suggestions a try from bigpaws and let you know what I find.  Thanks for replying.
**************
It just occurred to me what a possibility might be.  I'm trying to use ndiswrapper with the Ralink rt 61 driver created especially for linux users.  I have available the .inf and .sys files for windows.  I seem to recall though that on the ndiswrapper card list that it noted to use the ralink drivers.  A bit confusing because if the rt 61 driver was created for use on linux boxes why would I use ndiswrapper at all? 
« Last Edit: February 04, 2008, 06:15:44 pm by topgrey »
Logged

topgrey

  • Member
  • *
  • Posts: 11
Re: Linksys wrt54g PCI wireless question
« Reply #4 on: February 04, 2008, 07:55:44 pm »

Ok, lsmod shows ndiswrapper as the very first module loaded.  I also have the wireless applet running and it shows a decent connection.  I tried configuring using iwconfig (using hte man pages) and then tried using the control center for networking.  I can set my essid and my wep (I know, wpa is next after i get connected) and have set it to dhcp.  No ip address is given and still no surfing.  When i run lsmod ndiswrapper shows a 0 (zero) next as the last entry in the line.  Also, I exited X using init 2, ran vasm as root and di the autodetect feature.  During this somehow I've screwed up my video.  When I run init 4 the monitor displays a rainbowed background and, it seems, no backlight (lcd monitor).  I think I can fix that, however, but I'm not sure exactly how.  I told it to use the nVdia legacy drivers first and when that farked the monitor i went back and tried using the nv drivers.  Probably have to reinstall the nVidia drivers again to resolve.  Learning hurts.
Logged

topgrey

  • Member
  • *
  • Posts: 11
Re: Linksys wrt54g PCI wireless question
« Reply #5 on: February 11, 2008, 07:29:12 pm »

Thanks BigPaws and Newtor.  Got the wireless running using ndiswrapper.  Found out what I was doing wrong (using the network features in the control center...) and wanted to thank you again for your help. 

Sorry it took so long to get back and give thanks. 
Logged