VectorLinux
September 18, 2014, 05:25:23 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: installing swig from source  (Read 3019 times)
bad_gui
Member
*
Posts: 61


« on: February 15, 2008, 07:03:33 am »

I downloaded swig-1.3.33 and configure and make went without major problems
I'm trying to use checkinstall so that I have a way to uninstall this later.

However installation fails with this error:
Quote
root:# checkinstall
checkinstall 1.6.0, Copyright 2002 Felipe Eduardo Sanchez Diaz Duran
           This software is released under the GNU GPL.
********************************************
**** Slackware package creation selected ***
********************************************
This package will be built according to these values:
1 -  Summary: [ swig-1.3.33 ]
2 -  Name:    [ swig ]
3 -  Version: [ 1.3.33 ]
4 -  Release: [ 1 ]
5 -  License: [ GPL ]
6 -  Group:   [ Applications/System ]
7 -  Architecture: [ i386 ]
8 -  Source location: [ swig-1.3.33 ]
9 -  Alternate source location: [  ]
10 - Requires: [  ]
Enter a number to change any of them or press ENTER to continue:
Installing with make install...
========================= Installation results ===========================
Installing SWIG executable
Installing /usr/local/bin/swig
chmod: changing permissions of `/usr/local/bin/_inst.27561_': No such file or directory
make: *** [install-main] Error 1
****  Installation failed. Aborting package creation.
Cleaning up...OK
Bye.
If I touch /usr/local/bin/_inst.27561_ and try checkinstall again, I get the same error with
a larger number for this filename.  Any ideas what is wrong?
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #1 on: February 15, 2008, 07:11:11 am »

try running "checkinstall -L --fstrans=no"
Logged
bad_gui
Member
*
Posts: 61


« Reply #2 on: February 15, 2008, 07:14:20 am »

Using grep -R _inst. *  I found this entry among the long list:

Tools/config/install-sh:    dsttmp=$dstdir/_inst.$$_

Here is some of the code around that command

Quote
    # Make a couple of temp file names in the proper directory.
    dsttmp=$dstdir/_inst.$$_
    rmtmp=$dstdir/_rm.$$_

    # Trap to clean up those temp files at exit.
    trap 'ret=$?; rm -f "$dsttmp" "$rmtmp" && exit $ret' 0

    # Copy the file name to the temp name.
    (umask $cp_umask && $doit_exec $cpprog "$src" "$dsttmp") &&

    # and set any options; do chmod last to preserve setuid bits.
    #
    # If any of these fail, we abort the whole thing.  If we want to
    # ignore errors from any of these, just make sure not to ignore
    # errors from the above "$doit $cpprog $src $dsttmp" command.
    #
    { test -z "$chowncmd" || $doit $chowncmd "$dsttmp"; } \
      && { test -z "$chgrpcmd" || $doit $chgrpcmd "$dsttmp"; } \
      && { test -z "$stripcmd" || $doit $stripcmd "$dsttmp"; } \
      && { test -z "$chmodcmd" || $doit $chmodcmd $mode "$dsttmp"; } &&



Logged
bad_gui
Member
*
Posts: 61


« Reply #3 on: February 15, 2008, 07:21:05 am »

What does  checkinstall -L --fstrans=no  do exactly?  There is no man page.

It seemed to work but then at the end I get a warning but the package seems
to have been installed:

usr/local/share/swig/1.3.33/typemaps/valtypes.swg
usr/local/share/swig/1.3.33/typemaps/void.swg
usr/local/share/swig/1.3.33/typemaps/wstring.swg
usr/local/share/swig/1.3.33/uffi/
usr/local/share/swig/1.3.33/uffi/uffi.swg
usr/local/share/swig/1.3.33/wchar.i
usr/local/share/swig/1.3.33/windows.i
install/
install/doinst.sh
install/slack-desc
install/slack-required
tar-1.13: swig-1.3.33-i386-1.tar is the archive; not dumped
Compressing swig-1.3.33-i386-1.tlz ...
Package creation swig-1.3.33-i386-1.tlz complete.
OK
NOTE: The package will not be installed.
Erasing temporary files...OK
Deleting temp dir...OK
**********************************************************************
 Done. The new package has been saved to
 /home/progs/swig-1.3.33/swig-1.3.33-i386-1.tlz
 You can install it in your system anytime using:
      installpkg swig-1.3.33-i386-1.tlz
**********************************************************************




Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #4 on: February 15, 2008, 08:00:25 am »

from http://www.asic-linux.com.mx/~izto/checkinstall/
Quote
Recent news

    * Aug 3rd, 2007

      An incompatibility with the newest coreutils seems to have bitten a bunch of people, specially users of the recently released Slackware 12. A new checkinstall version will be released soon which will address this issue. In the meantime, as a workaround you can use the "--fstrans=no" command line flag when invoking checkinstall.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!