VectorLinux
October 23, 2014, 04:38:55 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Kqemu in VL5.8 SoHo  (Read 1106 times)
tortipede
Member
*
Posts: 9



« on: March 15, 2008, 09:50:45 am »

I'm trying to get kqemu working so that I can use some Win 9x software that either doesn't play nicely or (because of DRM-style stuff) doesn't play at all with Wine. I tried VirtualBox, but it wasn't great; I tried VMWare, but the install script couldn't find /bin/sh, which was a bit bizarre. Qemu seems much better, but still a bit slow, which is where kqemu comes in.

Problems: the version of kqemu that Gslapt finds for VL5.8 is kqemu_2.6.18.5--1.3.0pre11-i586-1vl58.tlz, which installs in /lib/modules/2.6.18.5/misc -- but the kernel shipped with VL5.8SoHo is 2.6.20.3. Unsurprisingly, modprobe can't find it. In case the earlier version of kqemu.ko worked anyway, I tried soft-linking this to /lib/modules/2.6.20 etc. -- but I still just get "modprobe kqemu FATAL: Module kqemu not found."

So I tried installing from source (kqemu-1.3.0pre11.tar.gz, downloaded from the qemu site). The configure script comes back with this:
DrSmile://tmp/kqemu-1.3.0pre11
richard:$ ./configure
big/little test failed
Source path       /tmp/kqemu-1.3.0pre11
C compiler        gcc
Host C compiler   gcc
make              make
host CPU          i386

kernel sources    /lib/modules/2.6.20.3/build
kbuild type       2.6

I've tried searching on this forum (amongst many, many other places), and all I've come up with is http://www.vectorlinux.com/forum2/index.php?topic=4380.msg28706#msg28706 which clearly implies that kqemu ought to be working... but it still isn't.

Ideas?

TIA Smiley
« Last Edit: March 16, 2008, 05:15:31 am by tortipede » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!