VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Mouse trouble on HP Compaq nc6000 (solved)  (Read 9012 times)

sledgehammer

  • Vectorian
  • ****
  • Posts: 1465
Mouse trouble on HP Compaq nc6000 (solved)
« on: February 27, 2008, 12:57:19 am »

The mouse jumps.  It has a mouse pad which, I believe, is synaptics.  I downloaded and installed the synaptics-0.1.4.6 driver, but it doesn't seem to make any difference.  the synaptics program provides modifications to /etc/X11/XF86Config-4.in, which I made.  I am thinking that the machine gets its mouse configuration from some other file.  If this is anywhere near right thinking, does anyone know how I can make the mouse use /etc/X11/XF86Config-4.in?

Quote
bash-3.1$ cat /proc/bus/input/devices
I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/class/input/input0
H: Handlers=kbd event0
B: EV=120013
B: KEY=4 2000000 3802078 f840d001 feffffdf ffefffff ffffffff fffffffe
B: MSC=10
B: LED=7

I: Bus=0011 Vendor=0002 Product=0007 Version=0000
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio4/input0
S: Sysfs=/class/input/input1
H: Handlers=mouse0 event1
B: EV=b
B: KEY=6420 0 70000 0 0 0 0 0 0 0 0
B: ABS=11000003

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=synaptics-pt/serio0/input0
S: Sysfs=/class/input/input2
H: Handlers=mouse1 event2
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0010 Vendor=001f Product=0001 Version=0100
N: Name="PC Speaker"
P: Phys=isa0061/input0
S: Sysfs=/class/input/input3
H: Handlers=kbd event3
B: EV=40001
B: SND=6

Thx

John
« Last Edit: March 03, 2008, 08:15:35 am by lawquest »
Logged
VL7.0 xfce4 Samsung RF511

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: Mouse trouble on HP Compaq nc6000
« Reply #1 on: February 27, 2008, 04:44:00 am »

Please post your /etc/X11/xorg.conf

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Mouse trouble on HP Compaq nc6000
« Reply #2 on: February 27, 2008, 04:45:13 am »

This is a problem unless using Vector version 4.0. After that
the file should be /etc/X11/xorg.conf

HTH

Bigpaws
Logged

sledgehammer

  • Vectorian
  • ****
  • Posts: 1465
Re: Mouse trouble on HP Compaq nc6000
« Reply #3 on: February 27, 2008, 08:03:02 am »

Here is /etc/X11/xorg.conf:

Quote
### A Minimum X-Window Configuration With VESA driver
### Originally generated using "Xorg -configure" then edited by hand
### PLEASE DO NOT MODIFY OR REMOVE THIS FILE
#
# This is a working xorg.conf that can be configured by vxconf
# Items that might be modified are marked like this
#     item  value           ## ITEM_MARKING
# Please, do not play with the marking. Anything else is your's.
# Thanks
#
# Eko M. Budi, for Vector Linux
#

Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   RgbPath      "/usr/X11R6/lib/X11/rgb"
   ModulePath   "/usr/X11R6/lib/modules"
   FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
   FontPath     "/usr/X11R6/lib/X11/fonts/TTF/"
   FontPath     "/usr/X11R6/lib/X11/fonts/Speedo/"
   FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
   FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
   FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
   FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
   Load  "record"
   Load  "extmod"
   Load  "dbe"
   Load  "dri"
   Load  "glx"
   Load  "xtrap"
   Load  "freetype"
   Load  "type1"
   Load  "speedo"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"                 ## KEYBOARD_DRIVER
    Option      "CoreKeyboard"
    Option      "XkbModel"  "pc101"   ## KEYBOARD_MODEL
    Option      "XkbLayout" "us"      ## KEYBOARD_LAYOUT
    Option      "XkbVariant" ""       ## KEYBOARD_VARIANT
#    Option      "XkbOptions" ""      ## KEYBOARD_OPTIONS
EndSection

Section "InputDevice"
    Identifier "Mouse0"
    Driver     "mouse"
    Option     "Device" "/dev/mouse"

# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using auto.
# Otherwise set it manually to:
#    Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2
#    Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2
#    MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse
#    ThinkingMouse ThinkingMousePS/2 Xqueue
    Option  "Protocol"  "PS/2"   ## MOUSE_PROTOCOL

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.
#    Option "BaudRate"      "9600"
#    Option "SampleRate"   "150"
# ChordMiddle is an option for some 3-button Logitech mice
#    Option "ChordMiddle"

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)
    Option "Emulate3Buttons"      ## MOUSE_E3BUTTONS
#    Option "Emulate3Timeout"    "50"           

# Settings for newer IMPS/2 mouse (with wheel)
#    Option "ZAxisMapping" ""    ## MOUSE_ZAXISMAPPING
#    Option "Buttons" ""    ## MOUSE_BUTTONS
#    Option "SendCoreEvents"      ## MOUSE_SENDCOREEVENTS

EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Generic"   ## MONITOR_VENDOR
    ModelName    "Generic"   ## MONITOR_MODEL
    Option    "DPMS"
#    HorizSync      ## MONITOR_HSYNCH
#    VertRefresh      ## MONITOR_VREFRESH
EndSection

Section "Device"
    Identifier  "Card0"
    Driver      "vesa"       ## DEVICE_DRIVER
    VendorName  "NoName"     ## DEVICE_VENDOR
    BoardName   "Generic"    ## DEVICE_BOARD

#    Option "swcursor" "true"    ## DEVICE_SWCURSOR
#    BusID  "PCI:1:0:0"    ## DEVICE_BUSID

EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    DefaultDepth 24   ## SCREEN_DEPTH
    SubSection "Display"
   Depth     1
       Modes "1024x768" "800x600" "640x480"  ## SCREEN_MODES
    EndSubSection
    SubSection "Display"
   Depth     4
   Modes "1024x768" "800x600" "640x480"  ## SCREEN_MODES
    EndSubSection
    SubSection "Display"
   Depth     8
   Modes "1024x768" "800x600" "640x480"  ## SCREEN_MODES
    EndSubSection
    SubSection "Display"
   Depth     15
   Modes "1024x768" "800x600" "640x480"  ## SCREEN_MODES
    EndSubSection
    SubSection "Display"
   Depth     16
   Modes "1024x768" "800x600" "640x480"  ## SCREEN_MODES
    EndSubSection
    SubSection "Display"
   Depth     24
   Modes "1024x768" "800x600" "640x480"  ## SCREEN_MODES
    EndSubSection
    SubSection "Display"
   Depth     32
   Modes "1024x768" "800x600" "640x480"  ## SCREEN_MODES
    EndSubSection
EndSection

# DRI enabled by default
# if the card does not capable, X simply ignores this, hopefully ;-)
Section "DRI"
    Mode 0666
EndSection


I use vector 5.8.  However, as I use this machine only for backup, I tried 5.9 on it a couple of months ago, and it did not seem to help.  So I reinstalled 5.8.

John
Logged
VL7.0 xfce4 Samsung RF511

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: Mouse trouble on HP Compaq nc6000
« Reply #4 on: February 27, 2008, 09:11:42 am »

You may have the drivers installed, but your xorg.conf doesn't look like it's using it at all..
I've lost ssh access to my laptop, but I've setup synaptics using this gentoo howto... it's not that hard to follow
http://gentoo-wiki.com/HARDWARE_Synaptics_Touchpad
HTH

sledgehammer

  • Vectorian
  • ****
  • Posts: 1465
Re: Mouse trouble on HP Compaq nc6000
« Reply #5 on: February 27, 2008, 10:21:13 am »

Thanks.  I keep the nc6000 at home and will try it when I get home tonight.  I gather that whatever synaptics changes I make have to be in /etc/X11/xorg.conf rather than in /etc/X11/XF86Config-4.in.

John
Logged
VL7.0 xfce4 Samsung RF511

sledgehammer

  • Vectorian
  • ****
  • Posts: 1465
Re: Mouse trouble on HP Compaq nc6000
« Reply #6 on: February 28, 2008, 10:16:23 pm »

I'm not going to mark this threat "solved" for a few days, as I want to see if it (decent mouse) lasts.  But I can say that MOE-lnx had the right idea.  I moved all the synaptics stuff from tc/X11/XF86Config-4.in. to xorg.conf and the mouse now seems to work fine. For a whole day.  It has never done that before.  Would work fine for a couple of hours, then revert to jumping.  Now, after about 30 hours with no jumping, I am concluding that it is fixed.

Thx

John
Logged
VL7.0 xfce4 Samsung RF511

sledgehammer

  • Vectorian
  • ****
  • Posts: 1465
Re: Mouse trouble on HP Compaq nc6000 (solved)
« Reply #7 on: March 03, 2008, 08:19:43 am »

The mouse on the nc6000 hasn't  jumped for 3 days running, so I am marking this thread solved.  The basic problem was that I was putting the synaptics code in the wrong file.  It needed to go into xorg.conf.  Once having done that, it got better, but was still quirky. I then changed the refresh rate and the horizontal sync in xorg.conf.  Basically, I took the horizontal sync from xorg.conf in my omnibook, and set the refresh rate to 60.  That seems to work.

Thanks to all.

John
Logged
VL7.0 xfce4 Samsung RF511

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: Mouse trouble on HP Compaq nc6000 (solved)
« Reply #8 on: March 03, 2008, 08:41:47 am »

Nice! ;)
Welcome to touchpad heaven!