VectorLinux
November 26, 2014, 09:56:39 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Config files [solved-thanks]  (Read 2075 times)
overthere
Vectorian
****
Posts: 1281



« on: March 01, 2008, 02:37:52 pm »

Hi..
Two questions

1-where do I find the config file for the xfce4 apps menu...

wine tests left a couple of entries in "other" after program uninstall

2-where are the config files for JWM..

I want to remove  not installed programs on menu and change wallpaper + add wbar to start at login.

thanks for any...I have looked in home hidden and usr, etc,opt.. but not finding
« Last Edit: March 05, 2008, 10:57:45 pm by overthere » Logged

Everything Is Relative
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #1 on: March 01, 2008, 07:39:32 pm »

1-where do I find the config file for the xfce4 apps menu...
~/.config/menus
Quote
2-where are the config files for JWM..
~/.jwmrc
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
overthere
Vectorian
****
Posts: 1281



« Reply #2 on: March 01, 2008, 09:13:28 pm »

well if it were that simple I would most likely have found it.

there is NO file .jwm.rc in my home directory.
there is a .config dir with a menu but it is a generic menu with no items from the start menu
I can post it but it is long.
I did a catfish search with no results

am I supposed to generate them via some command? from the depths of the system??

sorry I really want to do this and have been searching every file on the system. sometimes this can be the problem...it gets overlooked. or is in a folder you passed thinking it could not possible be there.
any thoughts?
Logged

Everything Is Relative
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #3 on: March 01, 2008, 10:10:09 pm »

jwm config is in /usr/etc/system.jwmrc you can copy it to ~/.jwmrc for your user or edit it directly for everyone.

the xfce menu is generated from the files in /usr/share/applications

HTH,
Uelsk8s
Logged
overthere
Vectorian
****
Posts: 1281



« Reply #4 on: March 02, 2008, 12:35:20 am »

Ok...thanks...I found the file and copy to home

I deleted the menu items (games less pysol) thats fine.

I found the line near the bottom referenceing the wallpaper and exchanged VL-rockface.jpg with Engagement.jpg. now I have no wall paper.
I added  wbar and wbar>vlbar<  near, above the wallpaper entry and it shows at the bottom of the screen under the taskbar at log in

I deleted this mess and attempted to just change the wallpaper as root in the original file..
the wallpaper shows at log in but is all messed up...not smooth.

I replace with VL-rockface and all is normal.

if I log in and set Engagement via gqview and start wbar from the menu it looks nice and I wanted this at log in. I'm right back where I started.

I'm guessing there is no point in even attempting the xfce menu.now as jwm could take a while.

I did not anticipate changeing wallpaper could be so complicated.

I now have the file copy to home and renamed to .jwmrc

« Last Edit: March 02, 2008, 12:41:13 am by overthere » Logged

Everything Is Relative
nightflier
Administrator
Vectorian
*****
Posts: 4030



« Reply #5 on: March 02, 2008, 05:46:39 am »

Running wbar launches a default setup with the bar at the bottom. Using vlbar by itself should put it at the top.
Try adding only vlbar just above the line:
   </StartupCommand>

Logged
overthere
Vectorian
****
Posts: 1281



« Reply #6 on: March 02, 2008, 08:40:24 am »

Thanks..
 I figured it out finally...I had it in the right place but as you say just vlbar works and I had to try all combos to finally get it.

I also have the wallpaper changed and removed the unwanted items from the menu

but I am doing this in the original file as root.

I could not get the copy to home to work for wallpaper although the bar and menu were fine.

I just got black background. when the file was removed from home I got root paper so moved there and changed everything. any idea what I was missing?

« Last Edit: March 02, 2008, 08:42:20 am by overthere » Logged

Everything Is Relative
nightflier
Administrator
Vectorian
*****
Posts: 4030



« Reply #7 on: March 02, 2008, 02:52:08 pm »

Try inserting a "Background" tag in the "Desktops" section like this:
Code:
<Desktops count="2">
<Background type="tile">/usr/share/wallpapers/eos.jpg</Background>
</Desktops>

Make sure you insert the full path to the background image.

HTH
Logged
overthere
Vectorian
****
Posts: 1281



« Reply #8 on: March 03, 2008, 12:34:09 am »

Oh...thanks...yes I seem a note regarding background tags in desktops but was not clear on it and afraid frankly to mess with the original file. should make a copy DA...thanks will test it now
had some fun though..if interested here is a shot or two

JWM with the wbar and a western theme useing opera and xine

http://my.opera.com/dsl-o/albums/showpic.dml?album=478693&picture=6672487

http://my.opera.com/dsl-o/albums/showpic.dml?album=478693&picture=6672488

Thanks
« Last Edit: March 03, 2008, 12:39:32 am by overthere » Logged

Everything Is Relative
overthere
Vectorian
****
Posts: 1281



« Reply #9 on: March 03, 2008, 03:46:42 am »

Thanks that works fine

Now..how would I activate the vlbar config in my home directory for jwms bar?

I have now vlbar in jwm but the config is system wide and I use vlbar in root fluxbox.
attempts:
I copy the config from dot.wbar to ~/.vlbar and # the top line.. but NO
I copy startwbar from user fluxbox to user and edit jwm for startwbar..NO
various edits of these...No

Anyone?
 Thanks
Logged

Everything Is Relative
nightflier
Administrator
Vectorian
*****
Posts: 4030



« Reply #10 on: March 03, 2008, 06:02:43 am »

The config file needs to be named ~/.wbar

Have some more fun with it:: open a terminal and type:
wbar -help

You will find some useful info. Example:
wbar -pos top -isize 96 -zoom 2 -config ~/.wbar
will get you a huge bar at the top with even bigger zoom, using the config file in your home dir.
Logged
overthere
Vectorian
****
Posts: 1281



« Reply #11 on: March 03, 2008, 02:55:57 pm »

Thanks...yes that works great...now fluxbox root is default and user jwm has customized vlbar/wbar
I did try dot.wbar and everything else that was not the right thing. again thanks

thanks for the tip also..yes more fun but vlbar settings are nice as is...I did lower the balfa a bit

now..back to my second question..removeing unwanted items from the xfce "other" menu

Oh..I have it...local/share/apps...

THANKS Nightflier for all your help and also ueisk8s and lagagnon
cheers
« Last Edit: March 03, 2008, 03:53:15 pm by overthere » Logged

Everything Is Relative
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!