VectorLinux
October 30, 2014, 10:40:07 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Vector talking to wireless adapter but not to router  (Read 2232 times)
loganda
Member
*
Posts: 4


« on: March 09, 2008, 04:56:07 am »

I am using Vector Linux 5.9 Gold. I am having difficulty with connecting to my wireless router. The router is a Netopia 3347NWG and the wireless adapter is a Linksys WUSB 200 Wireless-G Business USB Network Adapter. The encryption in use is WEP 128-bit. I have read the HowTo: Configure your Wireless Network. I am using ndiswrapper because I could not find which chip the device is using.

The output of lsusb was: Bus 1 Device 2: ID 13b1:0028 Linksys

but there was no information from Google about this ID number.

I have got as far as Vector talking to the wireless card and finding a number of wireless access points in the neighbourhood, including my own. When I use wifi Radar, it typically finds five wireless access points and all but mine have the router symbol (to the left of the SSID) covered by a question mark. I take this to indicate that some sort of connection has been established. But the message at the bottom of wifi Radar is "connected to None ip(none)" when I try using DHCP or "connected to None ip(192.168.1.80)" when I assign myself a fixed ip address. I have carefully entered the 26-character encryption key more than once. I have tried "Doing it Old School" as per the HowTo, wifi Radar and vlwifi but none enable me to get so far as to ping the router and get a reply.

One thing that I have noticed is that ifplugd does not seem to start on boot-up. When I enter ifconfig after booting up, all I get is:

root:# ifconfig
lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Then I restart ifplugd:

root:# service ifplugd restart
Stopping Network Interface Plugging Daemon:Failed to kill daemon. (No such file or directory)
 eth0Failed to kill daemon. (No such file or directory)
 wlan0.
Starting Network Interface Plugging Daemon: eth0 wlan0.

Trying ifconfig again:

root:# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:50:8D:7D:67:25 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:16

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wlan0     Link encap:Ethernet  HWaddr 00:1A:70:35:84:77 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

And here is the output from iwconfig wlan0:

root:# iwconfig wlan0
wlan0     IEEE 802.11g  ESSID:off/any 
          Mode:Auto  Frequency:2.412 GHz  Access Point: Not-Associated   
          Bit Rate=54 Mb/s   Tx-Power:20 dBm   Sensitivity=-121 dBm 
          RTS thr=2347 B   Fragment thr=2346 B   
          Encryption key:E805-1467-B7AC-64C4-3782-4364-0C   Security mode:restricted
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I think that I am very close to establishing a connection so any help or advice would be much appreciated!

Logged
bigpaws
Vectorian
****
Posts: 1856


« Reply #1 on: March 09, 2008, 05:11:06 am »

You are very close as you thought.

To make things easier disable the encryption on the
access point. Then try to establish a connection.

I see that an ESSID is not entered.

Try: iwconfig wlan0 essid <essid you used>
If you essid changes, then: iwconfig wlan0 key <key>

You can use iwlist scan to find access points.

HTH

Bigpaws
Logged
loganda
Member
*
Posts: 4


« Reply #2 on: March 11, 2008, 12:39:44 am »

Here is the result of iwlist scan:

root:# iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 00:18:39:8C:96:28
                    ESSID:"enniskillen"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.437 GHz (Channel 6)
                    Quality:50/100  Signal level:-64 dBm  Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
          Cell 02 - Address: 00:0F:E2:02:94:73
                    ESSID:"WDR814g"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.437 GHz (Channel 6)
                    Quality:28/100  Signal level:-78 dBm  Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
                              6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK 
          Cell 03 - Address: 00:0F:CC:25:26:84
                    ESSID:"eircom1122 4510"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.442 GHz (Channel 7)
                    Quality:71/100  Signal level:-50 dBm  Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
                              6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0

The access point to which I want to connect is "eircom1122 4510". I tried entering:

iwconfig wlan0 essid "eircom1122 4510"

I got no errors but when I keyed iwconfig wlan0 again, the essid had not changed - it remained at off/any. I have also tried to change the mode to managed:

iwconfig wlan0 mode managed

...but mode stays at Auto. I have only been able to enter the channel and the key. I am still not been able to associate the network adapter with the access point. For what it's worth, here is the output of iwconfig wlan0:

root:# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11g  ESSID:off/any  Nickname:"eircom1122 4510"
          Mode:Auto  Frequency:2.442 GHz  Access Point: Not-Associated   
          Bit Rate=54 Mb/s   Tx-Power:20 dBm   Sensitivity=-121 dBm 
          RTS thr=2347 B   Fragment thr=2346 B   
          Encryption key:E805-1467-B7AC-64C4-3782-4364-0C   Security mode:restricted
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I still have to try to establish a connection after the encryption on the access point is disabled.
Logged
loganda
Member
*
Posts: 4


« Reply #3 on: March 14, 2008, 03:50:20 am »

I disabled encryption on the wireless router and connected without any difficulty. After switching off encryption and booting into Vector, I opened Wifi Radar and saw that a connection had been established between the router and my computer but that the computer had no ip address. I clicked on "connect" and and immediately acquired an ip address. I opened a browser and was able to browse webpages.

So now that I know that Vector can connect me to so an unsecured router, how can I get it to work with encryption switced on? In the HowTo: Configure your Wireless Network it says that "Configuring your interface to use WEP is nearly as easy as when using an open network." But this has not been my experience. Connecting to an open network was very easy indeed but connecting to a WEP-protected network, to which I have a key, has proved impossible so far!
Logged
bigpaws
Vectorian
****
Posts: 1856


« Reply #4 on: March 14, 2008, 05:23:15 am »

My one test network is using  WEP authentication
all I needed to do was:

iwconfig wlan0 key <key>

Try Google "slackware wireless WEP"

That should get you going.

HTH

Bigpaws

Logged
kge420
Member
*
Posts: 73


« Reply #5 on: March 17, 2008, 06:06:25 pm »

I ran into the same problem and just disabled wep. No big deal for me.
Logged

Toshiba Satellite 2805
20 GB hdd
192mb ram
VL 5.9


"Beer is proof that God loves us and wants us to be happy".
    -Ben Franklin
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #6 on: March 17, 2008, 06:18:21 pm »

I can't help with WEP.  I can say that we're using WPA here with a TrendNet wireless router.  I didn't need to go to the command line at all.  I connected with vwifi on the first go.  It was every bit as easy as an open network other than having to specify the encryption and enter a password.  wifi-radar works as well.  Does your router support WPA?
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
loganda
Member
*
Posts: 4


« Reply #7 on: March 19, 2008, 01:39:26 pm »

The router supports WPA-802.1x and WPA-PSK. However, there are other people using the same router as their access point as well and I'd have to change the configuration of their computers to work with WPA if I wanted to switch over to WPA. I don't really want to do that because they are happy with the way things are. WEP works fine with their machines so I'd rather leave well enough alone.
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #8 on: March 19, 2008, 01:48:47 pm »

I have used wep here without problems.
have you tried VLwifi?
from the CL it should be
Code:
iwconfig wlan0 essid "eircom1122 4510" key "wepkey" && dhcpcd wlan0
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!