Please support VectorLinux!

Author Topic: 080317 Ardour 2.3.1  (Read 4008 times)

JohnB316

  • Administrator
  • Vectorian
  • *****
  • Posts: 1346
  • Registered Linux User #386728
080317 Ardour 2.3.1
« on: March 16, 2008, 08:44:51 pm »
Dweeberkitty has packaged the latest ardour, which is in the testing repository.

Code: [Select]
ardour: ardour: (Digital Audio Workstation)
ardour:
ardour: Ardour is a digital audio workstation.You can use
ardour: it to record, edit and mix multi-track audio.You
ardour: can produce your own CDs, mix video soundtracks,
ardour: or just experiment with new ideas about music
ardour: and sound.
ardour:
ardour: License: GNU GPL
ardour: Website: http://www.ardour.org
ardour: Authors: Paul Davis and others (see site)
ardour:

Post issues, etc., here.
VL 6.0 SOHO latest alpha on one box, VL 5.9 Lite on the other.

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2299
Re: 080317 Ardour 2.3.1
« Reply #1 on: March 26, 2008, 03:04:38 pm »
I have a weird issue, I get segmentation faults trying to run it after picking a session and starting jack.

Quote
loading default ui configuration file /etc/ardour2/ardour2_ui_default.conf
Loading ui configuration file /etc/ardour2/ardour2_ui_dark.rc
theme_init() called from internal clearlooks engine
loading system configuration file /etc/ardour2/ardour_system.rc
ardour: [INFO]: Using SSE optimized routines
ardour: [INFO]: looking for control protocols in /root/.ardour2/surfaces/:/usr/lib/ardour2/surfaces/
powermate: Opening of powermate failed - No such file or directory
ardour: [INFO]: Control protocol powermate not usable
ardour: [INFO]: Control surface protocol discovered: "Generic MIDI"
ardour: [INFO]: Control surface protocol discovered: "Mackie"
ardour: [INFO]: Control protocol Tranzport not usable
JACK tmpdir identified as [/tmp]
JACK COMMAND: /usr/bin/jackd -p 128 -T -d alsa -n 2 -r 48000 -p 1024 -d hw:0,0
Segmentation fault

I can run the previous version fine, does anyone else experienced the problem?
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

Dweeberkitty

  • Packager
  • Vectorian
  • ****
  • Posts: 836
    • Multimedia Bonus Disc
Re: 080317 Ardour 2.3.1
« Reply #2 on: March 26, 2008, 03:27:57 pm »
That is certainly strange, I've not had any problems like that at all. I'll have to look into it. It works great with the MMBD, so maybe it's a dependency issue.
Registered Linux User #443399
Desktop: Intel Pentium D 3.33Ghz, 320GB hard drive, 2 gigs DDR2 533mhz RAM, NVIDIA Geforce 7800 GS, X2GEN 22" widescreen monitor;
Laptop: Dell Mini 9, Intel Atom 1.6Ghz, 1GB ram
Multimedia Bonus Disc website: http://www.vectorlinuxsolutions.com/

Dweeberkitty

  • Packager
  • Vectorian
  • ****
  • Posts: 836
    • Multimedia Bonus Disc
Re: 080317 Ardour 2.3.1
« Reply #3 on: April 07, 2008, 04:28:42 pm »
rbistolfi, there is a new version of Ardour, 2.4. I have included this on MMBD 1.0. I'll submit it to the repos as well. Maybe that will fix the problem.
Registered Linux User #443399
Desktop: Intel Pentium D 3.33Ghz, 320GB hard drive, 2 gigs DDR2 533mhz RAM, NVIDIA Geforce 7800 GS, X2GEN 22" widescreen monitor;
Laptop: Dell Mini 9, Intel Atom 1.6Ghz, 1GB ram
Multimedia Bonus Disc website: http://www.vectorlinuxsolutions.com/

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2299
Re: 080317 Ardour 2.3.1
« Reply #4 on: April 07, 2008, 06:37:01 pm »
Thanks Dweeberkitty, I will reach the package in one way or the another ;)
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!