VectorLinux
September 01, 2014, 12:56:25 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Download error  (Read 1004 times)
MakoV
Member
*
Posts: 3


« on: March 21, 2008, 04:36:46 am »

Following the VL wiki to download/build/install compiz-fusion I got to step 4 (pyrex)
when I get an ERROR 404: Not Found.

The first 3 steps went fine (compiz, bcop and libcompizconfig) but step 4 fails.
Can I download this part from elsewhere or am I stuck until the file is back online?

Thanks for any help, I'm new to this Linux lark.
(Apologies if this isn't the right place to post this).
Logged

New to Linux. Any tech answers will be met with a blank stare.
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #1 on: March 21, 2008, 04:48:21 am »

I assume you're working with the vpackager build wiki... building from cruxports

There is an updated pyrex... but I dont have ssh keys here to modify the pkgfile...

As root, do this

* navigate to /usr/ports/VL/Pyrex
* open file named "Pkgfile"
* Change line 6 of the file to read like this
Code:
version=0.9.6.4
save and close the file... after that, try to build it again... that should fix it.
« Last Edit: March 21, 2008, 04:58:08 am by M0E-lnx » Logged

MakoV
Member
*
Posts: 3


« Reply #2 on: March 21, 2008, 05:54:48 am »

Well that was quick! Thanks for the reply. Yes I am building from cruxports as per the wiki.

I managed to do as you suggested (you didn't read my sig then!)
and it worked. Unfortunately further down the process I've encountered
another problem, in the VL/fusion-icon build;

=======> Using Pkgfile for building Package
=======> WARNING: Md5sum not found, creating new.
=======> Building '/usr/ports/VL/fusion-icon/fusion-icon-git-i586-1vl59.tlz'.
=======> ERROR: Building '/usr/ports/VL/fusion-icon/fusion-icon-git-i586-1vl59.tlz' failed.
+ build
+ git clone git://anongit.compiz-fusion.org/users/crdlb/fusion-icon
./Pkgfile: line 23: git: command not found
Result: FAILED

All help gratefully received.
Logged

New to Linux. Any tech answers will be met with a blank stare.
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #3 on: March 21, 2008, 06:37:20 am »

You need to install the git utility. This should be available via gslapt

or slapt-get --isntall git

after that, fusion-icon should be able to download sources, and build.
Logged

MakoV
Member
*
Posts: 3


« Reply #4 on: March 21, 2008, 07:24:40 am »

Many thanks for your help. That worked and CF is now installed.

I'm engaged in beta testing for X3 Reunion on Linux and am trying out
different distros to see what problems I encounter with installing and
playing. I've come to VL as part of this evaluation and I've been trying
to make them all as close as possible (hence the compiz-fusion install)
in form.

Whilst VL hasn't been the easiest to get to grips with it actually feels
nicer to use than many 'better known' distros and the speed of reply
through the forum is better than any other I've used. I'd seriously consider
coming back to it as my main platform when the testing has finished.

So congratulations to all involved in its inception and upkeep.
Logged

New to Linux. Any tech answers will be met with a blank stare.
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #5 on: March 21, 2008, 07:27:16 am »

Glad you like it..

Our implementation of cruxports4slack is still under development.. specially vpackager... I'm working on the next release, once that's done, I will concentrate more of my efforts into maintaing ports scripts as well.
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!