VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Xfce4 + Symbol lookup error + odd thing  (Read 2315 times)

joris20

  • Member
  • *
  • Posts: 6
Xfce4 + Symbol lookup error + odd thing
« on: March 19, 2008, 06:04:15 am »

1. Xfce4
i have it installed, it worked just fine, until my linux CRASHED (yer, sounds impossible but thats exactly what happened)
there was an error detected on my /dev/hdb2 so it said i had to try the "e2fsck <device>" command
i did (device= /dev/hdb2 ) and everything went back to normal (i usually work in blackbox)
but now i want to re-open Xfce4 (its easier when managing files) and all it does is give a black screen and my Xfce4 mouse indicator. it doesn't even show the Loading bar (doesn't load at all :S )

2. my friend told me i could use Thunar in Blackbox to manage my files easily as well.
so i type "thunar" in xterm and then it gives this error:

joris:$ thunar
thunar: symbol lookup error: thunar: undefined symbol: gdk_threads_lock

so i'm like "grrrr" and i decided to re-install Xfce4
i start firefox and look for it. i click to DL (it was FTP) but ofcourse then i get the .run-file in text format in my browser.
no problem, we have gFTP for something right?

joris:$ gftp
/usr/X11R6/bin/gftp-gtk: symbol lookup error: /usr/X11R6/bin/gftp-gtk: undefined symbol: gdk_threads_lock

at that moment i remembered +- the same error when trying to start Pidging (which never worked)

joris:$ pidgin
pidgin: symbol lookup error: pidgin: undefined symbol: gtk_window_set_focus_on_map


You may have noticed that "gtk" appears in all 3 error messages.
i believe the G2K (or was it GTK :-? ) library is the one i tried to install before installing (and trying to run) pidgin.
when pidgin didnt work, i uninstalled both (uninstalled G2K with the "make distclean" command)

and THATS when all troubles started.

that G2K/GTK thingy isn't clean... can anyone help me with this please? my friend finds it incredibly funny cuz he constantly kinda r*pes his system, not getting any complications, while i try to install a stupid library, messing up the whole thing >.<

3. odd thing

after the installation and deinstallation of the library, i got a weird message while starting up Linux:

computer has not been checked for 24781 days, check forced   (<-- it normally does that every 20 unchecked days, but now it did it this saturday AND sunday. 24781 days is +-70 years wth?)

it didn't do it again when i stared my computer today, but i thought i'd let u know :P ;D

Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: Xfce4 + Symbol lookup error + odd thing
« Reply #1 on: March 19, 2008, 06:15:51 am »

Can you tell us what version you are running?
From the lines it seems to be a version earlier than 5.9.

joris20

  • Member
  • *
  • Posts: 6
Re: Xfce4 + Symbol lookup error + odd thing
« Reply #2 on: March 19, 2008, 10:46:42 am »

yer it's most likely more than a year old (not completely shure tho)

where can i check that?
Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2305
Re: Xfce4 + Symbol lookup error + odd thing
« Reply #3 on: March 19, 2008, 10:59:39 am »

You can know the exact version with cat /etc/vector-version
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

joris20

  • Member
  • *
  • Posts: 6
Re: Xfce4 + Symbol lookup error + odd thing
« Reply #4 on: March 19, 2008, 12:37:54 pm »

Vector Linux 5.8 Standard 12-16-2006

so whats next? ;D
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: Xfce4 + Symbol lookup error + odd thing
« Reply #5 on: March 19, 2008, 01:02:32 pm »

I would suggest an upgrade. 5.9 is a much more complete release with lots of upgraded software and many more bugs fixed.

joris20

  • Member
  • *
  • Posts: 6
Re: Xfce4 + Symbol lookup error + odd thing
« Reply #6 on: March 20, 2008, 09:10:41 am »

so...how exactly do i update it?
cuz i only see the complete 5.9 which is like 300/600MB and i only just want an UPDATE :(

sry but i'm a newbie on Linux :(
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: Xfce4 + Symbol lookup error + odd thing
« Reply #7 on: March 20, 2008, 10:51:33 am »

There is no way to upgrade from 5.8 to 5.9... There were major changes between the 2 releases... You need to download the ISO, butn it on a CD and run the installer.

joris20

  • Member
  • *
  • Posts: 6
Re: Xfce4 + Symbol lookup error + odd thing
« Reply #8 on: March 21, 2008, 07:52:58 am »

ok thanks.
i hope that'll help.

how do i cleanly uninstall the 5.8 ?
i also have a version of windows on my comp and i dont want it to be erased...

is there a format option in the install CD?
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: Xfce4 + Symbol lookup error + odd thing
« Reply #9 on: March 21, 2008, 08:21:50 am »

the installer will ask you if you wish to format the drive ... that will wipe everything out of there and install the new iso