VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Pidgin: disconnects right after the account is enabled  (Read 2434 times)

fuelinux

  • Member
  • *
  • Posts: 52
Pidgin: disconnects right after the account is enabled
« on: March 25, 2008, 07:00:21 am »

Hello vectorians :) glad to be here

So I have installed VL5.8 Std on my machine at office. removed Gaim, downloaded Pidgin 2.4.0, built it from source (installed with no complaints). When I run it, Pidgin oofers to enable my account (Yahoo ID) and then displays message in main window (tittle - Buddy List)

"****** disconnected. Could not establish a connection with server:
Access denied: HTTP proxy server doesn't forbids port 8080 tunneling"


As far as I can judge, my internet works OK (typing from that machine, actually). proxy server address (and port #8080) is correct, I suppose. Ofcourse the address is Pidgin's settings too. No error messages in terminal as well while running programm.

hmmm... I dont know, what kind of info could I provide. if there will be anything to help you to help me, just bother me :D
Logged
Vector Linux 5.8 Standard

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Pidgin: disconnects right after the account is enabled
« Reply #1 on: March 25, 2008, 11:49:12 am »

Look at the logs on the proxy server. It looks like that
is where the problem is.

Looks like an answer is at the developers site:

http://developer.pidgin.im/ticket/496

Bigpaws
Logged

fuelinux

  • Member
  • *
  • Posts: 52
Re: Pidgin: disconnects right after the account is enabled
« Reply #2 on: March 25, 2008, 12:50:18 pm »

Bigpaws, thank you for the link. I hate to ask questions not looking at all the sources of info first. My bad :D
I'll give it a try when I get to my office and post the results.

edit -------------------------------

Still no solution. Proxy settings at our office network only allow http traffic to go through port #8080. But seems like the problem is in Pidgin's implementation of http traffic in yahoo messenger's case. So I think, Pidgin is not for me in this particular case.
Seems like it's common problem for Pidgin on yahoo + proxy .



Could anybody advice any chat client for yahoo?
I downloaded official YM from http://messenger.yahoo.com/unix.php (FreeBSD Installation). Running 'installpkg <filemane>' resulted in message "file has no description". Files where put in various locations (some even in ./  :o). Needless to say, I've been unable to run YM. I understand, it's a BSD package and I've issued Slackware install command. I just tried. Is there any workaround on the matter?


//edit

I think there is something weird with my LAN's proxy server
I have installed GyachE Improved 1.1.0. It runs, but when I try to connect to yahoo it issues a message
** Could not connect to Yahoo! [ Error connecting via proxy.  Proxy replied: 'HTTP/1.0 403 Forbidden' ] **
How is it possible to navigate internet and not being able to connect to yahoo using chat client? I'm kinda stuck


/Solved

OK, my sollution is to download Yahoo messenger's RPM from http://messenger.yahoo.com/unix.php (RH9 file), cd to directory where the file was put, issue command rpm2tgz <downloaded *.RPM file>, then installpkg <resulted *.tgz file>
just ignore the "warning"

WARNING: Non-standard package name

.-----.-----------------------------------------------------------------------.
| 1/1 | Installing rh9.ymessenger-1.0.4-1.i386.tgz                       |
'-----'-----------------------------------------------------------------------'
WARNING: Package has no description.

issue following /opt/ymessenger/bin/ymessenger
enjoy YM v.1.0.4 (yeah, seems like linux community is on lower range in Yahoo's priorities) >:(

Note: Attempt to change tabs (at the bootom of main window) resulted in Segmentation fault (I have no idea what it is :D) and the program was closed. I just turned Content Bar and Search Bar off.
« Last Edit: March 27, 2008, 02:18:30 am by fuelinux »
Logged
Vector Linux 5.8 Standard