VectorLinux
October 24, 2014, 04:17:53 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Gaim and Pidgin always creating new PID's  (Read 1285 times)
sakuramboo
Member
*
Posts: 2


« on: March 24, 2008, 11:55:58 am »

I just noticed this issue when i fired open Gaim for the first time on VL. I was monitoring GKrellM and noticed that the number of processes jumped from around 80 to over 200 in a matter of a couple hours. After looking at htop, i noticed that all the added PID's were all from Gaim. So I installed Pidgin and I am noticing the same exact thing happening. When I send an IM, 2 processes get created and then 1 gets removed and when someone sends me an IM 1 process gets added. So, if I am I'm a chatty mood, the number of processes will just sky rocket. What could be the issue and is there any way to fix this?

I am running VL 5.8.

BTW, other than this issue, VL runs perfect on a Dell Inspiron 3500, 400 Mhz P2 with 190 Megs of Ram.
Logged
LLL
Global Moderator
Vectorite
*****
Posts: 263


The sun is shining...


« Reply #1 on: March 24, 2008, 03:23:40 pm »

Is GAIM/Pidgin (really the same thing; the latter is the "legalized" naming and latest evolution of the former) a threaded application? I don't know a lot, but there are certain applications that take advantage of "threading" - which looks like more processes, but isn't really. Give it a Google, or wait for someone smarter to come along.

Cheers!

LLL
Logged

Lost & Lovin' Linux...living on:
VectorLinux 6.0 with XFCE on Thinkpad T43p (2.13 GHz | 2GB | 60GB)
sakuramboo
Member
*
Posts: 2


« Reply #2 on: March 25, 2008, 05:50:03 am »

pidgin is not a multi-threaded program. i have someone else looking into this, unfortunately, they are not experiencing the same problem. they see that pidgin loads and when they send and receive IM's, more PID's are created but they go away almost instantly (as soon as the message is sent or received). they arent using vector, so it seems like its only a problem with vector.

whats even more interesting is that htop reports all the processes and gkrellm sees them too, but ps doesnt, top doesnt and pstree doesnt (pstree doesnt even show the first instance of pidgin).

EDIT: I just noticed the same problem with Firefox. When ever I open a new tab, another process opens up and doesnt go away, even after I close the tab. To remove the processes, I need to completely close down firefox.
« Last Edit: April 01, 2008, 07:33:43 am by sakuramboo » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!