VectorLinux
September 20, 2014, 09:48:48 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: Text does not show up  (Read 2329 times)
Fansler
Member
*
Posts: 11


« on: March 24, 2008, 02:06:26 pm »

My first real linux install (ubuntu doesn't count Tongue ) is using this, so I don't know much about linux. I installed 5.9 gold edition just fine, and the md5 sum checks. But no text shows up whenever there should be text! Instead of text, I get a black (or white) box where the text should be. Below are pictures of what I am talking about.

[img=http://img146.imageshack.us/img146/3811/1000528tb0.th.jpg]
[img=http://img258.imageshack.us/img258/7595/1000529lb6.th.jpg]
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #1 on: March 24, 2008, 04:45:49 pm »

definately a problem with your video driver.

what video card/chipset do you have?
Logged
Fansler
Member
*
Posts: 11


« Reply #2 on: March 24, 2008, 04:55:33 pm »

I have a laptop (Fujitsu Lifebook) with a mobile intel 965 express chipset family. This is the link to it on fujitsu's website.

http://store.shopfujitsu.com/fpc/Ecommerce/buildseriesbean.do?series=T4220
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #3 on: March 24, 2008, 05:04:33 pm »

first thing you want to do is make sure you are using the intel driver in your xorg.conf
you should see a line like this
Driver "intel"
in your video device section.
if it says
Driver "i810"
then change it and reboot then let us know if that fixed it.
Logged
Fansler
Member
*
Posts: 11


« Reply #4 on: March 24, 2008, 05:09:09 pm »

urrrg. I'm really a noobie. Been using winblows for my entire life. What's the xorg.conf, and how do I edit it?
Logged
brock
Member
*
Posts: 26


« Reply #5 on: March 24, 2008, 05:46:22 pm »

Quote
urrrg. I'm really a noobie. Been using winblows for my entire life. What's the xorg.conf, and how do I edit it?


Hey I'm a noobie and I know what the xorg.conf is.  My point is:  hang in there.  I'm a recent convert from Apple.  It's worth the "urrrg".  Don't get too frustrated.  I know what it's like to wonder what the heck they are talking about.  I've gone thru a few distros and this is by far the best one.  And some really great help at this forum as well.  Some of the others are a bit nose-turned-up-ish.  I can't fix your problem.  I have no idea.  But I wanted to say that you're in the right place and don't feel like you're the only newbie.  Hang in there.  See ya around.
Logged

ChemBook Laptop (it was free) 1.50 GHz 1 gig ram 1024x768 screen Ethernet-cable modem (working on wireless), Vector 5.9 Standard Gold, HD install, NO dual boot--windowsfree system!  prefer Xfce for now
Fansler
Member
*
Posts: 11


« Reply #6 on: March 24, 2008, 06:00:44 pm »

haha. thanks. I guess it's just hard getting used to when the worst thing you had to do before was reinstall windows ME once a month.
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #7 on: March 24, 2008, 06:12:25 pm »

sorry for Assuming.

you need to open a text editor as root.
there are lots of ways you can do this, here is one:
open a terminal
type su then enter root password
type "mousepad /etc/X11/xorg.conf"
that will open the mousepad text editor with the /etc/X11/xorg.conf file ready to edit.
Logged
Fansler
Member
*
Posts: 11


« Reply #8 on: March 24, 2008, 06:52:35 pm »

I couldn't get mousepad to open.

I went to the linux-tui option, on the login screen, I typed "root", then my password, and everything seemed fine.
Then, with any way that I tried to open the mousepad text editor, I got this error message:
(mousepad: 3050 [this number changed every time]): Gtk-WARNING **: cannot open display:

The text in the terminal works fine though, so the video problem must be specific to the GUI
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #9 on: March 24, 2008, 07:07:54 pm »

from the tui login you will have to run an editor like mcedit

try "mcedit etc/X11/xorg.conf"
Logged
Fansler
Member
*
Posts: 11


« Reply #10 on: March 24, 2008, 08:00:49 pm »

I am assuming that you are talking about the part that reads this:

driver: i810
vendorname: Intel
etc...

I changed i810 to intel and Intel and neither fixed the problem. I didn't notice any change in the GUI with either option, though.
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #11 on: March 24, 2008, 08:24:16 pm »

did you restart the gui after each change?

the next thing to try is comment out the last line in /etc/profile.d/vasm.sh
so that it looks like this
#export XLIB_SKIP_ARGB_VISUALS=1

Logged
Fansler
Member
*
Posts: 11


« Reply #12 on: March 24, 2008, 09:04:52 pm »

If, by "restart the gui", you mean reboot the computer, then yes.

And that next thing didn't work either. The file edit succeeded, but nothing changed. Still blank boxes instead of text.
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #13 on: March 24, 2008, 09:40:01 pm »

I think you should try using the vesa driver for now
change Driver "i810" to Driver "vesa"
then reboot
Logged
Fansler
Member
*
Posts: 11


« Reply #14 on: March 24, 2008, 11:58:29 pm »

Wow! Thanks! It works quite well now. I really appreciate it.

Is vesa a universal driver of some sort?

But I've already managed to make the OS hang, though. Is there a linux equivalent of ctrl + alt + del, so I can get rid of frozen windows?
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!