Author Topic: Fujitsu Stylistic LT C-500 Touchscreen won't work  (Read 5891 times)


  • Member
  • *
  • Posts: 1
Fujitsu Stylistic LT C-500 Touchscreen won't work
« on: March 26, 2008, 03:28:23 am »
I have installed 5.9 STD Gold on a Fujitsu Stylistic LT C-500. It works brilliantly and is nearly the coolest thing in the world. I just need help getting the touchscreen to work.

The relevant parts of my xorg.conf look like this:

Code: [Select]
Section "ServerLayout"
Identifier     " Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0 "CorePointer"
InputDevice    "Mouse1" "SendCoreEvents"
InputDevice    "Keyboard0" "CoreKeyboard"

Section "InputDevice"
Identifier "Mouse0"
Driver "fpit"
Option "Device" "/dev/ttyS0"
Option "Passive"
Option "SendCoreEvents"

Section "InputDevice"
Identifier  "Mouse1"
Driver      "mouse"
Option     "Protocol" "auto"
Option     "Device" "/dev/input/mice"
Option     "ZAxisMapping" "4 5"

I've added these lines to /etc/serial.conf:

Code: [Select]
/dev/ttyS0 autoconfig
/dev/ttyS0 uart 8250 irq 5 port 0xfd68 low_latency

I've Googled for three days, tried every combination of settings, arguments, HAL, ttyS's and swearing I could find. I'm pretty sure it's device ttyS0, definitely "fpit" driver. All I've got so far is my X session killed when I tapped the screen on one set of settings.

Relevant section in /var/log/messages:

Code: [Select]
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
Time: acpi_pm clocksource has been installed.
serial8250: ttyS3 at I/O 0x2e8 (irq = 3) is a 16550A
pnp: Device 00:08 activated.
00:0b: ttyS0 at I/O 0xfd68 (irq = 5) is a 16550A
loop: module loaded
HP CISS Driver (v 3.6.14)
input: Macintosh mouse button emulation as /class/input/input1

And /var/log/Xorg.0.log (showing some of the different settings mentioned earlier):

Code: [Select]
(**) Option "SendCoreEvents"
(**) TOUCHSCREEN: always reports core events
(**) FPIT device name: TOUCHSCREEN
(**) Fpit associated screen: 0
(**) FPIT maximum x position: 4100
(**) FPIT minimum x position: 0
(**) FPIT maximum y position: 4100
(**) FPIT minimum y position: 0
(**) FPIT invert X axis: No
(**) FPIT invert Y axis: No
(**) FPIT swap X and Y axis: No
(**) FPIT Passive button mode: No
(**) Option "Protocol" "auto"
(**) Mouse0: Device: "/dev/input/mice"
(**) Mouse0: Protocol: "auto"
(**) Option "CorePointer"
(**) Mouse0: always reports core events
(**) Option "Device" "/dev/input/mice"
(==) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 9
(**) Mouse0: Sensitivity: 1
(**) Option "CoreKeyboard"
(**) Keyboard0: always reports core events
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard0: XkbRules: "xorg"
(**) Option "XkbModel" "latitude"
(**) Keyboard0: XkbModel: "latitude"
(**) Option "XkbLayout" "gb"
(**) Keyboard0: XkbLayout: "gb"
(WW) Option "XkbVariant" requires an string value
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(II) evaluating device (Keyboard0)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) evaluating device (Mouse0)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) evaluating device (TOUCHSCREEN)
(II) XINPUT: Adding extended input device "TOUCHSCREEN" (type: Fujitsu Stylistic)
(--) Mouse0: PnP-detected protocol: "ExplorerPS/2"
(II) Mouse0: ps2EnableDataReporting: succeeded
(**) Option "Device" "/dev/ttyS3"
(**) Option "BaudRate" "19200"
(**) Option "StopBits" "0"
(**) Option "DataBits" "8"
(**) Option "Parity" "None"
(**) Option "Vmin" "10"
(**) Option "Vtime" "1"
(**) Option "FlowControl" "None"

All looks like it's working but I'm getting nothing. Hot keys on the touchscreen (number keypad + a few other keys) all work and they use the touchscreen so the hardware's OK.

Apologies for the epic post but I wanted to get as much info in as possible. I started using linux with Vector a week or so before 5.1 was released and since then I've been to Slackware, FreeBSD, NetBSD, Familiar, Slax, Solaris and back on various machines and this is my very first forum question, ever (ie. I've tried everything honest). Any help would be greatly appreciated.