VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Unable to --upgrade due to missing 'hal-info' package.  (Read 1416 times)

vredfreak

  • Member
  • *
  • Posts: 2
Unable to --upgrade due to missing 'hal-info' package.
« on: March 27, 2008, 06:34:56 am »

No matter what sources I use for slapt-get, --upgrade always fails because it can't find the listed hal-info package.  So I went to a few of the mirrors in my browser, and lo-and-behold, the "meta" and "txt" files are present, but the actual package is not.  The exact package in question is "hal-info-20071212-noarch-1".  I checked three different sources in my browser and the situation was the same at all three.  I'm not sure if this has anything to do with it or not, but the meta file lists the package as a "tgz" file instead of a "tlz" file (neither of which is present).

Thanks.
Logged
VL 6.0 Standard

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: Unable to --upgrade due to missing 'hal-info' package.
« Reply #1 on: March 27, 2008, 11:17:00 am »

I've run into this too.  You can still upgrade by excluding hal-info.  Your exclude list is on the second line of your /etc/slapt-get/slapt-getrc file.  You can also upgrade specific packages at the command line.

I've reported this problem before.  Hopefully it will get fixed soon.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

vredfreak

  • Member
  • *
  • Posts: 2
Re: Unable to --upgrade due to missing 'hal-info' package.
« Reply #2 on: March 27, 2008, 06:34:57 pm »

Thanks for the reply.  I did see your post, but it was a few weeks old and the only suggestion was to change mirrors, which obviously doesn't help.  So I thought I'd start a different thread.  While this isn't really a show-stopper, I'd still like to get it resolved.

Thanks.
Logged
VL 6.0 Standard

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: Unable to --upgrade due to missing 'hal-info' package.
« Reply #3 on: March 27, 2008, 07:58:51 pm »

Me too.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1