VectorLinux
April 19, 2014, 03:40:20 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: VL Lite 5.9 automatic login  (Read 4638 times)
Uta
Member
*
Posts: 20


« on: March 31, 2008, 02:17:26 pm »

I have setup an old Dell laptop for my elderly neighbor to use only for email/web.
I am trying to make it as simple as possible for her, hence auto login.
This means she pushes the power button, waits and then she is looking at the desktop.
The Lite version of 5.9 is what I am using and would appreciate a howto, which files need to be edited.
Thanks.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 3941



« Reply #1 on: March 31, 2008, 04:03:21 pm »

I am looking at autologin possibilities for next release of VL Light.

For poweroff by pushing power button you need to install and configure ACPID. Have not tried that yet.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 3941



« Reply #2 on: March 31, 2008, 05:35:12 pm »

This worked for me:

Make sure you use KDM as your login manager.
Edit the file /usr/share/config/kdm/kdmrc, change three lines:
AutoLoginEnable=true   
AutoLoginUser=   <-- insert user name
PreselectUser=    <-- insert user name
Logged
Uta
Member
*
Posts: 20


« Reply #3 on: March 31, 2008, 07:24:07 pm »

Thank You! Perfect--

In terms of powering off, after the system halts I still have to push the power button once for a full shutdown.
I added "apm=power-off"  to lilo.conf, ran lilo -v but to no affect. This procedure did work on this laptop when I tested 5.9 the standard version. Is this possible with the Lite version.
Again, thanks for your help.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 3941



« Reply #4 on: April 01, 2008, 04:12:34 am »

Software power off is definitely possible. I don't know much about it myself, though. Web searching and experimentation usually pays off Wink
Logged
Freston
Vectorite
***
Posts: 165


« Reply #5 on: April 01, 2008, 09:20:45 am »

Auto-poweroff on old laptops can be a bit of a problem getting it to work. You'll need to look for the right ACPI settings.

You might want to try booting it with the following as kernel parameter:
Code:
acpi=force

And if this breaksaccess to the USB-ports, as it does on my old machine, try this:
Code:
acpi=force, pci=noacpi

I don't know about the light version though. And I don't guarantee it'll work. But it might be worth your time to try.

Do you know how to pass parameters to the kernel during boot?? 'cuz I have no idea how to do that on VL-light Wink
Otherwise just edit lilo.conf and don't forget to run 'lilo -v' afterwards :p
Logged
Uta
Member
*
Posts: 20


« Reply #6 on: April 02, 2008, 05:40:08 am »

Thanks for your suggestion unfortunately it doesn't have the desired affect.
I used "acpi=force " adding it to lilo, ran -v lilo restarted then shutdown and then once again it hangs at system has halted. Adding this had no affect on my usb devices so I didn't use the additional "pci=noacpi"
There must be something very different in this Lite 5.9 version because on this same laptop running the Standard version "apm=power-off" added to lilo.conf works perfectly.
I did confirm that acpid was loading.
This is a Dell Latitude CP 233MX.
Thanks for your help.
Logged
nubcnubdo
Vectorian
****
Posts: 675


« Reply #7 on: April 02, 2008, 06:03:12 am »

Please check BIOS for power management settings. Report here any settings related to APM or ACPI, as well as current status of setting(s). If the laptop is 233mhz, it will probably work best with APM power management.
Logged
Uta
Member
*
Posts: 20


« Reply #8 on: April 02, 2008, 10:54:09 am »

I did check the BIOs settings.
What I have is a Dell Latitude CP M233XT BIO v. A03. The only power settings in the bio section refer to power management when running on a battery (enabled) and on AC (disabled). I tried AC enabled and then shutdown but it still just halted.

What other info would be helpful?
Logged
nubcnubdo
Vectorian
****
Posts: 675


« Reply #9 on: April 02, 2008, 11:17:48 am »

I would say you can forget about ACPI power management on a machine that old, not that old machines are bad, just that APM was the PM scheme when this laptop was made. I suggest you disable both settings in BIOS and append LILO for APM power management. I recall that the actual appending code included turning APM on and as well as turning it off. I'll have to crank up my test box, see what's in LILO, if I can't find it on the VL Forum.

Code:
append="apm=on apm=power-off"

http://www.togaware.com/linux/survivor/APM_Power.html

You may have to append in more than one section of LILO, but especially, the append should be in the global section, IIRC. (All this from my memory, apologies.)

If this fails, try enabling AC PM in BIOS (again). Other combinations, too. Don't give up. Give things a reboot to take effect. Keep an eye or ear on the CPU fan, make sure it doesnt cut off during boot.
« Last Edit: April 02, 2008, 11:29:18 am by nubcnubdo » Logged
Uta
Member
*
Posts: 20


« Reply #10 on: April 02, 2008, 12:28:00 pm »

Thank you for your suggestions, I tried them but still hanging at halt.

I also tried this:
If you have apm as a module then use the following when you load the module:
# modprobe apm power_off=1
When I did this it wouldn't turn off even with the power button, I had to pull the battery.

adding apm=power-off worked so easily in 5.9 standard but not 5.9 Lite.

Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!