VectorLinux
November 23, 2014, 10:21:26 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Getting j-pilot to sync with Sony Clie  (Read 3092 times)
Stokstaartje
Member
*
Posts: 36


« on: April 01, 2008, 01:55:01 pm »

I was wondering if anyone has been successful in setting up j-pilot to sync with a Palm, in this Sony Clie peg-sj30. It is connected via a USB port.

I read in the j-pilot manual to link the port with /dev/pilot and to give read/write access to the port via chmod 666.

How do I figure out to which port the palm is connected?

Anyone done this before succesfully?
Logged

----------------------------------
I hope I didn't brain my damage!
kukibl
Guest
« Reply #1 on: April 01, 2008, 01:59:48 pm »

Try with dmesg when you plug-in your Palm:

Code:
$dmesg | tail

Output of command will probably show you which device node is created.
Logged
Stokstaartje
Member
*
Posts: 36


« Reply #2 on: April 02, 2008, 09:26:48 am »

The problem seems to be that as user I get a permission denied error. As root I can sync. I have chmod 666 /dev/ttyUSB1 or even chmod 777 /dev/ttyUSB1 but to no avail.

Syncing as root is cumbersome. Is there another way around this?


p.s. Even though syncing as root is possible, I then get an ID error, claiming that the Palm device has a NULL ID. Extra bonus points for fixing that one :-)

Logged

----------------------------------
I hope I didn't brain my damage!
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #3 on: April 03, 2008, 05:53:11 pm »

I *used to* be able to sync with my Clie as user in 5.9 Deluxe, but now I can sync only as root. If I try as user, I get this message:

me:$ jpilot
pi_bind error: /dev/ttyUSB1 Permission denied
Check your serial port and settings
Exiting with status SYNC_ERROR_BIND
Finished

I checked before I synced and the permissions on /dev/ttyUSB0 and /dev/ttyUSB1 are 0666. So permission should not be denied.

I had the same problem during beta testing but uelsk8s provided a solution involving udev. But those changes seem to have been incorporated in VL 5.9 Standard Gold.

I found several Google hits with the same problem but no solution.

Odd, very odd. Did an update to something screw things up?

Any ideas gratefully received, especially if they solve the problem.<g>
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
rbistolfi
Packager
Vectorian
****
Posts: 2290


« Reply #4 on: April 03, 2008, 08:28:07 pm »

I would run udevmonitor and then plug the pda to see if that gives any clues.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
derrell
Member
*
Posts: 2


« Reply #5 on: April 28, 2008, 06:58:37 pm »

If anyone is still interested I poked at this long enough to finally get it let me sync my sony clie handhelds without being root.  This might break something else but I haven't had any problems yet, your mileage may vary.

Add this rule to a file in /etc/udev/rules.d that is numbered lower than what in there already.  I used 05-local.rules as the file name, I already had it to control several usb hard disks that I swap around.
Code:
KERNEL=="ttyUSB[13579]", SUBSYSTEMS=="usb", ATTRS{product}=="Palm Handheld",  SYMLINK+="pilot", GROUP="users", OPTIONS+="last_rule"
Adding the last_rule option is what made it all work.  There is something down stream that is changing the owner and group of /dev/pilot -> /dev/ttyUSB1 -> tts/USB1 to root.  I never did find where it was happening. 

Also setting the group to users is probably not the most secure thing to do either so you might want to think about that. 

If you want to change the rule around to catch different palm devices this command will give you the information about what is hooked to ttyUSB1.  Run it after you hit sync on the palm or ttyUSB1 won't exist yet.
Code:
udevinfo -a -p $(udevinfo -q path -n /dev/ttyUSB1)
Logged

Vector Ver. 5.9 Standard GOLD built on Dec-16-07
Asus T2AE
AMD Sempron(tm) Processor 2800+
512 meg Ram
GeForce FX 5200 Video Card
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #6 on: April 29, 2008, 08:15:05 pm »

I just tried this fix and it works! Thanks so much.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
derrell
Member
*
Posts: 2


« Reply #7 on: April 30, 2008, 08:23:12 pm »

Glad it helped. 
If anyone is interested in writing their own udev rules to make external devices mount in the same location every time here is a link to a howto.
http://reactivated.net/writing_udev_rules.html

This is really handy for things like an mp3 player or usb hard drives that you use on a regular basis.
Logged

Vector Ver. 5.9 Standard GOLD built on Dec-16-07
Asus T2AE
AMD Sempron(tm) Processor 2800+
512 meg Ram
GeForce FX 5200 Video Card
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!