April 01, 2015, 02:07:32 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
Author Topic: xfce4-session crashes on startup  (Read 1715 times)
Posts: 10

« on: April 17, 2008, 02:55:26 am »

Hi all,

When I try to start xfce4-session the x-server starts and the "mouse" splash image briefly appears followed by the x-server stopping and the system reverting back to text mode.  Originally I had a full graphical login using KDM.  For some reason (which I now know was an upgrade of the QT shared libray) KDM stopped working and threw me back to text mode at boot up.  I could then start the graphical desktop with "startxfce4".  This eventually stopped working (giving the symptoms above) but I could still get xfce working with "startx" without system shutdown capability due to xfce4-session not running.  I've done a lot of experimentation over the last few days and the problem definitely seems to be xfce4-session.  At present I have the following in my ~/.xintrc:

#! /bin/sh

After text mode login I run xinit which runs the above script.  Everything works fine but as expected with no ability to shut down the system from the desktop.  I have version 4.4.0 of xfce installed running on VL5.8 standard.

Has anyone experienced this problem or can give some advice?


VL5.9-STD-GOLD: PIII 1.050GHz 384MB-RAM: 80GB,40GB,6GB HDD
Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!