VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Keyboard not Acting Properly  (Read 5651 times)

Pita

  • Vectorian
  • ****
  • Posts: 1342
Keyboard not Acting Properly
« on: April 12, 2008, 01:46:27 am »

While in X I seem to have problems with the keyboard.

-- In xterm, Alt-(some key) does not give special character,

-- setxkbmap ?? gives error: "Error loading new keyboard description",

-- Ctrl-Alt-F* has no reaction,

Startx gives:

syntax error: line 1 of pc
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            Error interpreting include file "pc"
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server
syntax error: line 1 of pc
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            Error interpreting include file "pc"
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server

I un/re-installed xkbcomp as well as xorg-server and it changed nothing.

-- vasmCC and vasm will not change keyboard setting while in X.

-- On console outside X vasm will change keyboard setting.

What could be amiss?

Thanks & regards
Logged

huz

  • Member
  • *
  • Posts: 1
Re: Keyboard not Acting Properly
« Reply #1 on: July 15, 2008, 12:10:31 pm »

hi there,
me and a friend of mine have similar problem:

we have two notebooks (hp omnibook vt6200, ibm thinkpad t22) and we have just installed VL Light Edition.

in X server special characters, activated by holding right Alt key, are not working.
Our keyboard layout is italian, then we have a lot of important chars that use right alt key.. like "@" "]" "[" and so on
Any ideas?

Thanks ;)
Logged

kidd

  • Packager
  • Vectorian
  • ****
  • Posts: 682
Re: Keyboard not Acting Properly
« Reply #2 on: July 15, 2008, 12:14:09 pm »

you can try to check /etc/X11/xorg.conf  manually.

here's my relevant part for my spanish keyboard

Code: [Select]
Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
Option     "XkbLayout" "es"    ## KEYBOARD_MAP!
Option     "XkbModel" "pc105"    ## KEYBOARD_MODEL!
Option     "Xkbvariant" ""    ## KEYBOARD_VARIANT!
EndSection

Pita

  • Vectorian
  • ****
  • Posts: 1342
Re: Keyboard not Acting Properly
« Reply #3 on: July 20, 2008, 08:39:49 pm »

Just when I wanted to move this old post of mine to Vectorphanage since there has been no reply I saw that it is up on the list.

I have an US keyboard. On suggestion if kidd I now added in /etc/X11/xorg.conf, Option     "XkbModel" "pc10l". Brought up X and nothing changed. Problem described in post persists. I wish it could be solved so I could move fully into VL59. As of now I am back in VL58 due to this keyboard fault.
Logged

Ben1000

  • Member
  • *
  • Posts: 9
Re: Keyboard not Acting Properly
« Reply #4 on: August 23, 2008, 03:26:46 am »

I have a simular problem. I have a FujitsuSimens C Series Lifebook with VL-Light 5.9 on it. The Keyboard works, but the Alt Gr Key don t work with the "at" and the "euro" sign. I have a German keyboard on the Laptop and I use the German Keymap. Anybody an Idea, what to do?
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1872
Re: Keyboard not Acting Properly
« Reply #5 on: August 23, 2008, 06:11:22 am »

Logged

Ben1000

  • Member
  • *
  • Posts: 9
Re: Keyboard not Acting Properly
« Reply #6 on: August 27, 2008, 10:30:01 am »

Sorry, that hints didn't worked for me. So I gave up and went back to the Standard Version and now everything is good.

Greets, Ben
Logged

Pita

  • Vectorian
  • ****
  • Posts: 1342
Re: Keyboard not Acting Properly
« Reply #7 on: August 27, 2008, 09:36:02 pm »

http://bbs.archlinux.org/viewtopic.php?id=53145

Bigpaws

Thanks!
Same with me tried all what is in that post and nothing doing. Will wait for VL-6.
Logged