VectorLinux
October 24, 2014, 11:38:37 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Cannot play audio cd's [Solved]  (Read 3302 times)
mntinman
Member
*
Posts: 3


« on: April 12, 2008, 12:09:31 pm »

Hi, this is my first post on this forum, so, hello everyone, great to be here.

Very happy with Vector 5.8, but one problem. I can't play audio cds on the cd player using e.g. audacious. I have a cd/dvd player and a cd/dvd burner (added after vector was installed). Everything works like a charm, playing videos, reading data cdroms, burning data/audio, even ripping audio cds. But i cannot use the player (or the burner) as a cd player.

I'm a bit of a hardware nitwit. Anybody any idea where i should look? - Thanx - mm

« Last Edit: April 14, 2008, 12:25:43 pm by nightflier » Logged
bigpaws
Vectorian
****
Posts: 1856


« Reply #1 on: April 12, 2008, 01:01:14 pm »

When you installed the CDROM did you use a wire to
connect from the player to the Motherboard?

Bigpaws
Logged
mntinman
Member
*
Posts: 3


« Reply #2 on: April 13, 2008, 05:12:05 am »

Connections to the cd player are:
1. data cable shared with the burner ; when i added the burner i set the player to slave and the burner to master. (the player was already there when i got the pc -- a writeoff from work).
2. "analog audio", shielded cable to motherboard
3. "digital audio", not connected! That's the problem, i guess?

Some more info: with the cdda-player command, most functions work, except playing tracks--
>cdda-player -p
error: connection error
error: command data missing

mm
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #3 on: April 13, 2008, 06:01:55 am »

The analog audio cable usually works fine, but you can eliminate the need for it by setting your player to use "digital audio extraction". In xmms I do this by clicking Options > Preferences > Audio I/O plugins > CD Audio Player > Configure > Play mode > digital audio extraction.
Logged
mntinman
Member
*
Posts: 3


« Reply #4 on: April 14, 2008, 08:43:59 am »

Thanks nightflyer. My first thought was: this will not help because it's the digital connection that is missing in my case, not the analog. But it appears that xmms can play it both ways (with the digital and the analog setting). Admittedly i'd deinstalled xmms because i preferred audacious, but i installed it again to see what happens.

Anyway i consider my problem solved. The problem with audacious is down to a plugin and cdda-player now also appears to play (in spite of error msgs).

Thanks nf and bp.
mm
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #5 on: April 14, 2008, 12:27:07 pm »

Very good. I'm marking this one as Solved then.   Smiley

I think "digital audio extraction" in xmms means it will read the sound track off the disc and process it, rather than making the optical drive pipe it through the connected audio cables.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!