VectorLinux
September 02, 2014, 11:20:27 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: Conky display help  (Read 9185 times)
Uta
Member
*
Posts: 20


« on: April 15, 2008, 04:04:21 pm »

I have downloaded and install the latest conky into my 5.9 Lite and need some help customizing it.
I have looked at the help docs but I am not getting my desired effect.

own_window yes
own_window_hints
own_window_transparent yes
undecorated,below,skip_taskbar

What I am trying to achieve is transparency and no taskbar.
I edited the /etc/conky/conky.conf

Is that the right file and how do I call this to load when the desktop mounts?
Thanks.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #1 on: April 15, 2008, 05:14:58 pm »

there should be a /home/_user_/.conkyrc but it's basically the same stuff. I have tried the same thing but never been successful in jwm or fluxbox. I know for a fact that lxde can do it
Logged

wcs
Packager
Vectorian
****
Posts: 1144


« Reply #2 on: April 15, 2008, 08:27:42 pm »

It looks like "own_window_hints" is missing, no?
EDIT: your "own_window_hints" is there, but is separated from the values by another line... maybe that's the problem.

This is what I have in my conky.conf, although this is for xfce:

Code:
own_window yes
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
double_buffer yes
draw_outline no
draw_borders no

The "own_window_type" option is commented. There might be a type that does almost the same as specifying those hints, but I think this yielded the best results.
I remember it working fine in fluxbox, but I'm not sure if I used these same options. Never got the transparency to work properly on kde, though...
« Last Edit: April 15, 2008, 08:29:41 pm by wcs » Logged
Uta
Member
*
Posts: 20


« Reply #3 on: April 16, 2008, 11:49:46 am »

Thank you it worked great and I do have transparency!

In order to get conky to be a startup item, which file should I add it to?
Thanks!
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #4 on: April 16, 2008, 12:59:46 pm »

Since we're on this thread, Does anyone know any way to force conky to stay on top of the desktop?
When I click the "Show Desktop" icon on the task bar, conky dissapears off the desktop... I know it's still running though, it just goes under the desktop.
Logged

toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #5 on: April 16, 2008, 01:40:00 pm »

Thank you it worked great and I do have transparency!

In order to get conky to be a startup item, which file should I add it to?
Thanks!

With Xfce, just have it running ('conky &' from a terminal or ALT-F2, 'conky'), then log off with the 'save for future sessions' box ticked. It will come back the next time you log in. For fluxbox, I edited it into ~/.fluxbox/init (I think, not on the VL box at the moment and I can't recall which file it went into...).

paul.
Logged
toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #6 on: April 16, 2008, 01:41:52 pm »

Since we're on this thread, Does anyone know any way to force conky to stay on top of the desktop?
When I click the "Show Desktop" icon on the task bar, conky dissapears off the desktop... I know it's still running though, it just goes under the desktop.

What desktop are you using - I've not had that problem with either Xfce or Fluxbox, but so far, I've not managed to avoid it if using KDE in the 5.9 SOHO beta. Very annoying... I'm on the dev mailing list, been meaning to ask if there is a suitable setting. I'll have to remember to send the developer a message.

paul.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #7 on: April 16, 2008, 02:22:46 pm »

I use LXDE but the desktop is really handled by pcmanfm.

__EDIT__
Never mind guys... I just found the answer to my own question...
You have to set this property in ~/.conkyrc

Code:
own_window_type desktop

Then it remains on top
« Last Edit: April 16, 2008, 03:00:24 pm by M0E-lnx » Logged

toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #8 on: April 16, 2008, 04:28:02 pm »

I use LXDE but the desktop is really handled by pcmanfm.

__EDIT__
Never mind guys... I just found the answer to my own question...
You have to set this property in ~/.conkyrc

Code:
own_window_type desktop

Then it remains on top

 Cry Thought that might be the answer for KDE (I'm trying to run Conky in the current SOHO beta). Unfortunately, I already had own_window_type desktop set. So I tried setting own_window to 'no'. Which got me a transparent Conky, but lost the rest of the desktop icons. If I set it back to 'own_window yes' it comes up with a black background rather than transparent, and gets lost as soon as I try to use the menus or run anything. Its still running, must not visible.

Oh well, I guess I'll have to read the man page again....

paul.
Logged
Uta
Member
*
Posts: 20


« Reply #9 on: April 16, 2008, 05:53:06 pm »

I am using 5.9 Lite beta 4
There is no save session option but there is "init"
"I edited it into ~/.fluxbox/init (I think, not on the VL box at the moment and I can't recall which file it went into...)"

what did you add exactly? Something like "conky & exit" ?
Thanks.
Logged
toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #10 on: April 16, 2008, 06:04:07 pm »

I am using 5.9 Lite beta 4
There is no save session option but there is "init"
"I edited it into ~/.fluxbox/init (I think, not on the VL box at the moment and I can't recall which file it went into...)"

what did you add exactly? Something like "conky & exit" ?

Right, I can access the Vector machine now. And I was wrong, its not 'init'. I edited ~/.fluxbox/startup. At the bottom of the file, I have this:

Code:
xfce-mcs-manager
~/.bluxbox/startwbar &
conky &
exec /usr/bin/fluxbox

I use a script to start wbar, then start conky, then start fluxbox itself. That should get it running on startup for you. You can ignore the wbar stuff - I use it because I want to customize the icon sizes and a few other things, so I don't use the standard Vector vlbar script.

paul.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #11 on: April 16, 2008, 06:16:30 pm »

after some more testing I found out that this does not really solve my issue. So the search 4 an answer continues
Logged

toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #12 on: April 16, 2008, 06:34:55 pm »

after some more testing I found out that this does not really solve my issue. So the search 4 an answer continues

I've found a partial answer to my problem with KDE. By changing own_window_type from desktop to override, Conky is no longer vanishing when I click things on the desktop, and its also not hiding desktop icons. However, I've now got the problem that its not using its normal transparency. After a bit of reading, its sounds as though I need something like Esetroot (which is in VL (well, SOHO at least), but which I have no idea how to configure) or feh. feh looks like the best bet, but it isn't in SOHO, so I may have to see if I can get it to build. I'll post if I can get it to work...

paul.
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #13 on: April 17, 2008, 06:24:22 am »

Quote
With Xfce, just have it running ('conky &' from a terminal or ALT-F2, 'conky'), then log off with the 'save for future sessions' box ticked. It will come back the next time you log in.

A possibly better way in Xfce is to go to settings and Autostarted applications, and make an entry for conky.
The save for future sessions might save stuff you don't want to save, and I remember some old problems with it (maybe solved now, but I got into the habit of never saving sessions).
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #14 on: April 17, 2008, 06:29:46 am »

I remember having a very hard time with trying to get it to work properly with kde. Either the transparency, or the colours, or the icons always got screwed up.
I tried it with 5.8 so at the time, so I don't think esetroot or feh were in the repos, and ended up forgetting about it.

Let us know if it works... I think this is a very old problem with conky (or with KDE) due to the desktop being drawn over the root window... or something.
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!