VectorLinux
November 25, 2014, 01:47:46 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: Cannot Play DVDs  (Read 4770 times)
divot55
Member
*
Posts: 4


« on: April 18, 2008, 07:16:34 pm »

Installed VL Standard Gold  today and love it except for not being able to play dvds on  either of my dvd players. Get a `no stream found to handle the url dvd with mplayer and xine also. VASMCC shows them as being recognized by VL. I`m pretty much a novice with Linux.  Thanks  Any suggestions would be appreciated.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4030



« Reply #1 on: April 18, 2008, 07:32:37 pm »

I take it you have multiple optical drives in your machine.
As root, in a terminal, run command: probedisk You should see something like:
Code:
/dev/hdc|cdrom|SONY DVD RW AW-Q170A
/dev/hdd|cdrom|NEC CDROM
now enter mcedit /etc/fstab, scroll down until you find this section:
Code:
# CDROM, CDWRITER, DVD
/dev/cdrom    /mnt/cdrom        iso9660 defaults,noauto,ro,user 0 0
#/dev/cdwriter /mnt/cdwriter    iso9660 defaults,noauto,rw,user 0 0
#/dev/dvd      /mnt/dvd         auto    defaults,noauto,ro,user 0 0

Using the information from the first command, change as appropriate. In this case it would be:
Code:
# CDROM, CDWRITER, DVD
/dev/hdd    /mnt/cdrom        iso9660 defaults,noauto,ro,user 0 0
#/dev/cdwriter /mnt/cdwriter    iso9660 defaults,noauto,rw,user 0 0
/dev/hdc      /mnt/dvd         auto    defaults,noauto,ro,user 0 0

Hit F2 to save, F10 to exit and try playing your DVD again.


Logged
divot55
Member
*
Posts: 4


« Reply #2 on: April 18, 2008, 08:11:06 pm »

I did what you suggested and I still get the same result.
Logged
divot55
Member
*
Posts: 4


« Reply #3 on: April 18, 2008, 08:25:05 pm »

Oddly enough I can open  the disc from the desktop and play each  individual vts video file in xine. But if I open Xine and attempt to play the dvd i get the cannot find stream error.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4030



« Reply #4 on: April 19, 2008, 04:32:01 am »

Try opening Xine, go to Settings > Setup > Media > scroll down to "device used for DVD playback" and enter the /dev/hd.. value for your DVD drive.
Logged
divot55
Member
*
Posts: 4


« Reply #5 on: April 19, 2008, 09:48:25 am »

 "> Setup > Media > scroll down to "device used for DVD playback"  My version of xine does not have this option. Not sure what you mean.  By the way my external dvd burner/player plays dvds with no problem,  but it`s not a solution to my problem.  Thanks for the help so far. 
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4030



« Reply #6 on: April 20, 2008, 05:48:15 am »

You may need to set your "configuration experience level" (in setup) to "Master of the known universe".
Logged
cyberbillp
Member
*
Posts: 4


« Reply #7 on: June 24, 2008, 06:16:45 pm »

Out of the blue, this exact problem started happening to me.

I'd recently loaded scratchbox which requires a new group, and that the user be added to the group.

I'm guessing that when I did this it wiped out all my group memberships. Since Vector doesn't have a user editor, (that lets you edit group memberships) I went in and re-added my account to all the proper groups in /etc/groups .

This fixed missing reboot/shutdown buttons, dvd playback and god knows what else.

Is this a bug? I did this:
usermod -G newgroup username
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2290


« Reply #8 on: June 24, 2008, 06:38:58 pm »

Out of the blue, this exact problem started happening to me.

I'd recently loaded scratchbox which requires a new group, and that the user be added to the group.

I'm guessing that when I did this it wiped out all my group memberships. Since Vector doesn't have a user editor, (that lets you edit group memberships) I went in and re-added my account to all the proper groups in /etc/groups .

This fixed missing reboot/shutdown buttons, dvd playback and god knows what else.

Is this a bug? I did this:
usermod -G newgroup username

Is not a bug, usermod works in that way, from man usermod:

Quote
-G group,[...]
              A  list  of supplementary groups which the user is also a member of.  Each group is separated from the next by a comma, with no intervening whitespace.  The groups are subject to the same restrictions as the group given with the -g option.  If the user is currently a member of a group which is not listed, the user will be removed from the group

A bit annoying, but I guess the author used to remove users from groups very often.
« Last Edit: June 24, 2008, 06:41:43 pm by rbistolfi » Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
Penguinista
Guest
« Reply #9 on: November 02, 2010, 06:24:42 pm »

I am having the same problem with VectorLinux 6.0 Standard (Deluxe) on a HP Pavilion dv9408ca Laptop. On a previous installation of VL6Std, my video DVDs would automount, open Xine and start playing no problem. Now with my reinstallation this only happens rarely. Most DVDs won't play.

I am using HAL. A search reveals that the libdvdread, libdvdcss and libdvdnav codecs are installed.

I ran probedisk and received these results:

root:# probedisk
/dev/hda|cdrom|TSSTcorpCD/DVDW TS-L632M
/dev/sda|Direct-Access|ATA      FUJITSU MHW2160B

Next, I edited Fstab to read as follows:

# CDROM, CDWRITER, DVD
/dev/hda    /media/cdrom  iso9660  defaults,noauto,ro,user  0 0
#/dev/cdwriter /media/cdwriter  iso9660  defaults,noauto,rw,user  0 0
/dev/hda      /media/dvd   auto  defaults,noauto,ro,user  0 0

Finally, I changed the setting in Xine setup > media > device used for DVD playback to:

/dev/hda

After an Xine reboot, my (store bought movies ) video DVDs still won't mount or play via Xine.

I receive this Xine error message:

"The source can't be read. Maybe you don't have enough rights for this, or source doesn't contain data (e.g: not disc in drive). (/dev/hda) . . . cannot find input plugin for MRL [dvd:/] . . ."

Where do I go from here?
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4030



« Reply #10 on: November 03, 2010, 03:21:58 am »

Where do I go from here?

Try opening a terminal and launch xine from it. Watch the terminal for messages when you experiment. Does the drive spin up and access light illuminate when you try this?
Logged
Penguinista
Guest
« Reply #11 on: November 03, 2010, 02:43:51 pm »

After loading a DVD, I can hear the DVD player chugging away trying to read the DVD with the access light flashing but (usually) the system does not mount the DVD. Rarely and at random, it does mount the DVD though.

I opened a terminal as user and typed xine and received this info:

richard:$ xine
This is xine (X11 gui) - a free video player v0.99.5.
(c) 2000-2007 The xine Team.
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdread: Could not open /dev/hda with libdvdcss.
libdvdread: Can't open /dev/hda for reading
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdread: Could not open /dev/hda with libdvdcss.
libdvdread: Can't open /dev/hda for reading

I also received the usual Xine errors:  "The source can't be read. Maybe you don't have enough rights for this, or source doesn't contain data . . ." and "There is no input plugin available to handle 'dvd:/'. Maybe MRL syntax is wrong or file/stream source doesn't exist".
Logged
Penguinista
Guest
« Reply #12 on: December 12, 2010, 12:23:36 pm »

I've tried just about everything to get DVDs playing without success. CDs play no problem. Could it be the libdvd codecs are out of date. Or perhaps, the DVD player is at end of life?
Logged
bigpaws
Vectorian
****
Posts: 1857


« Reply #13 on: December 12, 2010, 12:42:35 pm »

Change your xine back to /media/dvd

/dev/hda is owned by root.  Also open a
terminal and type groups.

Post the output here.

Bigpaws
Logged
Penguinista
Guest
« Reply #14 on: December 18, 2010, 04:28:51 pm »

Bigpaws,

I changed Xine setup back to /media/dvd. Here is the output of the groups command:

vector:/~
richard:$ groups
richard disk lp floppy audio video cdrom games slocate plugdev scanner users
vector:/~
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!