VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: [SOLVED] have to get rid of screensaver!!!  (Read 5035 times)

vdb

  • Member
  • *
  • Posts: 22
[SOLVED] have to get rid of screensaver!!!
« on: April 22, 2008, 03:37:12 am »

hi guys,

my vectorlinux pc on the servicedesk shows a live picture of the network, we could see on this monitor if there are errors.
the screensaver jumps on after several minutes, that is not the intension.

how to disable the screensaver?
« Last Edit: May 19, 2008, 03:50:14 am by vdb »
Logged
Vector Linux 5.8 SOHO

kc1di

  • Packager
  • Vectorian
  • ****
  • Posts: 1125
  • Morse Code Early digital mode. John 3:16
Re: have to get rid of screensaver?
« Reply #1 on: April 22, 2008, 03:47:03 am »

Which version of VL are you using?
 
Logged
Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608

vdb

  • Member
  • *
  • Posts: 22
Re: have to get rid of screensaver?
« Reply #2 on: April 22, 2008, 03:49:37 am »

VL 5.8 SOHO
Logged
Vector Linux 5.8 SOHO

vdb

  • Member
  • *
  • Posts: 22
Re: have to get rid of screensaver!!!
« Reply #3 on: May 08, 2008, 05:52:15 am »

Anyone?  ::)
Logged
Vector Linux 5.8 SOHO

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: have to get rid of screensaver!!!
« Reply #4 on: May 08, 2008, 06:43:03 am »

I know how in Standard and was about to post about it the other day. But realized you were talking SOHO.
I'm positive the procedure wouldn't apply.  Because in Standard, it's in a xfce specific file.
Logged

kc1di

  • Packager
  • Vectorian
  • ****
  • Posts: 1125
  • Morse Code Early digital mode. John 3:16
Re: have to get rid of screensaver!!!
« Reply #5 on: May 08, 2008, 07:33:01 am »

Anyone?  ::)

It's been awhile since i've used 5.8 SOHO,  But if it's the kde screen saver you can simply right click on a bare spot on the desktop >configure Desktop > ScreenSavers > uncheck the box labled start screen saver after ____ minutes.  That should disable it for you.

Logged
Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608

vdb

  • Member
  • *
  • Posts: 22
Re: have to get rid of screensaver!!!
« Reply #6 on: May 14, 2008, 05:47:17 am »

I know how in Standard and was about to post about it the other day. But realized you were talking SOHO.
I'm positive the procedure wouldn't apply.  Because in Standard, it's in a xfce specific file.

which specific file is it in standard? because i use xfce to controll my desktop
« Last Edit: May 14, 2008, 05:49:59 am by vdb »
Logged
Vector Linux 5.8 SOHO

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: have to get rid of screensaver!!!
« Reply #7 on: May 14, 2008, 07:59:19 am »

in /etc/xfce/xdg/xfce4/xinitrc

find:
Code: [Select]
# Launch xscreensaver (if available), but only as non-root user
if test $UID -gt 0 -a -z "$VNCSESSION"; then
    if test x"`which xscreensaver 2>/dev/null`" != x""; then
        xscreensaver -no-splash &
    elif test x"`which gnome-screensaver 2>/dev/null`" != x""; then
        gnome-screensaver &
    fi
fi

They are lines 56 through 63 in VL5.9 Standard.  Comment them out or delete if you think you will never change your mind.
Logged

vdb

  • Member
  • *
  • Posts: 22
Re: have to get rid of screensaver!!!
« Reply #8 on: May 16, 2008, 03:19:38 am »

thanks for your reply
it didn't work for me, maybe other user could use it...


has anyone else a solution for this problem??
Logged
Vector Linux 5.8 SOHO

overthere

  • Vectorian
  • ****
  • Posts: 1364
Re: have to get rid of screensaver!!!
« Reply #9 on: May 16, 2008, 04:36:17 am »

Hi
Are you refering to screen saver or screen blanking...I find in vl-std and light that the screen goes black after ten minutes..I add this to the fluxbox menu to toggle on and off.. you can type xset s off in a terninal and I think add to the bottom of /etc/rc.d/rc.local to exec at boot

        [exec] (Screenblank Off) {xset -dpms & xset s off}
        [exec] (Screenblank ON) {xset dpms & xset s on}

if you use the xfce gui the try kc1di's way to turn off the animated screen savers or from the saver dialog /file/ kill  deamon
hope that helps

cheers

« Last Edit: May 16, 2008, 04:46:25 am by overthere »
Logged
Everything Is Relative

vdb

  • Member
  • *
  • Posts: 22
Re: have to get rid of screensaver!!!
« Reply #10 on: May 16, 2008, 07:56:35 am »

yes the screen goes black after ten minutes
xset s Off didn't do anything, after ten minutes i have a black screen again

kc1di's way to turn off the animated screen savers didn't work either.

or from the saver dialog /file/ kill  deamon

what do you mean?
Logged
Vector Linux 5.8 SOHO

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2317
Re: have to get rid of screensaver!!!
« Reply #11 on: May 16, 2008, 10:57:14 am »

Backup your current -annoying but working- configuration, open a console and su to root, then:

Code: [Select]
cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
Then open the file with your favorite editor, for example:

Quote
mousepad /etc/X11/xorg.conf

Add / replace this options in your /etc/X11/xorg.conf file in the ServerLayout section:

Quote
Option "BlankTime" "0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"

Save and exit. Close all your windows and restart the X server with ctrl + alt + backspace.
Wait ten minutes and see :P
If after restarting de x server you find any problems and your desktop is not back, no worries. Login as root again with the su command and:

Code: [Select]
cp /etc/X11/xorg.conf_backup /etc/X11/xorg.conf
exit
startx

Let us know how it goes.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

overthere

  • Vectorian
  • ****
  • Posts: 1364
Re: have to get rid of screensaver!!!
« Reply #12 on: May 16, 2008, 01:18:56 pm »

xset -dpms & xset s off.. via terminal will work to stop screen blanking for a single unit perhaps  a networked unit is different. you can type xset in a terminal  to see a list of xset commands

the referance to /file/kill deamon  refers to the xscreensaver deamon which  has nothing to do with screen blank..I was still not sure which was your issue

perhaps the above post is more helpfull

cheers
Logged
Everything Is Relative

vdb

  • Member
  • *
  • Posts: 22
Re: have to get rid of screensaver!!!
« Reply #13 on: May 19, 2008, 03:48:34 am »

Backup your current -annoying but working- configuration, open a console and su to root, then:

Code: [Select]
cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
Then open the file with your favorite editor, for example:

Quote
mousepad /etc/X11/xorg.conf

Add / replace this options in your /etc/X11/xorg.conf file in the ServerLayout section:

Quote
Option "BlankTime" "0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"

Save and exit. Close all your windows and restart the X server with ctrl + alt + backspace.
Wait ten minutes and see :P
If after restarting de x server you find any problems and your desktop is not back, no worries. Login as root again with the su command and:

Code: [Select]
cp /etc/X11/xorg.conf_backup /etc/X11/xorg.conf
exit
startx

Let us know how it goes.

i am running the live picture off the network for 1h and still no black screen :) :)

thanks for your help :D
« Last Edit: May 19, 2008, 07:33:48 am by vdb »
Logged
Vector Linux 5.8 SOHO