VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Unable to upgrade vasm, vlnvidia, xarchiver, xine-lib, xine-ui  (Read 2393 times)

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144

Apologies if this has been raised elsewhere.

I've been unable to upgrade the following packages:
vasm, vlnvidia, xarchiver, xine-lib, xine-ui

(xarchiver, xine-lib, and xine-ui are in testing)

I get the following errors:

vasm: Depends:   pkgtools
vlnvidia: Depends: vlsetup >= 5.0
xarchiver: Depends: cairo-1.4.12 >= i486
pulseaudio: Depends: orbit2-2.14.8-1vl59 >=

I've been unable to locate vlsetup in the repos. Pkgtools is installed, but it does not seem to be enough. For cairo and pulseaudio, it seems that the version number is getting messed up (pulseaudio being a dependency of xine-lib and xine-ui).

EDIT: Using VL 5.9 Standard Deluxe, with packages, extras, testing and patching enabled.
Logged

budulay

  • Packager
  • Vectorian
  • ****
  • Posts: 568
  • NewComer
Re: Unable to upgrade vasm, vlnvidia, xarchiver, xine-lib, xine-ui
« Reply #1 on: April 22, 2008, 10:43:10 am »

Hi
I experienced kind of the same error, while trying to update vasm.
also messed up my vpackager. I updated it, but when I am trying to edit existing packages, it sais that pkgtools isn't installed and then crash.
tkgtools is installed.


ADDED:
I installed new vpackager and vasm ant it eliminated the error.
« Last Edit: June 10, 2008, 08:22:15 pm by budulay »
Logged
VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: Unable to upgrade vasm, vlnvidia, xarchiver, xine-lib, xine-ui
« Reply #2 on: June 10, 2008, 07:57:15 pm »

Xine-lib and xine-ui now solved.

vasm still fails, depending on pkgtools (the installed package and in the repos is pkgtools-tukaani)
xarchiver still fails, depending on cairo-1.4.12 >= i486 (version number is wrong, but in any case I could only find cairo-1.4.10 in my box)
pulseaudio still fails, depending on orbit2-2.14.8-1vl59 >= (no version number there)
vlnvidia still fails, depending on vlsetup >= 5.0

Thanks.
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: Unable to upgrade vasm, vlnvidia, xarchiver, xine-lib, xine-ui
« Reply #3 on: June 14, 2008, 08:23:47 am »

The vasm issue was raised on the pacakgers' forum.  It turns out that isn't an upgraded.  It's a mislabeled old version.  The repository managers are aware of it and that should be corrected shortly.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Unable to upgrade vasm, vlnvidia, xarchiver, xine-lib, xine-ui
« Reply #4 on: June 14, 2008, 10:26:34 am »

All the reported packages should be fixed in the repo now.

Thanks for your help in making the repo better,
Uelsk8s
Logged

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: Unable to upgrade vasm, vlnvidia, xarchiver, xine-lib, xine-ui
« Reply #5 on: June 14, 2008, 11:15:05 am »


Thank you!
Everything works now.

However, even though there is no upgrade for vasm now, the current package in the repo gives the same error (depending on pkgtools).
This can be a problem if re-installing this package.
Logged

joec

  • Member
  • *
  • Posts: 29
Re: Unable to upgrade vasm, vlnvidia, xarchiver, xine-lib, xine-ui
« Reply #6 on: December 02, 2008, 09:43:33 am »

Still gives this error .
Logged