VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: 1 [2]

Author Topic: vpackager-1.0.11 has been released!  (Read 9196 times)

sparkyhall

  • Vectorite
  • ***
  • Posts: 118
Re: vpackager-1.0.11 has been released!
« Reply #15 on: June 11, 2008, 01:58:56 pm »

Hi MOE,

I've only just seen your reply so I went to file a bug report and it seems you've already done it so thanks for that.

I'd just like to say apps like VASMCC and vpackager make a huge difference to linux noobs like myself so a big thanks to you and all the other contributors. I will of course keep an eye open for new releases and help with the testing where I can.

Chris
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: vpackager-1.0.11 has been released!
« Reply #16 on: June 11, 2008, 02:06:24 pm »

I appreciate you guys testing...

I really need testers badly.... so all contributions bug reports are welcome via the project page.
a lot of times I'll fill them out myself as notes to myself, but you guys can do them too. In fact, I'd rather you guys reported bugs there.

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: vpackager-1.0.11 has been released!
« Reply #17 on: June 11, 2008, 04:42:42 pm »

Thanks for doing it, M0E.
I've submitted the other bug and an additional suggestion.

Quote
In the 1.0.12 release (not released yet) I have enabled the build script writer function. This will generate a script with all the commands necessary to build the same package using whatever the user input was for that one application.
Also, in that release, before the build process begins, vpackager will play information such as application details, CFLAGS to be used, configure options and stuff like that.

"Build script writer function"... sweet.
Logged

Dweeberkitty

  • Packager
  • Vectorian
  • ****
  • Posts: 836
    • Multimedia Bonus Disc
Re: vpackager-1.0.11 has been released!
« Reply #18 on: June 11, 2008, 07:54:01 pm »

I appreciate you guys testing...

I really need testers badly.... so all contributions bug reports are welcome via the project page.
a lot of times I'll fill them out myself as notes to myself, but you guys can do them too. In fact, I'd rather you guys reported bugs there.

MOE-lnx, I'm sorry. I understand how it feels to have too few testers (MMBD). I don't use vpackager very much but I do recommend it to new VL users so I will try to do my best to submit any bugs I find.
Logged
Registered Linux User #443399
Desktop: Intel Pentium D 3.33Ghz, 320GB hard drive, 2 gigs DDR2 533mhz RAM, NVIDIA Geforce 7800 GS, X2GEN 22" widescreen monitor;
Laptop: Dell Mini 9, Intel Atom 1.6Ghz, 1GB ram
Multimedia Bonus Disc website: http://www.vectorlinuxsolutions.com/

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: vpackager-1.0.11 has been released!
« Reply #19 on: June 12, 2008, 05:55:24 am »

I've submitted the other bug and an additional suggestion.


Sweet!..

I really appreciate that dude...
Keep 'em comin'

edgeofthewoods

  • Member
  • *
  • Posts: 62
Re: vpackager-1.0.11 has been released!
« Reply #20 on: August 17, 2008, 06:49:21 pm »

Hi there. This is my first post here. Been around linux for a few years, Debian and RPM distros and Sabayon. This is my first Slackware based and it is great. But I am having this problem. I posted it to tech support and was asked to post it here.

System specs:
SOHO 5.9 with media files.
AMD 5200 4 gigs of ram 750 gig HD Nividia 6100 chipset.

Please post that question on the website. You can use this
thread:

http://forum.vectorlinux.com/index.php?topic=6144.0

Karl

Chuck Hudson via IM wrote:
> > Sun Aug 17 11:05:06 2008: Request 243 was acted upon.
> > Transaction: Ticket created by grundair@gmail.com
> >        Queue: support
> >      Subject: VPACKAGE Errors
> >        Owner: Nobody
> >   Requestors: grundair@gmail.com
> >       Status: new
> >  Ticket <URL: https://vector.ecosq.com:$WebPort/im/Ticket/Display.html?id=243 >
> >
> >

> >

> >
> > Hello. Sorry to keep bothering, but this is my first time with a slack
> > based distro.
> >
> > I am geting this error with Vpackage.
> >
> > This application raised and unexpected error an must abort.
> >
> > [45] file or directory does not exist
> > FText editor .?0
> >
> > Getting this error I clicked Edit Build Script on the main page where
> > the buttons have display available and Update ports and Build current.
> >
> >
> > The next error is:
> >
> > This application raised and unexpected error an must abort.
> > [-1] key already used:'chw.a'
> > MdlCruxFunctions.?.0
> >
> > What I did before those errors happened is I added souses to the
> > repsoitory through the GUI of Vpackager.
> >
> > Thanks
> >
> > Chuck Hudson Edgewood NM
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: vpackager-1.0.11 has been released!
« Reply #21 on: August 20, 2008, 06:06:22 am »

Can you tell us which version this is? and which repositores you enabled

edgeofthewoods

  • Member
  • *
  • Posts: 62
Re: vpackager-1.0.11 has been released!
« Reply #22 on: August 20, 2008, 06:17:05 am »

Can you tell us which version this is? and which repositores you enabled

It is vpackager 1.0.11, the version that came with my new 5.9 soho. I at first enabled all of them, then I got errors. I then went back to the Vector only ones. Sorry I am at work on my Mandriva laptop so I can't check.


Chuck
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: vpackager-1.0.11 has been released!
« Reply #23 on: August 20, 2008, 06:42:19 am »

Ok. when you get a chance... Check it and let me know what causes the error.
also, try running it from a terminal window as root and post any output in that terminal here after the program has crashed

edgeofthewoods

  • Member
  • *
  • Posts: 62
Re: vpackager-1.0.11 has been released!
« Reply #24 on: August 20, 2008, 07:43:53 am »

Ok. when you get a chance... Check it and let me know what causes the error.
also, try running it from a terminal window as root and post any output in that terminal here after the program has crashed
Thanks!  The error is caused when ever I click List Avaiable I get the error I posted.

Chuck
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: vpackager-1.0.11 has been released!
« Reply #25 on: August 20, 2008, 07:53:56 am »

I'd like you to fill out a bug report for this... This is the first time I hear this..

Please visit
http://developer.berlios.de/projects/vpackager/
Click on "BUGS" and create a new report.
I'm currently busy with another project ATM, A report there will help me pin-point the problem.

Thank you

edgeofthewoods

  • Member
  • *
  • Posts: 62
Re: vpackager-1.0.11 has been released!
« Reply #26 on: August 23, 2008, 06:26:42 pm »

Hey folks. Stupid question. What if I remove vpackager and re-install it? I've tried it once but when I reload it i get the same error. I removed by

slapt-get --remove vpackager

Thanks
Chuck
Logged

edgeofthewoods

  • Member
  • *
  • Posts: 62
Re: vpackager-1.0.11 has been released!
« Reply #27 on: August 23, 2008, 06:31:26 pm »

Ok. when you get a chance... Check it and let me know what causes the error.
also, try running it from a terminal window as root and post any output in that terminal here after the program has crashed

Sorry for the delay but here is the CL results

thrudheim://home/chuck1
root:# vpackager
MdlCruxFunctions.?.0: Key already used: chw.a
WARNING: circular references detected
FrmPorts (1)
FMain (1)
Mutex destroy failure: Device or resource busy
thrudheim://home/chuck1
root:#             


Most likely something stupid I did!!:)

CHuck
Logged

blurymind

  • Packager
  • Vectorian
  • ****
  • Posts: 1082
Re: vpackager-1.0.11 has been released!
« Reply #28 on: February 13, 2009, 09:43:25 am »

alright. I found a bug in vpackager 1.0.11. It does not save packages built from compressed source.
I tried to make a ristretto package and it compiled it successfully,but i couldnt find it on the desktop,where i told vpackager to put it.

I also tried to build it from cruxports and it compiled fine,but then it didnt install,giving me the following error:
ERROR: File not found: /usr/ports/VL/ristretto/ristretto-0.0.7-i586-1vl60.tlz
FAILED
 when i looked at it log,i saw that it gave it a different name,from the one i wanted (vl6):
Building '/usr/ports/VL/ristretto/ristretto-0.0.7-i586-1vl59.tlz' succeeded.

i looked if that file exists,and it does..so i had to copy it and rename it by hand
Sorry for being absent for some time. I'm back and willing to help however i can to make this tool one of VEc's killer apps. I think that bugs such as this should be fixed before it gets into VL6 gold- thats when alot of people will start downloading and trying it alot ..
« Last Edit: February 13, 2009, 10:00:28 am by blurymind »
Logged
status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/
Pages: 1 [2]