VectorLinux
October 01, 2014, 02:27:04 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Problem with newly created account (solved, but something strange in here)  (Read 1696 times)
demigaucher
Member
*
Posts: 58


« on: May 01, 2008, 05:51:03 am »

Hi all

I want to report the following problem.

I wanted to create an account "guest", with password "guest" on my private machine,
under VL 5.9 gold. I used VASM:

menu > system > VASM; I selected "super", typed the root password, then "user", then
"add", and finally could type the new username, and twice its password. I then exited
carefully from VASM.

After half a minute a small window popped up, informing me that the new account was
created. So far, so good.

Then I opened a console (under my ordinary user account), typed "su guest", was asked for
the password; I typed it, and... the login was refused ! (with a "sorry" message and a smiley).
I tried three times with the same result: so no mistyping can be invoked.

I then typed "su" and the root password, to inspect the file /etc/shadow  and I discovered that
in the "guest" line, the crypted password was replaced by a "!" character.

Huh  where have guest's  password gone ?

I could easily get out of trouble: editing /etc/shadow (as root), and removed this infamous "!"
character (leaving a zero-length sting in its place). Then, in another console I could type
"su guest" and enter the account without any password; then, from inside, I finally changed
it (using the "passwd" command).

So the problem is solved, but what the hell did happen ? Did I do something wrong ? or is
there some undocumented security measure at work here ?

Apart from this small problem, VL5.9 gold is a pleasure to use !

Demigaucher
Old pentium 3 @ 700 MHz, 384 Mo ram





Logged
overthere
Vectorian
****
Posts: 1281



« Reply #1 on: May 01, 2008, 07:28:16 am »

sooo...you easily added a second user account and the first user can not access the second users account.....but you can log in to both with there passwords at the log in screen or log in as root and edit both..sounds good to me.
« Last Edit: May 01, 2008, 07:43:02 am by overthere » Logged

Everything Is Relative
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #2 on: May 01, 2008, 08:04:43 am »

It works fine here. I would suggest you must have typed something in wrong or did not go through the prompts correctly. Go back in to vasm, remove that user and try again.
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
demigaucher
Member
*
Posts: 58


« Reply #3 on: May 01, 2008, 12:45:44 pm »

Hi Overthere, hi Lagagnon

Thanks for answering. I found what was wrong:

1. I could repeat the problem, creating other new users; each time the corresponding
encrypted password in /etc/shadow was a "!" character and login was impossible.
So the problem is real and reproducible.

2. I installed a new vectorlinux 5.9 in a spare partition, and immediately created a
new user: no problem (I could login with "su" and its pasword; the encrypted password
in /etc/shadow was not any longer the fatal "!" character).

3. Because I already observed similar problems in the past, I suspected the cause could be
the change from english to other language; to check, in this fresh installation, I modified
/etc/profile.d/lang.sh: in line 8, I changed  "export LANG=en_US" to "export LANG=fr_FR.UTF-8"
as explained in VL forum at:

https://vector.ecosq.com/ic/FAQs#head-4aacfc6369166b69a01a4976f4e3151f4a581404

and attempted then to create a new user: bingo ! impossible to login, and the cursed "!"
character appeared again in /etc/shadow.

So the problem lies in some mysterious incompatibility with LANG=fr_FR.UTF-8

By the way, some comments in /etc/profile.d/lang.sh warn about UTF-8:

  # There is also support for UTF-8 locales, but be aware that
  # some programs are not yet able to handle UTF-8 and will fail to
  # run properly.  In those cases, you can set LANG=C before
  # starting them.  Still, I'd avoid UTF unless you actually need it.

Since UTF-8 is optional, I'll make an attempt with "LANG=fr_FR" ...
 
... and wait for some smoke from the display...

Demigaucher
Old P3 @ 700 MHz
Logged
overthere
Vectorian
****
Posts: 1281



« Reply #4 on: May 02, 2008, 02:47:56 pm »

Hope the smoke clears rapidly..I have english so did not see the issue, perhaps the post will be of value to others also
cheers
Logged

Everything Is Relative
demigaucher
Member
*
Posts: 58


« Reply #5 on: May 03, 2008, 11:33:09 am »

Well, the smoke has now definitely cleared:

I tried with    "export LANG=fr_FR"     (i.e. without UTF-8), rebooted to be
sure it has been taked into account, then created a new user with VASM:
the machine refused to boot in that user's account, and the infamous
"!" appeared in /etc/shadow.

Counter-test: I commentarized "export LANG=fr_FR" and changed it to
"export LANG=en_US", rebooted, and it was possible to create a completely
functional new user !

Conclusion: for some unknown reason, creating users with VASM is not compatible
with (at least) some non-english languages: back to good old console again and
"useradd" command !

Demigaucher
Old Pentium 3 @ 700 MHz, 384 Mo ram 



Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!