Please support VectorLinux!

Author Topic: Only USB Mouse Recognized  (Read 1262 times)

Martin109

  • Vectorite
  • ***
  • Posts: 290
Only USB Mouse Recognized
« on: May 05, 2008, 10:25:22 am »
Setting up VL 5.8 SOHO on a new HP laptop for a friend, it's not recognising the built-in pad and button, only a USB mouse.  I tried rebooting without the USB fitted, which didn't work.  I tried using VASM to reconfigure the system with the laptop-specific mouse option, but still no response from the built-in hardware.  Any ideas? :-\
Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

bigpaws

  • Vectorian
  • ****
  • Posts: 1868
Re: Only USB Mouse Recognized
« Reply #1 on: May 05, 2008, 06:32:47 pm »
Change /etc/X11/xorg.conf to mouse IMPS/2

Bigpaws

Martin109

  • Vectorite
  • ***
  • Posts: 290
Re: Only USB Mouse Recognized
« Reply #2 on: May 08, 2008, 09:56:52 am »
Change /etc/X11/xorg.conf to mouse IMPS/2
Bigpaws

Thanks, Bigpaws

I've now had another look at the xorg.conf file, and the entry looks like this:

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option       "Protocol" "auto"
Option       "Device" "/dev/mouse"
Option       "ZAxisMapping" "4 5"
EndSection


Which bit(s) should I change?  Tried changing Driver  "mouse" to  Driver "IMPS/2", but that didn't work.

Tried changing it via VASM, but that didn't work, even after reboot.
« Last Edit: May 08, 2008, 10:07:41 am by Martin109 »
Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Martin109

  • Vectorite
  • ***
  • Posts: 290
Re: Only USB Mouse Recognized
« Reply #3 on: May 09, 2008, 12:24:22 pm »
Bump!
Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

bigpaws

  • Vectorian
  • ****
  • Posts: 1868
Re: Only USB Mouse Recognized
« Reply #4 on: May 09, 2008, 01:11:57 pm »
"Protocol" "IMPS/2"

see if that works, you may also have to change /dev/mouse to
/dev/input/mice.

HTH

Bigpaws

Martin109

  • Vectorite
  • ***
  • Posts: 290
Re: Only USB Mouse Recognized
« Reply #5 on: May 09, 2008, 01:51:15 pm »
Thanks, Bigpaws.

I've made both those changes, but unfortunately still no change! :-\
Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard