VectorLinux
September 18, 2014, 05:16:54 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: Setting up VL 5.8 with an Epson Printer - SOLVED  (Read 2686 times)
Martin109
Vectorite
***
Posts: 289


« on: May 04, 2008, 06:21:50 am »

I'm running VL 5.8 Standard.
My printer is Epson Stylus Photo 890.

I've downloaded a file called gutenprint-5.0.1-1lsb3.1.i486.rpm

What are the next steps I need to take to be able to print?  I've looked at a few help pages, but don't really understand what they're telling me.

Is there a simple Vectorbie's step-by-step guide?

« Last Edit: May 09, 2008, 12:22:34 pm by Martin109 » Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
nightflier
Administrator
Vectorian
*****
Posts: 4023



« Reply #1 on: May 04, 2008, 06:44:33 am »

Preferred way to install software would be to use the gslapt package manager. It should be on your start menu. Hit the refresh button and then search for your package.

Next choice should be manual install of packages for your distro. Here is gutenprint:
http://ftp.oregonstate.edu/pub/vectorlinux/veclinux-5.8/packages/base-apps/gutenprint-5.0.0-i586-2vl58.tlz
Download package, open a terminal (command prompt, shell), type su and the root password, then
installpkg (/path/to)gutenprint-5.0.0-i586-2vl58.tlz

You may not even need to do this. Set up your printer using CUPS. Run vasm, select service, then cupsweb.
Logged
Martin109
Vectorite
***
Posts: 289


« Reply #2 on: May 04, 2008, 07:11:37 am »

Thanks nightflier.

It seems as if the gutenprint package is installed OK, as it is listed by the Gslapt package manager (blue square icon).

I have tried to run the VASM CUPS manager, but it seems to be referring to network printer setup, whereas mine is simply connected via a parallel cable, and the notes suggest it should be listed, but it isn't. Undecided
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
Martin109
Vectorite
***
Posts: 289


« Reply #3 on: May 04, 2008, 11:40:48 am »

Searching around, I wonder if I could use lpadmin to do the same job? 

Would something like this work?

/usr/sbin/lpadmin -p epson -E -v parallel /dev/lp0 -m <probablyEpsonSomething>.ppd

If so, what's the correct .ppd file?

The command 'locate .ppd | grep 890' (to find files relating to my Epson Stylus Photo 890) came up with:

/usr/share/cups/model/C/escp2-890.ppd.gz
/usr/share/cups/model/C/pcl-890.ppd.gz
/usr/share/cups/model/gutenprint/5.0/C/stp-pcl-890.5.0.sim.ppd.gz
/usr/share/cups/model/gutenprint/5.0/C/stp-escp2-890.5.0.ppd.gz
/usr/share/cups/model/gutenprint/5.0/C/stp-escp2-890.5.0.sim.ppd.gz
/usr/share/cups/model/gutenprint/5.0/C/stp-escp2-pma890.5.0.ppd.gz
/usr/share/cups/model/gutenprint/5.0/C/stp-escp2-pma890.5.0.sim.ppd.gz
/usr/share/cups/model/gutenprint/5.0/C/stp-pcl-890.5.0.ppd.gz
/usr/share/ppd/HP/HP-DeskJet_890C-hpijs.ppd.gz

The last one's obviously a rogue element!

They've all got .ppd in them, but what's .gz?

I think I've probably got all the files I need, but don't know how to link them together properly. Undecided
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
nightflier
Administrator
Vectorian
*****
Posts: 4023



« Reply #4 on: May 04, 2008, 05:44:22 pm »

Not familiar with lpadmin.. I use KDE and it shows the locally connected printers in the printer wizard.

Is your parallel port is initialized?
Use vasm > service > hwset and make sure parallel is checked
Logged
Martin109
Vectorite
***
Posts: 289


« Reply #5 on: May 05, 2008, 04:06:00 am »

Is your parallel port is initialized?
Use vasm > service > hwset and make sure parallel is checked

It appears that it wasn't.
I've used vasm > service > hwset and made sure parallel is checked.

When attempting to print from Abiword, a dialog comes up with:

Create a PDF document
Generic Postscript
Epson                     Printing 1

It's the 'Generic Postscript' that's selected even though Epson states 'Printing', but nothing is happening at the printer.

Opening a terminal and typing 'lp' or 'lpr' brings up: lp (or lpr): Error - no default destination available

So, as far as I can see, Abiword now knows about the Epson printer and thinks it's send a job to it, but the printer doesn't know about it.
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
nightflier
Administrator
Vectorian
*****
Posts: 4023



« Reply #6 on: May 05, 2008, 05:10:49 am »

Did you use CUPS to set up the printer? It can be accessed in your browser at this address:
http://localhost:631/

From the CUPS interface you can print a test page. Does that work?
Logged
Martin109
Vectorite
***
Posts: 289


« Reply #7 on: May 05, 2008, 09:09:38 am »

OK, now the printer is shown under CUPS, whereas before it wasn't.

If I click on 'Printers', it comes up:

"Printer not connected; will retry in 30 seconds..."

Description: epson
Location:
Make and Model: Local Raw Printer
Printer State: processing, accepting jobs, published.
Device URI: parallel

As the location is blank, perhaps CUPS doesn't know how to connect to it.

Can't print test page, it just hangs.

« Last Edit: May 05, 2008, 10:28:02 am by Martin109 » Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
Martin109
Vectorite
***
Posts: 289


« Reply #8 on: May 05, 2008, 09:47:48 am »

If I try and modify anything or try setting the printer up again, I'm asked for authentication, but it does not accept my username and password, or the root username and password.
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #9 on: May 05, 2008, 09:51:25 am »

Username has to be "root" (small caps)
And whatever password you gave root when you installed the system (and case matters).
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
Martin109
Vectorite
***
Posts: 289


« Reply #10 on: May 05, 2008, 09:56:36 am »

Yes, that's what I've done.

root
<password> in same case as original
« Last Edit: May 05, 2008, 10:29:27 am by Martin109 » Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
nightflier
Administrator
Vectorian
*****
Posts: 4023



« Reply #11 on: May 05, 2008, 12:55:25 pm »

As the location is blank, perhaps CUPS doesn't know how to connect to it.

That should not make any difference. I would try starting over, deleting all printers and adding it again, using the browser interface. For user root there has to be a password. If password is blank, it will not work.
Logged
Martin109
Vectorite
***
Posts: 289


« Reply #12 on: May 06, 2008, 12:06:50 am »

Thanks, nightflier.

I didn't know about specifically having to have a root password -  Roll Eyes

I've followed your suggestions and got a bit further.  The CUPS system found two printers for Parallel_Port_1, Canon and Epson.  Why it came up with Canon, I don't know.  I selected Epson, and chose a file from the many gutenprint files listed.  CUPS now displays:

Description: EPSON
Location: Local Printer
Make and Model: Generic PCL 5 Printer - CUPS+Gutenprint v5.0.0 Simplified
Printer State: idle, accepting jobs, published.
Device URI: epson:/dev/lp0


However, if I try to print a test page, nothing happens, except CUPS keeps refreshing its page and the printer job(s), but the printer doesn't respond.  (The printer IS connected to the parallel port, and it IS switched on!)

Attempting to print a file from a text editor also produces nothing.

In a terminal, if I type lp, it still brings up lp: Error - no default destination available

I've also set this printer as the default printer.
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
nightflier
Administrator
Vectorian
*****
Posts: 4023



« Reply #13 on: May 06, 2008, 04:41:07 am »

Make and Model: Generic PCL 5 Printer - CUPS+Gutenprint v5.0.0 Simplified

In the process of adding the printer you should get to a page where you select your printer make/manufacturer. Select Epson. Next page has a long list of models. Look for the entry for your Epson Stylus Photo 890 (it's way down the list on my installation).
Logged
Martin109
Vectorite
***
Posts: 289


« Reply #14 on: May 06, 2008, 05:05:27 am »

Thanks, nightflier.

I shall next be back at my VL machine on Thursday, so will give this a go then.
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!