Please support VectorLinux!

Author Topic: 080505 KoboDeluxe-0.5.1 [VL5.9]  (Read 2842 times)

exeterdad

  • Moderator
  • Vectorian
  • *****
  • Posts: 2046
080505 KoboDeluxe-0.5.1 [VL5.9]
« on: May 05, 2008, 06:59:35 am »
toothandnail has packaged KoboDeluxe-0.5.1 for VL5.9

Package: KoboDeluxe-0.5.1
Sources: http://vectorlinux.osuosl.org/veclinux-5.9/source/testing/games/kobodeluxe
Quote
KoboDeluxe: KoboDeluxe (a simple but addictive 2d space-shooter)
KoboDeluxe:
KoboDeluxe: KoboDeluxe is a 3'rd person scrolling 2D shooter with a simple
KoboDeluxe: and responsive control system. It has 50 levels of smoothly
KoboDeluxe: increasing difficulty. Based on Akira Higouchi's original Xkobo
KoboDeluxe:
KoboDeluxe:
KoboDeluxe:
KoboDeluxe: License: GPL
KoboDeluxe: Authors: David Olofson
KoboDeluxe: Website: http://olofson.ne/kobodl
Please let us know if this package works or not in this thread.

kidd

  • Packager
  • Vectorian
  • ****
  • Posts: 682
Re: 080505 KoboDeluxe-0.5.1 [VL5.9]
« Reply #1 on: May 05, 2008, 08:46:27 am »
The game works fine but I couldn't get to display the fonts of menus.

I'm using vl-light beta3 and I installed adobe and dejavu fonts.

Screenie:
http://img84.imageshack.us/img84/3756/screenrk9.jpg

toothandnail

  • Moderator
  • Vectorian
  • *****
  • Posts: 2527
Re: 080505 KoboDeluxe-0.5.1 [VL5.9]
« Reply #2 on: May 05, 2008, 09:06:05 am »
The game works fine but I couldn't get to display the fonts of menus.

I'm using vl-light beta3 and I installed adobe and dejavu fonts.

Screenie:
http://img84.imageshack.us/img84/3756/screenrk9.jpg


Strange. The only thing I can think of is that I have the MS webcore fonts installed. Can you try this package, see if it sorts things out?

http://www.users.waitrose.com/~paulm/files/webcore-fonts-1.3-noarch-lnt.1.tgz

If it does, I'll uninstall them and rebuild the package, since I don't imagine too many people have those fonts installed.

The only other thing would be some difference between 5.9 Standard and Light - don't know of anything there though...

paul.

kidd

  • Packager
  • Vectorian
  • ****
  • Posts: 682
Re: 080505 KoboDeluxe-0.5.1 [VL5.9]
« Reply #3 on: May 05, 2008, 09:14:51 am »
It does not work either.

We'll have to wait for other testers with std and light, and compare results

exeterdad

  • Moderator
  • Vectorian
  • *****
  • Posts: 2046
Re: 080505 KoboDeluxe-0.5.1 [VL5.9]
« Reply #4 on: May 05, 2008, 10:41:07 am »
I just installed via Gslapt with a fairly clean machine (VL5.9 Standard).  I didn't notice any font problems after about 10 minutes of play.
Nice find Tooth!

M-ake

  • Member
  • *
  • Posts: 92
Re: 080505 KoboDeluxe-0.5.1 [VL5.9]
« Reply #5 on: May 05, 2008, 10:47:01 am »
Installed to freshly installed VL-light beta 5. Works fine
Jumalauta!!
--
Fish go m00!

toothandnail

  • Moderator
  • Vectorian
  • *****
  • Posts: 2527
Re: 080505 KoboDeluxe-0.5.1 [VL5.9]
« Reply #6 on: May 05, 2008, 10:47:19 am »
I just installed via Gslapt with a fairly clean machine (VL5.9 Standard).  I didn't notice any font problems after about 10 minutes of play.
Nice find Tooth!

 ;D Glad its working. You'll be cursing me soon enough - it is one dreadful time waster...

paul.

MikeCindi

  • Moderator
  • Vectorian
  • *****
  • Posts: 1073
Re: 080505 KoboDeluxe-0.5.1 [VL5.9]
« Reply #7 on: May 06, 2008, 03:09:06 pm »
Game won't start on SOHO B2 (at least my rendition of it). I get the following"
Code: [Select]
satellite:/~
mscott:$ kobodl
Application path: '.'
[149] Could not get double buffered display.
[149] Shadow buffer requested; relying on SDL's shadow buffer.
[213] sprite: Failed to load sprite "/usr/share/kobo-deluxe/gfx/loading3.png"!
[214]   Failed to load /usr/share/kobo-deluxe/gfx/loading3.png!
[214] Couldn't load "/usr/share/kobo-deluxe/gfx/loading3.png"!
satellite:/~
mscott:$
I'll try on my Light beta 5 and/or VL-64 B2 and see if I get better results.

Later...
Worked on light b5 but not fonts...will install the above package and try again later.
« Last Edit: May 06, 2008, 08:01:49 pm by mikecindi »
The plans of the diligent lead to profit...Pro. 21:5
VL64 7.1b3                                     RLU 486143

toothandnail

  • Moderator
  • Vectorian
  • *****
  • Posts: 2527
Re: 080505 KoboDeluxe-0.5.1 [VL5.9]
« Reply #8 on: May 07, 2008, 02:39:50 am »
Strange. It runs for me on SOHO B2 (haven't tried the earlier beta yet). I've not updated anything on the SOHO beta - straight out of the box....

paul.

kidd

  • Packager
  • Vectorian
  • ****
  • Posts: 682
Re: 080505 KoboDeluxe-0.5.1 [VL5.9]
« Reply #9 on: May 07, 2008, 05:10:02 am »
I installed B5 yesterday and my font problem persists.  I installed kobo to another box with B4 and worked flawlessly.  I guess it has something to do with my X configuration, or maybe ~/.Xdefaults. I have colordepth set to 16, fully changed ~/.Xdefaults.


toothandnail

  • Moderator
  • Vectorian
  • *****
  • Posts: 2527
Re: 080505 KoboDeluxe-0.5.1 [VL5.9]
« Reply #10 on: May 07, 2008, 06:05:51 am »
I installed B5 yesterday and my font problem persists.  I installed kobo to another box with B4 and worked flawlessly.  I guess it has something to do with my X configuration, or maybe ~/.Xdefaults. I have colordepth set to 16, fully changed ~/.Xdefaults.

I managed to kill Kobo Deluxe under B2 a little earlier - installed some of the SDL stuff from the repos. At which point Kobo failed instantly. Couldn't uninstall the packages - Gslapt came up with an error. I've just done a clean install of B2 and its working again. I'll try installing one package at a time and see what kills it.

 :( Maybe it needs a separate build for SOHO. Either that or I need to add something extra to Standard and rebuild it. A bit of a pain...

paul.

MikeCindi

  • Moderator
  • Vectorian
  • *****
  • Posts: 1073
Re: 080505 KoboDeluxe-0.5.1 [VL5.9]
« Reply #11 on: May 07, 2008, 09:59:32 am »
If it's SDL's presence that causes issues that would explain my problems with each version of VL. I install ppracer which has also loads the SDL packages from the repo.
The plans of the diligent lead to profit...Pro. 21:5
VL64 7.1b3                                     RLU 486143

toothandnail

  • Moderator
  • Vectorian
  • *****
  • Posts: 2527
Re: 080505 KoboDeluxe-0.5.1 [VL5.9]
« Reply #12 on: May 07, 2008, 10:58:31 am »
If it's SDL's presence that causes issues that would explain my problems with each version of VL. I install ppracer which has also loads the SDL packages from the repo.

I just tried installing a few of the SDL packages, then rebuilding against them. Still fails - looks as though it doesn't like the Vector version of SDL for some reason. I've sent the author some email - see if he has any suggestions to fix the problem...

paul.