Author Topic: Problem Starting Windows Manager - SOLVED  (Read 1579 times)

Martin109

  • Vectorite
  • ***
  • Posts: 290
Problem Starting Windows Manager - SOLVED
« on: May 05, 2008, 09:41:59 am »
I'm setting up a friend's machine with VL 5.8 SOHO, and all has gone well, including internet, but I can only start the Windows Manager by typing 'startx' from root.  If I first log in with my name and password, or my friend's name and password, the system hangs and I eventually get the message:

timeout in locking authority file //.serverauth.3635

Any help with this appreciated.  I'm more familiar with VL 5.8 Standard, where this issue hasn't arisen.
« Last Edit: May 10, 2008, 08:14:24 am by Martin109 »
Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Martin109

  • Vectorite
  • ***
  • Posts: 290
Re: Problem Starting Windows Manager
« Reply #1 on: May 09, 2008, 11:19:18 pm »
If I start VL by selecting Linux-gui from the first screen, and then put in my username and password (or my friend's username and password), I get the message: Your login shell is not listed in /etc/shells

There is no folder /etc/shells

How do I get login shells for users apart from root?
Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3499
Re: Problem Starting Windows Manager
« Reply #2 on: May 10, 2008, 05:37:16 am »
log in as root then start vasmcc click on user and remove the user account. After that create it again.

Martin109

  • Vectorite
  • ***
  • Posts: 290
Re: Problem Starting Windows Manager
« Reply #3 on: May 10, 2008, 08:14:00 am »
Thanks, MOE-Inx, that's sorted it! ;D
Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard