Please support VectorLinux!

Author Topic: 080506 claws-mail-3.4.0 [VL5.9]  (Read 2753 times)

exeterdad

  • Moderator
  • Vectorian
  • *****
  • Posts: 2046
080506 claws-mail-3.4.0 [VL5.9]
« on: May 06, 2008, 04:13:48 am »
kc1di has packaged claws-mail-3.4.0 for VL5.9

Package: claws-mail-3.4.0-i586-1vl59.tlz
Sources: http://vectorlinux.osuosl.org/veclinux-5.9/source/testing/net/claws-mail
Quote
claws-mail: claws-mail (claws-mail-3.4.0)
claws-mail: Claws Mail is an email client (and news reader), based
claws-mail: on GTK+, featuring  Quick response, Graceful,
claws-mail:  and sophisticated interface Easy configuration,
claws-mail:  intuitive operation Abundant features Extensibility
claws-mail: Robustness and stability
claws-mail:
claws-mail:
claws-mail: License: GPL
claws-mail: Authors:  Claws-mail  Project
claws-mail: Website:  http://www.claws-mail.org/
Please let us know how this package works for you in this thread.

Lyn

  • Vectorian
  • ****
  • Posts: 661
Re: 080506 claws-mail-3.4.0 [VL5.9]
« Reply #1 on: May 06, 2008, 12:56:04 pm »
No go unfortunately

claws-mail: error while loading shared libraries: libetpan.so.13: cannot open shared object file: No such file or directory

kc1di

  • Packager
  • Vectorian
  • ****
  • Posts: 1125
  • Morse Code Early digital mode. John 3:16
Re: 080506 claws-mail-3.4.0 [VL5.9]
« Reply #2 on: May 06, 2008, 01:38:40 pm »
No go unfortunately

claws-mail: error while loading shared libraries: libetpan.so.13: cannot open shared object file: No such file or directory

libetpan is one of the dependacies you'll have to install it. it's in the testing Repository  it will also ask for Bluz-libs you can ignore that one and go ahead and install it using gslapt it will run fine. Will correct the dependency in the next upgrade.
Cheers Dave

Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608

kidd

  • Packager
  • Vectorian
  • ****
  • Posts: 682
Re: 080506 claws-mail-3.4.0 [VL5.9]
« Reply #3 on: May 06, 2008, 01:46:25 pm »
Shouldn't slapt-get do that automagically?

kc1di

  • Packager
  • Vectorian
  • ****
  • Posts: 1125
  • Morse Code Early digital mode. John 3:16
Re: 080506 claws-mail-3.4.0 [VL5.9]
« Reply #4 on: May 06, 2008, 02:00:00 pm »
Shouldn't slapt-get do that automagically?

It should but for somereason it is not doing it.  Any Ideas?

Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608

kidd

  • Packager
  • Vectorian
  • ****
  • Posts: 682
Re: 080506 claws-mail-3.4.0 [VL5.9]
« Reply #5 on: May 06, 2008, 02:17:34 pm »
root:# slapt-get --install claws-mail
Reading Package Lists... Done
Excluding claws-mail, use --ignore-dep to override
The following packages have unmet dependencies:
  claws-mail: Depends: bluez-libs >= 3.26-i486-1
The following packages have been EXCLUDED:
  claws-mail
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Done


That's what I'm getting

exeterdad

  • Moderator
  • Vectorian
  • *****
  • Posts: 2046
Re: 080506 claws-mail-3.4.0 [VL5.9]
« Reply #6 on: May 06, 2008, 02:33:53 pm »
I hate to be the bearer of bad news...  But these packages MUST be built from a clean VL5.9 Standard install, or a VL5.9 Standard chroot within a alternate VL version.  If packages are built against deps that we don't already have in the repo, all of the deps must be supplied.  These deps can not be packages from another distro.

I'm sorry, but these are the rules.

Okay...  I'm done being the bad guy.  Just rebuild while bumping it up a build number, supply additional deps and we're back in business.

Love ya man :)

Edited to add:  A user needs to be able to install via Gslapt with one click.  Using additional flags with slapt-get to get a package installed is above many users ability.  We need to avoid this method.
« Last Edit: May 06, 2008, 02:38:20 pm by exeterdad »

kc1di

  • Packager
  • Vectorian
  • ****
  • Posts: 1125
  • Morse Code Early digital mode. John 3:16
Re: 080506 claws-mail-3.4.0 [VL5.9]
« Reply #7 on: May 06, 2008, 06:14:51 pm »
Thanks Exeterdad and all.
I've built bluz-libs-3.31 and uploaded it.. , libetpan -0.54 is already in testing. I also built claws again on a clean VL 5.9 std install. (build 2) they are all in my folder at the contrib.

I'll post the particualrs to the packager forum when I get back from my trip  most like late Thursday or Friday.  I do not know why libetpan is not being resolved by slapt-get. It's there and if installed ahead of Claws works fine. though I rebuilt Claws-Mail on a freshly installed minium VL5.9 Standard it still produces the same dependency list as when originally built on a VL 5.9 Light install.  In any event the bluz-libs-3.31 will solve that dependancy problem.  There was a bluz-libs already in the repro and when I originally did the build - I thought it would work , didn't notice the version number on that one was wrong.  Will try harder next time  ;)

Thanks for being loving and kind.
hope this works :)
dave
« Last Edit: May 07, 2008, 02:40:36 am by kc1di »
Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608

kc1di

  • Packager
  • Vectorian
  • ****
  • Posts: 1125
  • Morse Code Early digital mode. John 3:16
Re: 080506 claws-mail-3.4.0 [VL5.9]
« Reply #8 on: May 08, 2008, 02:47:23 am »
Since my last post , I've noticed that Slapt-Get has seemingly picked up the libetpan dependacy ok now.  The bluz-libs has been packaged and should be available soon in testing, that should take care of the other dependancy issue.
Thanks for all the Help
Dave
« Last Edit: May 08, 2008, 02:49:10 am by kc1di »
Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608

exeterdad

  • Moderator
  • Vectorian
  • *****
  • Posts: 2046
Re: 080506 claws-mail-3.4.0 [VL5.9]
« Reply #9 on: May 08, 2008, 04:16:17 am »
The bluez-libs package is now in testing.  I had a successful "one click" claws-mail install via Gslapt after updating sources. Using VL5.8 Standard.  Cool looking app.
Nicely done kc1di

kc1di

  • Packager
  • Vectorian
  • ****
  • Posts: 1125
  • Morse Code Early digital mode. John 3:16
Re: 080506 claws-mail-3.4.0 [VL5.9]
« Reply #10 on: May 08, 2008, 05:38:56 am »
The bluez-libs package is now in testing.  I had a successful "one click" claws-mail install via Gslapt after updating sources. Using VL5.8 Standard.  Cool looking app.
Nicely done kc1di

Thanks  :)
Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608

overthere

  • Vectorian
  • ****
  • Posts: 1311
Re: 080506 claws-mail-3.4.0 [VL5.9]
« Reply #11 on: June 05, 2008, 05:46:22 pm »
installed claws to vl-light via package manager..included libetpan..bluez was already installed with jpilot..seems to work fine but no icon in the menu or when I added a panel launcher...added an icon from /usr share/icons manually and I am fine with that...but thought it may be of interest...thanks
Everything Is Relative

kc1di

  • Packager
  • Vectorian
  • ****
  • Posts: 1125
  • Morse Code Early digital mode. John 3:16
Re: 080506 claws-mail-3.4.0 [VL5.9]
« Reply #12 on: June 06, 2008, 06:01:10 am »
Thanks overthere,
I'm aware of the problem in light will try to resovlve it in the next build of Claws-mail.
It's because claws-mail puts the Icon in a different place tha /usr/share/applications is looking for it.
if you go to /usr/share/Icons >Hicolor >48x48 and copy the claws mail icon from there to /usr/share/pixmaps it will show up in the menu and the pannel if you have it listed there.
Cheers ,
Dave
Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608

overthere

  • Vectorian
  • ****
  • Posts: 1311
Re: 080506 claws-mail-3.4.0 [VL5.9]
« Reply #13 on: June 06, 2008, 08:33:42 am »
thank YOU..for the program..I will add the appropriate icon via move to pixmaps thanks
cheers
Everything Is Relative