VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: XBindKeys won't start up  (Read 2193 times)

Tommy599

  • Member
  • *
  • Posts: 61
XBindKeys won't start up
« on: April 18, 2008, 10:17:13 pm »

I installed XBindKeys http://hocwp.free.fr/xbindkeys/xbindkeys.html, it installed correctly, if I start it from the command line with xbindkeys & it starts up, I set up a shortcut for xterm, it works, but I can't get it to start up at logon.

At it's homepage it says:
Quote
You can now use xbindkeys by typing :
 xbindkeys &
or by loading it automatically when X starts up by adding the preceeding line to the file $HOME/.xsession.

I tried this, added that line to the end of the .xsession file, it didn't work. I added it to the ~./fluxbox/startup file, but that doesn't work either (xterm and gkrellm are both started from there and it works).

Any ideas? Thanks!

Logged
Vector Linux 6.0 Light Final
Toshiba Satellite Pro 4200 @ 500Mhz/128MB/20GB
Registered Linux user #470287
t599.mybrute.com <- can you defeat me?

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: XBindKeys won't start up
« Reply #1 on: April 18, 2008, 10:50:41 pm »

Try putting it in the .fluxbox/apps file, you need the correct syntax though, check the fluxbox website.
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

Tommy599

  • Member
  • *
  • Posts: 61
Re: XBindKeys won't start up
« Reply #2 on: April 18, 2008, 11:11:54 pm »

Never mind, I discovered that I can make shortcuts in Fluxbox too  ;D
Logged
Vector Linux 6.0 Light Final
Toshiba Satellite Pro 4200 @ 500Mhz/128MB/20GB
Registered Linux user #470287
t599.mybrute.com <- can you defeat me?

vdb

  • Member
  • *
  • Posts: 22
Re: XBindKeys won't start up
« Reply #3 on: May 08, 2008, 03:11:38 am »

Sorry for hooking up into your Post but I think it is useless to make a new thread for this.

Does Xbindkeys also have the possibility to save up alt-codes (characters) and display them after assigning them to a shortkey(s)?
Like in Windows you type in alt + 130 and you get 'é'

Thanks!
Logged
Vector Linux 5.8 SOHO

bigpaws

  • Vectorian
  • ****
  • Posts: 1872
Re: XBindKeys won't start up
« Reply #4 on: May 08, 2008, 07:16:59 am »

From reading the docs the answer appears to be yes.

Bigpaws
Logged