April 21, 2015, 02:59:00 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
Author Topic: Can run a Mono-ap as root, but not as user  (Read 2299 times)
Posts: 210

Dude In The Snappy Hat

« on: May 09, 2008, 10:51:13 am »

Got me stumped here:

Configuring my laptop with 5.9 std Gold, I came to the point where I had to install MONO in order to run an app, I need to loot graphical sites.(Yes; I got it from an "adult" site, so bite me  Tongue )
It worked fine on my Desktop(VL5.8 SOHO) but on my lappy I ran into the following:

Mono works.
The app works too, but only as root...
When I try to run it in my user-account, the following is spit to the screen:
Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.XplatUI ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Drawing.GDIPlus ---> System.DllNotFoundException: gdiplus.dll
  at (wrapper managed-to-native) System.Drawing.GDIPlus:GdiplusStartup (ulong&,System.Drawing.GdiplusStartupInput&,System.Drawing.GdiplusStartupOutput&)
  at System.Drawing.GDIPlus..cctor () [0x00000] --- End of inner exception stack trace ---

  at System.Drawing.Graphics.FromHdcInternal (IntPtr hdc) [0x00000]
  at System.Windows.Forms.XplatUIX11.SetDisplay (IntPtr display_handle) [0x00000]
  at System.Windows.Forms.XplatUIX11..ctor () [0x00000]
  at System.Windows.Forms.XplatUIX11.GetInstance () [0x00000]
  at System.Windows.Forms.XplatUI..cctor () [0x00000] --- End of inner exception stack trace ---

  at System.Windows.Forms.Application.EnableVisualStyles () [0x00000]
  at PGRipper.MainForm.Main (System.String[] Args) [0x00000]
Looks like some libs are reserved for root, without any logic as to the "why" of it..
Need pointers to fix this.
And then I'm not even 'plainin' bout not getting the desktop-link reacting(It just sits there as a turd)...
Thanks in advance.
« Last Edit: May 09, 2008, 10:53:36 am by SuSE-Refugee » Logged

<Lame sig>
Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!