VectorLinux
October 22, 2014, 01:32:29 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: How to install Bibletime in a VL 5.9 light system  (Read 6364 times)
kc1di
Packager
Vectorian
****
Posts: 1125


Morse Code Early digital mode. John 3:16


« on: May 13, 2008, 04:26:02 am »

I received an email the other day asking how my Bibletime package can be installed in a VL 5.9 Light install. knowing there are most likely others who are wanting to do the same thing thought I'd write up the proceedure in a how to.

Bibletime is a Kde Based package and will install and run fine on the SOHO 5.9 version.. but inorder to install and run it in VL 5.9 Light B5 you will have to track down and install several kde packages , some of which are not yet in the VL repositories.

in Gslapt install the following packages before attempting to install bibletime.
Qt4 -4.3.2
arts
sword

then you will have to download kdelibs-3.5.9 from
http://vectorlinux.osuosl.org/johnb316/kde-3.5.9/kdelibs-3.5.9-i586-2vl59.tlz
and install it manually from a terminal using the command installpkg
if you need help doing that just PM in the forum or email me at davekc1di@gmail.com
once those are installed you can Gslapt install bibletime and all should work in vl5.9 light just fine.

If you are using the JWM desktop after completing the install above and under system click refresh menu
it will add bibletime to the menu under utilities.
Enjoy
Dave

P.S. have not tried in 5.9 Std Gold but should work fine there also.

« Last Edit: May 13, 2008, 06:17:09 am by kc1di » Logged

Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608
Penguinista
Guest
« Reply #1 on: January 28, 2009, 09:48:38 am »

Would this work for VL 5.9.1 SOHO?

I noticed that there are tar.bz2 files located at the following sites. Would they work (i.e., contain dependencies) or is it best to follow your steps.

http://www.bibletime.info/software_installation.html

http://sourceforge.net/project/showfiles.php?group_id=954
Logged
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #2 on: January 28, 2009, 11:32:45 am »

Pardon me, but... a complete KDE, as in version 3.5.10, is in the repositories, as is bibletime.  Make sure you have the packages, patches, and extra repository enabled.  You can then install bibletime with gslapt or slpat-get and the dependencies are automatically installed.  I am willing to bet that your problem is that you don't have all of the necessary repositories enabled.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
kc1di
Packager
Vectorian
****
Posts: 1125


Morse Code Early digital mode. John 3:16


« Reply #3 on: January 28, 2009, 01:32:42 pm »

Pardon me, but... a complete KDE, as in version 3.5.10, is in the repositories, as is bibletime.  Make sure you have the packages, patches, and extra repository enabled.  You can then install bibletime with gslapt or slpat-get and the dependencies are automatically installed.  I am willing to bet that your problem is that you don't have all of the necessary repositories enabled.

Thanks Caitlyn,
I'm back ,had to be away for VL for a number of months just too many iron in the fire at work ,and was without my wideband internet here at home, but it's finally back up and running must say 6.0 is looking great.
Dave
Logged

Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #4 on: January 28, 2009, 08:55:36 pm »

Glad you're back, Dave!

Dave is our package maintainer for bibletime.  He's the man who built the package Smiley
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
radio_silence
Member
*
Posts: 15


« Reply #5 on: March 01, 2009, 08:11:47 pm »

Intall went well in 6.0 dlx, thank you for the packaging

I can access it in kde4 and xfce4, but am unable to find in lxde menu
(there is no menu refresh otion that I can find as in jwm)
Logged

ToshSat330cds_233Mhz_96Mb_4Gb-VLL5.9Final
IBMnetvista_2Ghz_1Gb_30Gb-VL5.9.1/MSxp
ToshSatPro4600_700Mhz_512MB_20Gb-VL5.9.1/MSnt
kc1di
Packager
Vectorian
****
Posts: 1125


Morse Code Early digital mode. John 3:16


« Reply #6 on: March 02, 2009, 02:24:20 am »

I did not test it at the time against LXDE , you may have to manually update the menu it that desktop.
Hope you enjoy the package and it leads to much study of the Word.
Dave

Logged

Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608
radio_silence
Member
*
Posts: 15


« Reply #7 on: March 02, 2009, 08:49:15 pm »

Thanks Dave
I am way too short of time to even look at manually entering things into menu right now...
I'm using terminal or a shortcut with no icon to start it
However, today I crashed the Bibletime twice while trying to do a word search
(6.0 Dlx, lxde wm) App was trying to index modules prior to running search, and crash...
Logged

ToshSat330cds_233Mhz_96Mb_4Gb-VLL5.9Final
IBMnetvista_2Ghz_1Gb_30Gb-VL5.9.1/MSxp
ToshSatPro4600_700Mhz_512MB_20Gb-VL5.9.1/MSnt
kc1di
Packager
Vectorian
****
Posts: 1125


Morse Code Early digital mode. John 3:16


« Reply #8 on: March 03, 2009, 02:11:39 am »

Thanks Dave
I am way too short of time to even look at manually entering things into menu right now...
I'm using terminal or a shortcut with no icon to start it
However, today I crashed the Bibletime twice while trying to do a word search
(6.0 Dlx, lxde wm) App was trying to index modules prior to running search, and crash...

I'll take a look at that see if I can figure out what's going on.
Oh which version of bibletime do you have installed ?

Dave
Logged

Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608
radio_silence
Member
*
Posts: 15


« Reply #9 on: March 03, 2009, 09:52:21 am »

I gues my problem may be that  I'm using KDE4 and version is as follows
BibleTime 1.6.5.1 (using KDEmod 3.5.10 on compiled resources)

Also, I had been running as user, but am unable to login as such right now, so
I switched to running as root.  Now Bibletime  wants to reinstall library and I
don't know how to redirect it to share with existing user library
Logged

ToshSat330cds_233Mhz_96Mb_4Gb-VLL5.9Final
IBMnetvista_2Ghz_1Gb_30Gb-VL5.9.1/MSxp
ToshSatPro4600_700Mhz_512MB_20Gb-VL5.9.1/MSnt
kc1di
Packager
Vectorian
****
Posts: 1125


Morse Code Early digital mode. John 3:16


« Reply #10 on: March 04, 2009, 03:33:26 am »

You do need the QT3.5 libraries for bibletime the programers of the package have not as yet released a
qt4 version so that maybe where your running into trouble.  however that being said qt 3.5 libs should have been install along with bible time.

As far as accessing them as root , you'll have to redo the reference libs. for root as bibletime keeps each users references separate. so that two or more people can use the same machine same program but have differing reference libraries.

Dave




Logged

Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608
Subito Piano
Member
*
Posts: 3



WWW
« Reply #11 on: April 22, 2010, 05:00:53 am »

Hmm - i have a problem with not having cross-references in BT, using VL Standard Gold and the latest Swword/BT from the standard repos.  Is this a known bug?
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!