VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Trying to set up Realtek 8187b wireless card in VL 5.9 SOHO  (Read 7214 times)

Jerry

  • Vectorite
  • ***
  • Posts: 119

I have been trying to set up wireless on this new Toshiba Satellite A205, which has the Realtek
8187b wireless card built in on pci bus 2.

The router is a Belkin G-Plus MIMO.

The Marvell ethernet card is also not recognized by 5.9 for some reason, so I am unable to download
drivers (even if I knew exactly which ones to download) or to get ndiswrapper, etc.

I've been thinking of trying to get the drivers on cd using my pc.  ??

Any suggestions about all this?   :-[

  - Jerry



Logged

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: Trying to set up Realtek 8187b wireless card in VL 5.9 SOHO
« Reply #1 on: May 16, 2008, 11:49:45 am »

I have the same card working with ndiswrapper.

Stay tuned...  I'll hook you up with info's.
Logged

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: Trying to set up Realtek 8187b wireless card in VL 5.9 SOHO
« Reply #2 on: May 16, 2008, 11:56:05 am »

Extract this driver somewhere:
ftp://61.56.69.18/cn/wlan/RTL8187B_driver_only.zip
Use VLwifi, and point it to the drivers .inf file when asked.  I believe I'm using the ones in the winXP folder.  Though I know I've used the one in the win98 folder before with success.

I'm using a later kernel (2.6.24.3) with a non-working rtl8187 kernel module.  I had to blacklist it before ndiswrapper would work.
« Last Edit: May 16, 2008, 11:59:29 am by exeterdad »
Logged

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: Trying to set up Realtek 8187b wireless card in VL 5.9 SOHO
« Reply #3 on: May 16, 2008, 12:04:28 pm »

Oh yeah....  Don't know what version of ndswrapper is in 5.9 SOHO offhand...  But the version that's available for Standard needed updated using this card.  It would work...  but then I could only stay connected for a very short time.  I compiled myself the latest ndiswrapper and haven't had a problem since.
Logged

Jerry

  • Vectorite
  • ***
  • Posts: 119
Re: Trying to set up Realtek 8187b wireless card in VL 5.9 SOHO
« Reply #4 on: May 16, 2008, 12:05:43 pm »

Extract this driver somewhere:
ftp://61.56.69.18/cn/wlan/RTL8187B_driver_only.zip
Use VLwifi, and point it to the drivers .inf file when asked.  I believe I'm using the ones in the winXP folder.  Though I know I've used the one in the win98 folder before with success.

I'm using a later kernel (2.6.24.3) with a non-working rtl8187 kernel module.  I had to blacklist it before ndiswrapper would work.

Oh, good.. that looks like it'll work.  

I gave the wrong Vector version:  it's the 5.9 released last December, not SOHO.  I haven't checked yet, but I'll bet that has one of the 2.4 kernels.

I'll follow that advice there, exeterdad.  I'll come back in with a post about the results.  Thank you so much!

 - Jerry
Logged

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: Trying to set up Realtek 8187b wireless card in VL 5.9 SOHO
« Reply #5 on: May 16, 2008, 12:09:49 pm »

You won't have any trouble with the kernel that comes with 5.9 Standard.  That module isn't included.  But I wouldn't be surprised if you decide to update ndiswrapper.
Logged

Jerry

  • Vectorite
  • ***
  • Posts: 119
Re: Trying to set up Realtek 8187b wireless card in VL 5.9 SOHO
« Reply #6 on: May 16, 2008, 01:00:29 pm »

 :(  Well .. my heart sunk..  everything was going along fine, but I get an error applet after the wifi utility searches for my card saying "no wireless card found," then it exits.

??

(edit):

Dang, I can't even get "hwconf" or "HWCONF" to re-detect my hardware in console mode with no X.

I wonder what's wrong, all it says is "command not found."
« Last Edit: May 16, 2008, 01:36:10 pm by jerrybasham »
Logged

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: Trying to set up Realtek 8187b wireless card in VL 5.9 SOHO
« Reply #7 on: May 16, 2008, 01:59:36 pm »

I've never had to set up ndiswrapper via command line. http://www.vectorlinux.com/forum2/index.php?topic=1282.0 easuter has written up a excellent howto. About midway down his post is about as good as a explanation as your going to find on how to set it up.  Looks fairly easy.
Logged

Jerry

  • Vectorite
  • ***
  • Posts: 119
Re: Trying to set up Realtek 8187b wireless card in VL 5.9 SOHO
« Reply #8 on: May 16, 2008, 05:23:24 pm »

I've never had to set up ndiswrapper via command line. http://www.vectorlinux.com/forum2/index.php?topic=1282.0 easuter has written up a excellent howto. About midway down his post is about as good as a explanation as your going to find on how to set it up.  Looks fairly easy.

Thanx again.  I'll give it a go.

This whole thing renews my frustration with hardware manufacturers who won't provide drivers for Linux along with Windows drivers;  we should be able to plug and play something like a wireless card. 

Maybe I'm too picky, but Toshiba is a big company, as are Acer and Dell and the others who we have to go through so much trouble to get their hardware to work in Linux.  The developers of distros are always dealing with moving targets, it seems.   :-\
Logged

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: Trying to set up Realtek 8187b wireless card in VL 5.9 SOHO
« Reply #9 on: May 16, 2008, 08:10:24 pm »

Actually Realtek does provide linux drivers for that card.  But they only work with the older kernels.  They also have (according to the mailing list devs) been assisting the devs working on the rlt8187 kernel module.  Much of Realteks own code is merged into the sources for the kernel module.  But for some reason the 8187b cards aren't fully working.  If I recall, it's a change in the actual kernel that broke it.  Something about a "stack" being changed.  Whatever that is. I could use the kernel module and get the card up and running.  But nothing was going on.

I'm sure they'll get the kinks out in a release or so.  Then our card will work right out of the box. Natively.
Logged

Jerry

  • Vectorite
  • ***
  • Posts: 119
Re: Trying to set up Realtek 8187b wireless card in VL 5.9 SOHO
« Reply #10 on: May 17, 2008, 04:09:26 am »

That explains why on Sabayon the old "how to" for this card won't work anymore(http://wiki.sabayonlinux.org/index.php?title=HOWTO:_Realtek_8187b_Wireless_Networking).  I tried that distro and followed the explanation to the "t" and got the system to see and report the device as loaded, etc, but it would not connect.  It even had the name of my connection and other info correct, just no connection.

I had similar (or worse  ::)) results with the new Mint, Ubuntu and Dream Linux.

I wonder if there's a work around for us. 

I'm sure glad I got a spare hard drive for all this Linux experimenting.   ;) 

(with apologies for a second edit of this post  :P) I'd like to contribute this informative, recent (April '08) article about the driver problems with Linux.. there are some links included that contain actuall solutions for many:
http://www.linux.com/feature/130589.  Maybe we'll see a post or two back here from those with success to report.
« Last Edit: May 17, 2008, 04:59:52 am by jerrybasham »
Logged