VectorLinux
October 01, 2014, 02:17:45 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 080520 openssl-0.9.8e [VL59]  (Read 1952 times)
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« on: May 20, 2008, 07:13:58 am »

rbistolfi has packaged openssl-0.9.8e for VL59

Package: openssl-0.9.8e-i486-3.tlz
Sources: http://vectorlinux.osuosl.org/veclinux-5.9/source/testing/net/openssl
Quote
openssl: openssl (Secure Sockets Layer toolkit)
openssl:
openssl: The OpenSSL certificate management tool and the shared libraries that
openssl: provide various encryption and decryption algorithms and protocols.
openssl:
openssl: This product includes software developed by the OpenSSL Project for
openssl: use in the OpenSSL Toolkit (http://www.openssl.org).  This product
openssl: includes cryptographic software written by Eric Young
openssl: (eay@cryptsoft.com).  This product includes software written by Tim
openssl: Hudson (tjh@cryptsoft.com).
openssl:

After testing this package, please take a moment and come back to this thread to let us know how it works for you.
Logged
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #1 on: May 20, 2008, 10:01:15 am »

Seems to be working fine here. I am a bit curious however - this seems to be a version regression from what was in 5.9 Standard - it replaces openssl-0.9.8f-i486-1. In the same way, openssl-solibs seems to be a regression - 5.9 Standard originally had openssl-solibs-0.9.8f-i486-1 installed.

paul.
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2284


« Reply #2 on: May 20, 2008, 10:58:37 am »

Thanks for pointing this Paul, I found it weird too, but looks like this are the packages SW is using. Without them I was unable to make the new openssh to work. The old openssh package is affected by a security advisore. I should take a deeper look into this.
Thanks again.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« Reply #3 on: May 20, 2008, 12:02:03 pm »

Nice catch Paul!
Per request of rbistolfi this package has been pulled from the repo.
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2284


« Reply #4 on: May 20, 2008, 09:14:11 pm »

With uelsk8s we found the origin of the mistake. openssl-0.9.8g will be available soon. This fixes some security advisories on the 0.9.8e and 0.9.8f versions. More info here: http://www.openssl.org/news/secadv_20071012.txt
Since security is involved, would be great if Paul and may be other experienced users can test this soon. Please let me know about any issue and I will try to solve it promptly.
Thanks!
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« Reply #5 on: May 21, 2008, 07:31:30 am »

rbistolfi's updated package openssl-0.9.8g-i486-1, is in the testing repo and ready for download.
Logged
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #6 on: May 21, 2008, 09:05:25 am »

Tested openssh, ospenssl and openssl-solibs latest versions. All working fine here (I do a fair bit of remote server admin using ssh).

I had a bit of a problem updating with Gslapt - it complained about an md5sum misssmatch on the openssh package. Used slapt-get to download and it went straight through.

paul.
Logged
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« Reply #7 on: May 21, 2008, 09:15:49 am »

Doh...  Thanks for the md5 tip.  I may know what's up with that.
Logged
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« Reply #8 on: May 21, 2008, 04:45:04 pm »

I forgot to mention that I think I worked out the md5 error earlier today.  Can anyone confirm?
Logged
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #9 on: May 22, 2008, 03:43:11 am »

I forgot to mention that I think I worked out the md5 error earlier today.  Can anyone confirm?

Just installed to a fresh SOHO install, worked fine. I had, of course, forgotten that the files were in the local cache, but I think (?) I would still have got the warning when attempting to update with Gslapt if the problem was still there....

paul
Logged
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« Reply #10 on: May 22, 2008, 03:56:20 am »

Thanks Paul, I too have installed it fine, but couldn't be certain about the cache from a prior install.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!