Please support VectorLinux!

Author Topic: Getting Beryl to install  (Read 2616 times)

rafiki6

  • Member
  • *
  • Posts: 14
Getting Beryl to install
« on: May 19, 2008, 09:53:59 am »
So I have been attempting to install beryl with no luck. When I go into the beryl core directory and type in ./configure here is where the error happens:

checking for BERYL... configure: error: Package requirements (libpng xcomposite >= 0.3 xfixes xdamage xrandr ice sm xinerama libstartup-notification-1.0 >= 0.7) were not met:

No package 'xrandr' found
No package 'ice' found
No package 'sm' found
No package 'xinerama' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BERYL_CFLAGS
and BERYL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Are these packages installed on VectorLinux and if they are which directory should I direct the installer to. Also if they are not, where can I find  them. Thanks...

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: Getting Beryl to install
« Reply #1 on: May 19, 2008, 10:03:25 am »
Beryl is old and discontinued. Try compiz-fusion instead. Packages are available from the repositories

rafiki6

  • Member
  • *
  • Posts: 14
Re: Getting Beryl to install
« Reply #2 on: May 19, 2008, 11:34:21 am »
Oh ok, I though compiz fusion was the precursor to Beryl not the other way around. Thanks for the info and tip, I'll get back to you on how it works out!

rafiki6

  • Member
  • *
  • Posts: 14
Re: Getting Beryl to install
« Reply #3 on: May 19, 2008, 11:49:18 am »
Well I attempted to install compiz-fusion. So I downloaded the ccsm tarbells, and I downloaded the compiz fusion plugins and the compiz fusion manager. I tried ./configure in the compiz fusion plugins folder and it says I am missing the Compiz package. So  I downloaded compiz-0.6.2 and attempted ./configure in it and guess what happens:

checking for COMPIZ... configure: error: Package requirements (xcomposite       xfixes                   xdamage                 xrandr                  xinerama                ice                     sm                      libxml-2.0     libxslt                  libstartup-notification-1.0 >= 0.7) were not met:

No package 'xrandr' found
No package 'xinerama' found
No package 'ice' found
No package 'sm' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables COMPIZ_CFLAGS
and COMPIZ_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Same errors I was getting with Beryl. Any idea what these packages are and how I get them?

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: Getting Beryl to install
« Reply #4 on: May 19, 2008, 12:06:21 pm »
Again, Try the repositories first

HINT: Gslapt from your vector menu

Enable the "testing" and "extra" repositories...
All deps should be resolved if you install from there

WORD OF WARNING: I hope you are running one of the 5.9 versions and not some 5.8 version.
Vector did not implement Xorg V7 until the 5.9 releases.

rafiki6

  • Member
  • *
  • Posts: 14
Re: Getting Beryl to install
« Reply #5 on: May 19, 2008, 12:22:41 pm »
Well I am running the 5.8 SOHO Release