VectorLinux
April 24, 2014, 02:15:08 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: using Transmission bittorrent client on VL  (Read 1738 times)
cool_arrow
Member
*
Posts: 6


« on: May 22, 2008, 07:28:50 am »

I just installed VL 5.9 and I would like to use Transmission to download some files.  However when I actually open some torrent files from within Transmission I get various errors such as:

-"Error: no response from tracker --will keep trying"
-"Error: access denied, leeching forbidden, you are only allowed to seed"
-"Error: unregistered torrent"

  In preferences "Automatic port mapping" is checked and the "Listening Port" is 9090.  My guess is that I need to open up the firewall somehow but I'm not sure how to do this or if this is in fact the problem.  When I go to VASM>Network>Firewall and attempt to open ports I see that I cannot enter a number for a port and 9090 is not in the list.  Any help is appreciated.   
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« Reply #1 on: May 22, 2008, 07:35:26 am »

By reading those messages, I have to guess that the torrent you're downloading requires registering. On these types of torrents you must register somwhere to get it to download.

Try other torrents and see if that works ok... I've Transmission in the past, and I was quite impressed btw.

HTH
Logged

cool_arrow
Member
*
Posts: 6


« Reply #2 on: May 22, 2008, 08:12:09 am »

Thanks for the reply.  I purposely chose torrents w/ lots of seeders and the trackers are not private and no registration.  I dowloaded some other torrents to try and w/ one of them it says it is "Downloading from 0 of 0 peers"  and the debug window says "Got scrape response from opentracker.thepiratebay.org:80': Invalid Request" .   Thanks for your help.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« Reply #3 on: May 22, 2008, 08:15:03 am »

I say bad build...
try building it yourself from ports using vpackager

I've done it in the past and it worked for me
Logged

cool_arrow
Member
*
Posts: 6


« Reply #4 on: May 22, 2008, 08:16:42 am »

One of them is actually downloading now  Smiley   Not sure what the problem is w/ the others.  I'll try the problem torrents on another machine w/ a different client to see if it is a Transmission specific problem. 
Logged
tomh38
Vectorian
****
Posts: 912



« Reply #5 on: May 22, 2008, 08:30:12 am »

Certain bittorrent sites require that you use a certain port, or in other cases that you not use a certain port or ports.  I don't know what the default ports are for the VL build of Transmission (I use ktorrent usually), but you might want to check that too.
Logged

"I'm doing a (free) operating system (just a hobby, won't be big and professional like gnu) for 386(486) AT clones." - Linus Torvalds, April 1991
cool_arrow
Member
*
Posts: 6


« Reply #6 on: May 22, 2008, 08:35:37 am »

Would I be correct in assuming that in order to open "non-standard" ports that this must be done from the command line and not VASMCC?
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« Reply #7 on: May 22, 2008, 08:40:39 am »

Would I be correct in assuming that in order to open "non-standard" ports that this must be done from the command line and not VASMCC?
This is normally done by the bittorrent client ( if you have this feature enabled in your router ) I have no idea how to do it in command line nor vasmCC
Logged

exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #8 on: May 22, 2008, 08:41:31 am »

Huh wha??  I know I built a new transmission package recently.  The one that came with VL5.9 wouldn't hardly work for me.  I will say, The newer versions work great.  I'll try to find what I did with that package and actually submit it.  Or make a new one whichever is easiest.
Logged
tomh38
Vectorian
****
Posts: 912



« Reply #9 on: May 22, 2008, 08:53:45 am »

cool_arrow:  You can set the listening port to be used in Transmission by going to Edit -> Preferences.  I don't know any more than that since I stopped using Transmission some time ago (I grew too frustrated with it).  Sorry I can't be of more help.
Logged

"I'm doing a (free) operating system (just a hobby, won't be big and professional like gnu) for 386(486) AT clones." - Linus Torvalds, April 1991
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #10 on: May 23, 2008, 06:16:11 am »

Here's the latest, packaged and ready to install:
http://www.vectorlinux.com/forum2/index.php?topic=6370.msg43667#msg43667
Logged
blurymind
Packager
Vectorian
****
Posts: 1082



« Reply #11 on: May 24, 2008, 08:57:00 am »

i noticed that some trackers dont like transmission.Thats why i keep my azureus.
Logged

status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!