VectorLinux
August 01, 2014, 03:42:51 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2 3
  Print  
Author Topic: VL 5.9 Light RC1 released.  (Read 44905 times)
nightflier
Administrator
Vectorian
*****
Posts: 4018



« on: May 22, 2008, 08:07:44 pm »

The VectorLinux team is proud to announce VL-Light Release Candidate 1.

VL-Light turns an aging PC into a usable computer again. Living up to the VL motto of "When Choice Matters," we give you lots of choices in a small package. JWM and Fluxbox for those who want something very light and basic, and the exciting new lightweight desktop environment, LXDE, for those who want more features. You will find xfe and pcmanfm file managers, Opera, Dillo and lynx web browsers. Xine, MPlayer, and XMMS handle Multimedia while Abiword and Gnumeric cover basic office tasks. Of course the usual Vector tools are included to make life easier for the user.

Come discover the difference that VL-Light makes.

ISO can be downloaded here: http://vectorlinux.osuosl.org/veclinux-5.9/iso-release/VL5.9-Light-RC1.iso
MD5SUM: b6bbf3395520819f45826850fc5d7ef5  VL5.9-Light-RC1.iso

Please post any bugs here: http://www.vectorlinux.com/forum2/index.php?topic=6362.0
Logged
blurymind
Packager
Vectorian
****
Posts: 1082



« Reply #1 on: May 24, 2008, 09:06:11 am »

which version of xorg does it have?
Logged

status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/
VgnFrnd
Member
*
Posts: 91


« Reply #2 on: May 25, 2008, 09:45:39 am »

As some may recall, I have a thinkpad 380z that plays hard to get with just about every linux distributions available, except for VL-Lite. Thus far, I've successfully installed b3, b5, and now RC1.

I can sincerely say that VL-Lite keeps getting better! For example, in RC1 the ndiswrapper wizard that pops up from within the vasmcc wifi control successfully wrapped my xonet zew1501 (rt2500 chipset) win xp driver, and the installation is persistent - it automatically loads on reboot. In b3 and b5, I had to configure my card manually from the command line and modify my rc.local file to match.

LXDE is also looking better and better. I especially like the menu-style file explorer on the taskbar. The menus can still be unstable, however. They sometimes disappear without notice. I haven't figured out what prompts them to disappear (leaving me with only openbox-type interface options), but I do not consider this behavior to be a big deal. I enjoy playing with it, and I still have jwm and fluxbox whenever I need them.

In other news, I figured out one reason why vl-lite installs on the 380z whereas most other distributions do not: Vl-lite is not a live cd, and it does not use x during any part of its install routines. On my 380z, every single linux distribution that either runs as a live cd or calls on x during installation fails to load. My comments here are one way of saying, "please, do not change the text-only installation routines of vl-lite!"

Thank you for your great work. Keep it lite!
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4018



« Reply #3 on: May 25, 2008, 12:20:52 pm »

which version of xorg does it have?

Same as 5.9 Std.
Logged
blurymind
Packager
Vectorian
****
Posts: 1082



« Reply #4 on: May 25, 2008, 01:21:35 pm »

welp,lets hope i get it right this time with the new driver  Roll Eyes

i feel very much in home with this release. Very impressed by the desktop settings and order.Its perfect!

only two things need to be adressed- the bootsplash theme is horribly terrible and lilo screen is the same old thing.

Other than that - i find it aestetically very appealing,responsive and perfectly ordered.

Its a darn shame i cant set my pcmanfm to open directories/files with a single click.  Cry
« Last Edit: May 25, 2008, 01:23:53 pm by blurymind » Logged

status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/
maywyk
Member
*
Posts: 3


« Reply #5 on: May 27, 2008, 04:35:50 am »

Hello, VL-people!
I have just downloaded ISO of VL-Light RC1 and launched the installation. Everything seemed fine, till I've reached boot-loader install stage. Just wonder - why Vector use LILO - GRUB seems to be more popular (and I have some basic knowledge of it too)?
So, I chose "install to boot sector of partition". And it did not finish ok:

"lilo error=Fatal: Either FIX-TABLE or IGNORE-TABLE must be specified"

I tried running LILO-install once more, and it threw the same error.

What is wrong with it???
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3178



« Reply #6 on: May 27, 2008, 04:42:06 am »

Maywyk, I've seen that happen before... It's harder for lilo to overwrite a GRUB mbr than anything else.

If you have another distro that you boot using grub, I would recommend you boot into that distro, and run grubconfig or add the appropriate lines to boot VL using grub.

I've had success wiping out the MBR before and then writing lilo into it.

HTH
Logged

VgnFrnd
Member
*
Posts: 91


« Reply #7 on: May 27, 2008, 05:06:47 am »

For what its worth, I always run "darik's boot and nuke" from the "ultimate boot cd" to erase my boot sector before installing a new operating system. This wouldn't help if installing a second os on a multi-boot system, but that's a separate case.

Edit: Here's the url for the ultimate boot cd (with darik's boot and nuke): http://www.ultimatebootcd.com/
« Last Edit: May 27, 2008, 05:09:01 am by VgnFrnd » Logged
Witek Mozga
Vectorite
***
Posts: 113



WWW
« Reply #8 on: May 28, 2008, 12:17:18 am »

"lilo error=Fatal: Either FIX-TABLE or IGNORE-TABLE must be specified"

I once had this issue on Slackware and , I guess, I booted the system using installation disc with what is prompted when you`re booting its install CD:

Code:
linux root=/dev/hda2 ro noinitrd

then I ran lilo with option ignore-table according to lilo manual:

Code:
-P {fix|ignore|<global-option>}
              Fix or ignore `corrupt' partition tables,  i.e.,  partition  tables
              with  linear  and cylinder/head/sector addresses that do not corre-
              spond.  Always try -P ignore first, as -P  fix  will  re-write  the
              partition table, possibly destroying all partitions on the disk.


It worked.



Logged

maywyk
Member
*
Posts: 3


« Reply #9 on: May 29, 2008, 02:23:49 am »

In order to check, if the LILO error issue was due to not set BOOT flag on ROOT partition, i've performed install on my home PC too. And still, LILO rose the same error. I can't imagine, how this can be connected with previous OS on that HDD partition - because it gets formatted. Moreover, for this install I've created new partition on Unalocated Space.

in / directory I found  liloerror :
"
Warning: Device 0x0340: Inconsistent partition table, 1st entry
  CHS address in PT:  353:0:1  -->  LBA (5670945)
  LBA address in PT:  449836065  -->  CHS (28001:0:1)
Fatal: Either FIX-TABLE or IGNORE-TABLE must be specified
If not sure, first try IGNORE-TABLE (-P ignore)
"

I am using Symon R3 as boot manager (it also generates MBR for every system boot). And CHS (28001:0:1) is the value, I've set in partition editor as beginning of Vector root partition.


Some other observations.
0) When installing, immediately after VECTOR LINUX CONFIGURATION dialog (as described in file:///F:/doc/manuals/vl5_installation_guide_en.html#configure), follows the dialog, where I was asked if I want to change default Keyboard Layout and Keyboard type (from pc-102). What is this for? I've already had 2 opportunities to change KEYMAP, and Keyboard type too. Does it affect the text-mode, or X-Window UI?  By the way, in the KEYMAP dialog, after selecting "ru" layout, I didn't manage to switch layout and test for correctness. What is the default <layout switch> hotkey (really, need that in both console and X-Window)?

1) When booting, the following appeared
"Performing Coldplugging
   /dev/.tmp-3-00: unknown volume type"

is it supposed to be this way ?

A bit later

"Caching fonts :                 FAILED"

I'have managed to break smth already ?

2) At KDM prompt
when provided wrong user login/password the appearing message "Login Failed" overlaps buttons

3) VASMCC didn't launch at all, without any messages - in HTOP process "gksu" loaded CPU for 2 seconds, then was gone

4) In LXDE: in lxApperance ( Menu->Settings->Appearence )  the program has to panels. When selecting theme/icon on the left side the right window refreshes to blank sometimes. I.e. nothing is dispalyed for current selection.

5) VASM->HARDWARE->KMAPSET
when choosing 'default', text file "Usage for Xdialog" is opened (if running X-Window; without it nothing happens)

6) In X File Explorer (Xfe): when mouse is positioned over column separator ( | ) or panel separator (vertical line) its cursor simply disappears. When dragging, both cursor and object icon disappear.


Vector has proven to be FAST: I did some stop-watch metering
1) Suse 9.3 (no tweaking)  boot to      X-Window with Window Maker         60 sec
2) Mandriva 2007.1            boot to      command prompt                   30 sec
3) Vector 5.9 Light             boot to       JWM (autologin)                             30 sec
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3178



« Reply #10 on: May 29, 2008, 03:37:41 am »


3) VASMCC didn't launch at all, without any messages - in HTOP process "gksu" loaded CPU for 2 seconds, then was gone
Can you try opening a terminal and starting vasmcc from there instead of launching from the menu?
Post the output of
Code:
ls -al /var/log/packages | grep -i vasmcc

4) In LXDE: in lxApperance ( Menu->Settings->Appearence )  the program has to panels. When selecting theme/icon on the left side the right window refreshes to blank sometimes. I.e. nothing is dispalyed for current selection.
This happens because the list also shows mouse pointer themes in the same place, thus, mouse pointer themes do not have icons for your desktop, so the right panel goes blank.... I will report this to the LXDE developers to get an opinion.

Vector has proven to be FAST: I did some stop-watch metering
1) Suse 9.3 (no tweaking)  boot to      X-Window with Window Maker         60 sec
2) Mandriva 2007.1            boot to      command prompt                   30 sec
3) Vector 5.9 Light             boot to       JWM (autologin)                             30 sec

That would make VL the fastest then... you've got a full blown desktop in 30 sec... that's pretty fast
Logged

maywyk
Member
*
Posts: 3


« Reply #11 on: May 30, 2008, 02:12:56 am »

Good Morning!
To MOE-lnx:

root:# vasmCC
gbr2: error while loading shared libraries: libffi.so.5: cannot open: No such file or directory

And output of that   ls -al /var/log/packages:
-rw-r--r--   1 root root 4221 2008-02-10 21:15 vasmCC-1.0.12-i586-3vl59

Finally, I've succeeded in installing LILO (just specified -P ignore). Next boot I was rewarded with bootsplash (Vector Light) and progress bar! However, after trying to switch bootsplash in VASM, I've got framebuffer console at next boot. Still, on shutdown the bootsplash remained. (issue #7)

Other obstacles on my Happy-VL trip:
Cool VXCONF->DEFAULT RESOLUTION:   very common 1680x1050  (22" LCD) is not listed
9) VASM->HARDWARE-> VL-HOT/HAL:  no reaction
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3178



« Reply #12 on: May 30, 2008, 03:43:29 am »

libffi is a dependancy to gambas2.
Please install it via slapt-get / gslapt
Logged

kc1di
Packager
Vectorian
****
Posts: 1125


Morse Code Early digital mode. John 3:16


« Reply #13 on: May 30, 2008, 03:58:30 am »

need Help with LXDE -- I really like this desktop in light.. but need to get more info.. i've tried googling it but no luck.

1. I would like to know how does one add a menu catagory-- I can add items manually just fine.. but so far haven't been able to figure out how to add a new catagory.

2.  Is there a way to configure the clock to show the seconds also?  if So how.

I'm sure I'll have more questions but would appreciate help with those 2 first.

the more I use Light the better I like it.
Cheers Dave


Logged

Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608
budulay
Packager
Vectorian
****
Posts: 568


NewComer


« Reply #14 on: May 30, 2008, 05:56:59 am »

Hi
Have a question:
I am using VL5.9 STD. Works pretty good with JWM, but I have to always worry about disk space, b/c have mall HDD.
Does it make sense for me to switch to VL Light 5.9 RC1?

Also have a question, does LXDE lighter than XFCE? Is there a lot of bugs in it?

Thanks a lot.
Logged

VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!
Pages: [1] 2 3
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!