VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Desktop 'xkill' ed [Solved]  (Read 2603 times)

Sivatheja

  • Vectorite
  • ***
  • Posts: 156
    • Banthigaadu
Desktop 'xkill' ed [Solved]
« on: June 20, 2008, 09:47:06 am »

Hi,

I 'xkill' ed my desktop. How  to  restore it?  :o
I typed 'xkill' in command prompt and then clicked on the desktop. Since then nothing shows up on the desktop even after restart! Everything is normal, but  the Desktop would not show up.

Any clue?

Curiously,
Sivatheja.
« Last Edit: August 04, 2008, 09:51:05 am by Sivatheja »
Logged
Full Linux Machine - Vector Linux 5.9 STD Gold, Intel - 1.79 GHz, 1Gb RAM, 60GB HDD

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: Desktop 'xkill' ed
« Reply #1 on: June 20, 2008, 09:50:31 am »

try run xfdesktop at CLI....
Logged

Sivatheja

  • Vectorite
  • ***
  • Posts: 156
    • Banthigaadu
Re: Desktop 'xkill' ed
« Reply #2 on: June 20, 2008, 10:04:34 am »

I've typed in xfdesktop in terminal (CLI = Terminal window, am I correct? )and desktop shows up along with the wallpaper, but when the terminal window is closed, the wall paper remains and t he icons on the desktop vanish.
Is there any way to xfdesktop on startup?

- Sivatheja
Logged
Full Linux Machine - Vector Linux 5.9 STD Gold, Intel - 1.79 GHz, 1Gb RAM, 60GB HDD

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: Desktop 'xkill' ed
« Reply #3 on: June 20, 2008, 10:07:08 am »

Did you enable save xfce session when logout? If yes, disable it and restart X again....
Logged

Sivatheja

  • Vectorite
  • ***
  • Posts: 156
    • Banthigaadu
Re: Desktop 'xkill' ed
« Reply #4 on: June 20, 2008, 10:27:24 am »

Yes, that 'save' option is enabled, but restart with that un checked still shows the desktop Black. The 'black' option must have already been saved in previous restarts with the check box checked.
Logged
Full Linux Machine - Vector Linux 5.9 STD Gold, Intel - 1.79 GHz, 1Gb RAM, 60GB HDD

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: Desktop 'xkill' ed
« Reply #5 on: June 20, 2008, 10:31:30 am »

Ok, is the xfce taskbar still there? If yes, click Menu -> Run Program. Type xfdesktop again. If it work, save the session again and logout. Login again and disable the save session.
Logged

Sivatheja

  • Vectorite
  • ***
  • Posts: 156
    • Banthigaadu
Re: Desktop 'xkill' ed
« Reply #6 on: June 20, 2008, 10:53:27 am »

Hammayya!

Eureka!! Got my lovely desktop back :D

Gratefully,
Sivatheja.
Logged
Full Linux Machine - Vector Linux 5.9 STD Gold, Intel - 1.79 GHz, 1Gb RAM, 60GB HDD

Masta

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 725
Re: Desktop 'xkill' ed
« Reply #7 on: July 02, 2008, 09:48:07 pm »

Sweet.
 Don't forget to edit this topic and add [Solved] so that others can benefit, and helpers can spot the unsolved ones easier. Thanks :)
Logged

Sivatheja

  • Vectorite
  • ***
  • Posts: 156
    • Banthigaadu
Re: Desktop 'xkill' ed [Solved]
« Reply #8 on: August 04, 2008, 09:51:44 am »

Done :)
Logged
Full Linux Machine - Vector Linux 5.9 STD Gold, Intel - 1.79 GHz, 1Gb RAM, 60GB HDD