VectorLinux
July 25, 2014, 05:26:07 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2 3
  Print  
Author Topic: Wireless Connection Problem  (Read 7204 times)
ng234
Member
*
Posts: 16


« on: May 27, 2008, 05:04:55 pm »

I have installed Vector 5.9 onto an Toshiba Portege 4000 laptop. It has been running fine but I am trying to use the wireless card and having no luck. I am quite new to Linux, but I have been picking it up quickly. Any ideas?

-Stewart
Logged
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #1 on: May 27, 2008, 05:10:48 pm »

pls tell what is the model/brand/chip of your wireless card?
give us the output of 'lspci', 'lsmod' and 'lspcmcia'......
Logged
ng234
Member
*
Posts: 16


« Reply #2 on: May 27, 2008, 05:18:06 pm »

I am not sure how to find the model/brand/chip of my wireless card -

LSPCI
00:00.0 Host bridge: ALi Corporation M1644/M1644T Northbridge+Trident (rev 01)
00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:04.0 IDE interface: ALi Corporation M5229 IDE (rev c3)
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 01)
00:07.0 ISA bridge: ALi Corporation M1533/M1535 PCI to ISA Bridge [Aladdin IV/V/V+]
00:08.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:0a.0 Ethernet controller: Intel Corporation 82557/8/9 Ethernet Pro 100 (rev 08)
00:10.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 01)
00:11.0 CardBus bridge: Toshiba America Info Systems ToPIC100 PCI to Cardbus Bridge with ZV Support (rev 32)
00:11.1 CardBus bridge: Toshiba America Info Systems ToPIC100 PCI to Cardbus Bridge with ZV Support (rev 32)
00:12.0 System peripheral: Toshiba America Info Systems SD TypA Controller (rev 03)
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade XPAi1 (rev 82)

LSMOD
Module                  Size  Used by
ndiswrapper           186372  0
ieee80211              31560  0
ieee80211_crypt         5504  1 ieee80211
e100                   33292  0
ohci1394               32432  0
ieee1394               82360  1 ohci1394
parport_pc             37092  0
parport                32072  1 parport_pc
acpi_cpufreq            7880  0
freq_table              4768  1 acpi_cpufreq
toshiba                 4632  0
snd_seq_dummy           3716  0
snd_seq_oss            32128  0
snd_seq_midi_event      7168  1 snd_seq_oss
snd_seq                48720  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7692  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            38048  0
snd_mixer_oss          15232  1 snd_pcm_oss
orinoco_cs             14596  1
orinoco                39060  1 orinoco_cs
hermes                  7168  2 orinoco_cs,orinoco
snd_ali5451            20108  2
snd_ac97_codec         98084  1 snd_ali5451
serio_raw               6276  0
ac97_bus                2944  1 snd_ac97_codec
snd_pcm                69764  3 snd_pcm_oss,snd_ali5451,snd_ac97_codec
eepro100               27664  0
snd_timer              19972  2 snd_seq,snd_pcm
snd                    45796  14 snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_ali5451,snd_ac97_codec,snd_pcm,snd_timer
mii                     5504  2 e100,eepro100
soundcore               7008  1 snd
snd_page_alloc          8712  1 snd_pcm
ali_agp                 6400  1
agpgart                28108  1 ali_agp
i2c_ali1535             6916  0
i2c_ali15x3             7556  0
i2c_core               20992  2 i2c_ali1535,i2c_ali15x3
shpchp                 30228  0
pci_hotplug            28616  1 shpchp
evdev                   8704  0

IWCONFIG
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11b  ESSID:"Murphy"  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.457 GHz  Access Point: None   
          Bit Rate:11 Mb/s   Sensitivity:1/3 
          Retry limit:4   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

LSPCMCIA
Socket 0 Bridge:        [yenta_cardbus]         (bus ID: 0000:00:10.0)
Socket 0 Device 0:      [orinoco_cs]            (bus ID: 0.0)
Socket 1 Bridge:        [yenta_cardbus]         (bus ID: 0000:00:11.0)
Socket 2 Bridge:        [yenta_cardbus]         (bus ID: 0000:00:11.1)
« Last Edit: May 27, 2008, 05:27:56 pm by ng234 » Logged
mutencillo
Member
*
Posts: 13


« Reply #3 on: May 27, 2008, 05:44:17 pm »

It seems to be well configured with ndiswrapper, though i continue without knowing the chipset (if it is usb prove it with lsusb). Doesn't router have wep password? If it has you can configure it with "iwconfig eth1 key s:X000134987510" (string key), and then try with "dhcpcd eth1" for take an IP. The last thing only if router has DHCP enabled. good luck
Logged

Vector Linux 5.9 Light RC1
Dell Latitude C610
P3 1000 128MB RAM 20GB HD
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #4 on: May 27, 2008, 06:11:06 pm »

I believe you already have the wireless driver install.......

Quote
orinoco                39060  1 orinoco_cs
hermes                  7168  2 orinoco_cs,orinoco

did you try to configure your wireless using VASM??

http://www.cl.cam.ac.uk/~pb22/portege4000.html#S0550
http://www.cs.helsinki.fi/linux/portege4000.html
http://www.it.uc3m.es/ptb/toshiba_portege_4000.html
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2276


« Reply #5 on: May 27, 2008, 09:31:51 pm »

and ndiswrapper is loaded as well, may be a conflict between orinoco and ndiswrapper modules?
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
ng234
Member
*
Posts: 16


« Reply #6 on: May 28, 2008, 05:02:27 am »

I open up VASM -> Network -> Wireless - and it asks me if I "would like to insert a windows driver into ndiswrapper and see if it works with your hardware." Then it takes Zenity ~30 seconds to load and takes me to the /usr/bin/ directory. I am unsure what to do at this point (find a windows driver to load through ndiswrapper? - how would I identify the windows driver?)

Thanks Everyone

Edit - according to those sites above (http://www.cl.cam.ac.uk/~pb22/portege4000.html#S0550 / http://www.cs.helsinki.fi/linux/portege4000.html / http://www.it.uc3m.es/ptb/toshiba_portege_4000.html) - they seem to use the orinoco drivers exclusively, is it an option to just use an orinoco driver for my wireless card, and not use ndiswrapper?
« Last Edit: May 28, 2008, 05:06:18 am by ng234 » Logged
ng234
Member
*
Posts: 16


« Reply #7 on: May 28, 2008, 05:16:44 am »

Going off the assumption that my settings are correct, as I use VLwifi it gives me the following prompts
1. wirless interface eth1 was found - lets set it up
2. wifi security (none, wep, wpa) - chose WPA
3. enter essid to connect - I entered my essid
4. add wpa passphrase - entered password for network
5. wifi options (start at boot, dhcp, static, set static DNS nameserver) - chose start at boot, dhcp

It pauses for a second and says "failed - could not obtain an address for wireless interface eth1"

At this point it closes and I am lost on how to proceed.
Logged
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #8 on: May 28, 2008, 05:27:29 am »

Do your wireless have security encryption enable? If yes then try to disable it and try again. I am not sure about VLwifi but usually I use wifi-radar to connect to my wireless.......
Logged
ng234
Member
*
Posts: 16


« Reply #9 on: May 28, 2008, 05:38:58 am »

I disabled my wifi security, and it continued to say "could not obtain an address for wireless interface eth1"
Logged
bigpaws
Vectorian
****
Posts: 1843


« Reply #10 on: May 28, 2008, 06:22:04 am »

You need to check some information. Open a console as root.

First post output of ndiswrapper -l   (that is a lower case L)

Next if ndiswrapper shows device then check to see if it is active:
ifconfig look for the wireless device.

Next try iwconfig eth1 <change to proper device name> essid "insert essid here without quotes"

Then check iwconfig that the essid is set correctly.

If so then use dhcpcd eth1 <change to proper device name>

Check ifconfig to see if there is an inet adress. If so try ping google.com

If any failures please post them.

Bigpaws
Logged
ng234
Member
*
Posts: 16


« Reply #11 on: May 28, 2008, 06:32:22 am »

NDISWRAPPER -l

root:# ndiswrapper -l
2802w : driver installed
80211stats : invalid driver!
airplus : driver installed
bcmwl5 : driver installed
gplus : driver installed
mrv8ka51 : driver installed
net8180 : driver installed
netadm11 : driver installed
netdlwl : driver installed
ntpr11ab : driver installed
w70n51 : driver installed

Do I have a problem with 80211stats driver?
« Last Edit: May 28, 2008, 06:34:58 am by ng234 » Logged
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #12 on: May 28, 2008, 09:32:43 am »

Ok. Let start all over again. Goto VASM -> Network -> Wireless -> DEL, delete any existing wireless setting. Then create a new wireless by choosing the ADD option. Key in the SSID and other information. Then check your ifconfig and iwconfig, ping your wireless access point to verify the connection.

btw, are you using an external wireless card?

From your system detail it seem you are using a orinoco based wireless card and I am using 1 too......

Quote
vector://home/hata_ph
root:# ndiswrapper -l
2802w : driver installed
airplus : driver installed
bcmwl5 : driver installed
gplus : driver installed
mrv8ka51 : driver installed
net8180 : driver installed
netadm11 : driver installed
netdlwl : driver installed
ntpr11ab : driver installed
w70n51 : driver installed
vector://home/hata_ph
root:# lsmod
Module                  Size  Used by
orinoco_cs             14596  1
orinoco                39060  1 orinoco_cs
hermes                  7168  2 orinoco_cs,orinoco
freq_table              4768  0
snd_seq_midi            7200  0
novmsplice              2572  0
snd_seq_dummy           3716  0
snd_seq_oss            32128  0
snd_seq_midi_event      7168  2 snd_seq_midi,snd_seq_oss
snd_seq                48720  6 snd_seq_midi,snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            38048  0
snd_mixer_oss          15232  1 snd_pcm_oss
snd_es1968             25216  2
gameport               12296  1 snd_es1968
i2c_piix4               8332  0
snd_ac97_codec         98084  1 snd_es1968
i2c_core               20992  1 i2c_piix4
ac97_bus                2944  1 snd_ac97_codec
snd_pcm                69764  3 snd_pcm_oss,snd_es1968,snd_ac97_codec
snd_timer              19972  2 snd_seq,snd_pcm
snd_page_alloc          8712  2 snd_es1968,snd_pcm
snd_mpu401_uart         7808  1 snd_es1968
snd_rawmidi            20128  2 snd_seq_midi,snd_mpu401_uart
snd_seq_device          7692  5 snd_seq_midi,snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd                    45796  16 snd_seq_dummy,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_es1968,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               7008  1 snd
eepro100               27664  0
radio_maestro           7424  0
videodev               26880  1 radio_maestro
mii                     5504  1 eepro100
v4l2_common            16256  1 videodev
serio_raw               6276  0
v4l1_compat            14468  1 videodev
compat_ioctl32          2176  1 radio_maestro
joydev                  9152  0
evdev                   8704  0
vector://home/hata_ph
root:# lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (AGP disabled) (rev 03)
00:04.0 CardBus bridge: Texas Instruments PCI1211
00:05.0 VGA compatible controller: ATI Technologies Inc 3D Rage LT Pro (rev dc)
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
00:08.0 Multimedia audio controller: ESS Technology ES1978 Maestro 2E (rev 10)
00:09.0 Ethernet controller: Intel Corporation 82557/8/9 Ethernet Pro 100 (rev 09)
00:09.1 Serial controller: Agere Systems LT WinModem
vector://home/hata_ph
root:# lspcmcia
Socket 0 Bridge:        [yenta_cardbus]         (bus ID: 0000:00:04.0)
Socket 0 Device 0:      [orinoco_cs]            (bus ID: 0.0)

Above is how i connect to my wireless access point, all using VASM. Maybe you can try it. Pls let us know the result.
Logged
ng234
Member
*
Posts: 16


« Reply #13 on: May 29, 2008, 05:25:25 am »

After looking at my lspci, and recognizing that the Portege 4000 has a cardbus, plus hata-ph asking what kind of wireless card I have (internal/external) I realize that I am a bit of a dope. I am used to internal wireless cards, but I am assuming since there is a cardbus port that the wireless card should go in there - but when I received this laptop from a friend a few weeks ago it didn't come with one, so I have been trying to connect without a wireless card...oh boy.

Does anyone know how I could determine what sort of cardbus wireless card works best with my hardware and Vector Linux, and where I can purchase it at a minimal price?

Thanks,
Stewart
Logged
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #14 on: May 29, 2008, 06:44:02 am »

does your laptop have a build in wireless devices?
Logged
Pages: [1] 2 3
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!