VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Enable automatic login...  (Read 2057 times)

avantgardaclue

  • Member
  • *
  • Posts: 7
Enable automatic login...
« on: May 29, 2008, 01:26:17 am »

Hi guys, new to vector, 3 years an ubuntu user but time to move on!

Just wondering if there is an 'automatic login' function? There's only me using the system so i really don't need to login with password every time i boot up.

thanks... Simon
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3237
Re: Enable automatic login...
« Reply #1 on: May 29, 2008, 04:43:51 am »

Question is answered here
http://www.vectorlinux.com/forum2/index.php?topic=2913.0


NOTE
The path to kdmrc has changed, so instead of editing /opt/kde/share/config/kdm/kdmrc
you need to edit /usr/share/config/kdm/kdmrc
Other than that, the procedure is the same

Welcome to vl
« Last Edit: May 29, 2008, 04:46:06 am by M0E-lnx »
Logged

avantgardaclue

  • Member
  • *
  • Posts: 7
Re: Enable automatic login...
« Reply #2 on: May 29, 2008, 06:01:31 am »

Thanks Moe. I'm certain i don't have KDE on this machine so following the instructions you kindly pointed me to i edited the inittab file accordingly.... (setting the default level to 7)

>>In case you dont want to launch the heavy KDM just for this ...

Edit /etc/inittab.
Change the default run level to 7 or 8.

To change the default user,
edit /etc/rc.d/rc.A.
Change the user id from 1000 to whoever you wish.

p.s: Not sure if this is still valid (it was in VL Dynamite 5.9.x)<<

Simple enough you might think!!?

>>Use of this method on VL 5.8 standard causes system to hang on boot up when starting services for Run Level 8.  However the method described for editing the kdmrc file does work flawlessly...<<

Hmmm, well it's caused my system to hang too! How do I login now that the gui has not booted? PLEASE!!!!

thanx
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4109
Re: Enable automatic login...
« Reply #3 on: May 29, 2008, 06:04:23 am »

Wild guess.. your other post mentions that Opera was installed by default. That indicates that you have VL Light. In Light B5 and later, you should see a menu entry "KDM Autologin" that will do this for you.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4109
Re: Enable automatic login...
« Reply #4 on: May 29, 2008, 06:05:32 am »

Hmmm, well it's caused my system to hang too! How do I login now that the gui has not booted? PLEASE!!!!

Can you select linux-tui from the boot menu?
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3237
Re: Enable automatic login...
« Reply #5 on: May 29, 2008, 06:07:29 am »

The fact of the matter is that if you have VL 5.8 STD or later, you may not have KDE, but you do have KDM (unless you removed it yourself)

So the instructions will still work ;)

avantgardaclue

  • Member
  • *
  • Posts: 7
Re: Enable automatic login...
« Reply #6 on: May 29, 2008, 06:23:05 am »

Hmmm, well it's caused my system to hang too! How do I login now that the gui has not booted? PLEASE!!!!

Can you select linux-tui from the boot menu?

Hi Nightflier, yes have tried linux-tui, got to the stage where i key my name in and my password. At the nest prompt went startxfce4  which came up with some old guff... fatal server error: no screens found. giving up.  Data incomplete in file /etc/X11/xorg.conf


Tried again going startx... same thing, hmmmmm!
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4109
Re: Enable automatic login...
« Reply #7 on: May 29, 2008, 06:58:38 am »

If you can log in to the command line you are in good shape.

First undo the changes that made your system hang. "mcedit /etc/inittab" should get you there. Make the changes, hit F2 to save, F10 to exit.

Next, try "vasm", continue to xwindow > xconf to see if you can fix your GUI.

Which VL version are you running?
Logged

avantgardaclue

  • Member
  • *
  • Posts: 7
British English Keyboards
« Reply #8 on: May 29, 2008, 09:51:13 am »

Hi Nightflier,
Can't be doing with all this... however what i saw of vector definitely suggested to me that i should persevere so i downloaded the gold iso and installed over the top.... fan dabby dozy... love it!

One thing though... how on earth do you get it to accept a British English keyboard?!?

thanks... Simon
Logged

avantgardaclue

  • Member
  • *
  • Posts: 7
Re: Enable automatic login...
« Reply #9 on: May 29, 2008, 09:57:44 am »

The fact of the matter is that if you have VL 5.8 STD or later, you may not have KDE, but you do have KDM (unless you removed it yourself)

So the instructions will still work ;)

Thanks for this Moe, i decided to download the 5.9 Gold ver of Vector though where this KDM thing is i dunno, looked through all the menus, typed kdm into a terminal, but alas it is determined to stay hidden!

Simon
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3237
Re: Enable automatic login...
« Reply #10 on: May 29, 2008, 10:11:48 am »

KDM will not be on the menu, KDM gets launched by xorg I believe, but it's a good thing that you're upgrading to 5.9 gold ;)
although, you could have made it work on 5.8 too