VectorLinux
August 23, 2014, 01:05:03 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: TV out for tui  (Read 1482 times)
brig001
Member
*
Posts: 31


« on: May 27, 2008, 11:29:33 am »

Hi.  I hope someone can help me with this.  I am running VL 5.9 on a VIA mini ITX.  It is hooked to my TV via the composite TV out on the mobo.

The problem I have is that after coldplugging, the TV screen becomes scrambled even though a connected monitor is fine  (a bit like the horizontal hold has gone).  When I have logged in (I am booting into tui mode), then startx, the gui is fine.  Is there a way to set the graphics mode for the tui login?

Thanks.

Edit:
I think that this has something to do with choosing an option during installation where more characters would be displayed in tui mode and there would be a penguin on the login screen.  I think that I need to undo this.
« Last Edit: May 27, 2008, 01:01:43 pm by brig001 » Logged
brig001
Member
*
Posts: 31


« Reply #1 on: June 02, 2008, 03:14:50 pm »

I think this is something to do with framebuffer.  My graphics card doesn't support this, so I need to disable framebuffer mode for the TUI / console.

I have vga = normal in lilo.conf, so it should boot like this, but it doesn't.  Could this be something to do with bootsplash?  If so, please can someone tell me how to disable it.

Thanks,
Brian.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4019



« Reply #2 on: June 02, 2008, 04:40:00 pm »

If you run vasm > filesystem > lilo > ... you should get to a selector for boot splash or not. The top entry (safe choice) should give you standard VGA output.
Logged
brig001
Member
*
Posts: 31


« Reply #3 on: June 03, 2008, 10:03:54 am »

Thanks for your quick reply.  Unfortunately, the only thing that changed was the lilo boot selection screen.  The video mode still changes after "performing coldplugging" to one that my TV cannot display.  Is there a setting for this display mode?
Logged
brig001
Member
*
Posts: 31


« Reply #4 on: June 07, 2008, 10:55:31 pm »

I've done a bit more digging now and by adding echos and sleeps everrywhere, found the line in rc.udev which causes the problem:

/sbin/udevtrigger && /sbin/udevsettle

when this line runs, the video mode changes to a higher resolution*, but the settings are obviously wrong for my TV.
Don't know what is wrong with it or how to fix it, anyone got any ideas?

Edit: * may be higher - it's difficult to tell.
« Last Edit: June 08, 2008, 07:58:24 am by brig001 » Logged
brig001
Member
*
Posts: 31


« Reply #5 on: June 10, 2008, 11:39:02 am »

It seems I am not alone:
http://www.linuxquestions.org/questions/slackware-14/slack-11-acpi-and-udevsettle-problem-504032/
http://ohioloco.ubuntuforums.org/showthread.php?p=5077994
There was another on these forums, but I can't find it now.

I had selected standard vga during the installation and had checked that vga=normal was in lilo.conf.

When udevsettle (Performing coldplugging) was running, the screen mode changed.  In desperation, I changed lilo.conf to vga=771 (800x600x256), the screen mode doesn't change at all during boot and TV out works as it should.  I also see the penguin now - cute.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!