Author Topic: Konqueror: Bus error  (Read 3868 times)


  • Vectorite
  • ***
  • Posts: 115
Konqueror: Bus error
« on: June 03, 2008, 11:59:05 am »

This weekend, i removed XP from my computer. Reason is I don't need my win only printer anymore for school, and xp started to do weird crashes. The screen just froze and only the button could help me out.
I installed vector, but the problem didn't fade away. I had to do numerous button reboots, and suddenly it disappeared. My computer just kept on going like a madman.

About the crashes:
~ The screen would just freeze (and no ctrl - alt - backspace) would work
~ Everything inside the pc was still running. The hd was still writing from time to time so its not a failed hd

So I blamed the GPU (Nvidia gf 7600 gs)

As the problem was gone, I started installing my desktop. I installed KDE 3.5.9 instead of XFCE, and so far everything works fine, but then today I tried to open konqueror for the first time and I got this error:

Code: [Select]
joachim:$ konqueror
QMultiInputContext::changeInputMethod(): index=0, slave=xim
Bus error

I reinstalled most KDE packages but that didn't work. Reinstalling GTK didn't solve the problem either.
Then I saw this on a mailing list:
The last time I saw a bus error, my nvidia card was dieing, and it
took the mobo with it.  Not saying thats whats wrong with yours, but
keep it in mind.

So in short terms: Is my GPU RIP?


  • Member
  • *
  • Posts: 6
Re: Konqueror: Bus error
« Reply #1 on: June 04, 2008, 02:50:30 pm »
Dont wanna crush your heart either, but I also had similar things going on when my nVidia (hm..any ATI experience here..) dieeddd.
Actually I first feared the whole mobo was dead, so nothing but a relief went through me, when it started to boot after I  exchanged the geforce with an old 4mb card.
The system was a little on and off. Probably due to some temp/load factor. Forced reboots needed suddenly. But do not throw anything before you checked a good number of times. Have vga on your mobo ? Havent tried to take it out yet ?


  • Global Moderator
  • Vectorian
  • *****
  • Posts: 729
Re: Konqueror: Bus error
« Reply #2 on: June 04, 2008, 07:26:46 pm »
One thing you can do before assuming the worst is:
Check in your BIOS for a setting that allows to "reset configuration data" (turn it on, reboot)

After rebooting, go back into the bios and make sure everything is as they should be, reboot again, and if symptoms still occur , you're probably headed for some type of hardware error, whether or not it's the video card, I can't be sure, but gathering from your information, it seems most logical.

P.S. I have saved one system, in the past, which give very similar symptoms , by re-installing the bios (flash),  everything was back to normal after that, and the card was fine. I'm not recommending you re flash your bios unless you know exactly what you're doing, and it should certainly be a last resort (I'd recommend replacing the card  instead, especially if you don't have a backup system).


  • Vectorite
  • ***
  • Posts: 115
Re: Konqueror: Bus error
« Reply #3 on: June 05, 2008, 03:33:19 am »
For now it's all running fine again, the only app in kde that still doesn't want to run is konqueror, all the rest works fine, no more freezes either. I don't get it.

I'll run some day in the bios and attempt your fixes masta, for big hardware replacement I have not much time now (end exams :()

I'll keep this updated.

edit: My bios does not support advanced computing. No reset options available. I unplugged the power cable and pressed the power button, everything but konqueror works.
« Last Edit: June 05, 2008, 03:46:48 am by Xeon »