Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: no tbird icon on Lxde lxpanel on 5.9 light (solved)  (Read 1517 times)


  • Member
  • *
  • Posts: 15
no tbird icon on Lxde lxpanel on 5.9 light (solved)
« on: June 06, 2008, 04:45:26 pm »

I recently installed vl5.9 light and I am using the LXDE desktop. Everything works fine except the launchbar icon for thunderbird disappeared the first time I rebooted. I've tried everything I can think of including pointing the icon string in the config file in /usr/share/applications to a different icon.
anybody have any suggestions?  btw, congrats to the 5.9 developer team, this version of VL is very fast, Thanks

I was on the right track when I pointed the icon string to a different icon. What worked for me was to change the icons=/usr/share/pixmaps/  string
to /usr/lib/thunderbird/icons/mozicon50.xpm      Worked for me, if you run across this problem you can access the destop config file by rt click on the name in /usr/share/applications

« Last Edit: June 06, 2008, 05:33:47 pm by roywhite »
VL ADDICT-running 5.8


  • Vectorian
  • ****
  • Posts: 1369
Re: no tbird icon on Lxde lxpanel on 5.9 light (solved)
« Reply #1 on: June 06, 2008, 06:09:52 pm »

Glad you found the solution..In addition to thunderbird there is now also claws-mail..and I Just did the icon for that in a similar fashion on vl-light for the lxde panel..definately a nice distro..I have tinyme2008 and puppy dingo and find the vl-light beta a better out of the box experience although they all have little issues..I think that is unescapable in computeing
Everything Is Relative


  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: no tbird icon on Lxde lxpanel on 5.9 light (solved)
« Reply #2 on: June 06, 2008, 08:23:31 pm »

Whoops! My fault.  I included a /usr/share/pixmaps/thunderbird.xpm
But the desktop file calls for a /usr/share/pixmaps/thunderbird.png

Completely wrong. But oddly, in Xfce (which is what I always use), it shows correctly.  So I never noticed. Thunderbird is overdue for another release, I'll wait to fix the problem until then.

Thanks for pointing that out.